summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-09 09:20:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-09 09:20:00 +0000
commit1b28dcc60c56c2a235bc026bd5dbddca484b5a14 (patch)
tree242124217076bfa206094283899af24bd542a4a4 /dev-dotnet/evolution-sharp/files
parentRemove old versions (diff)
downloadgentoo-2-1b28dcc60c56c2a235bc026bd5dbddca484b5a14.tar.gz
gentoo-2-1b28dcc60c56c2a235bc026bd5dbddca484b5a14.tar.bz2
gentoo-2-1b28dcc60c56c2a235bc026bd5dbddca484b5a14.zip
Add a patch to properly respect libdir; before the pkg-config file was updated by the installed files were still in /usr/lib rather than /usr/lib64. Submitted as upstream bug #559977.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-dotnet/evolution-sharp/files')
-rw-r--r--dev-dotnet/evolution-sharp/files/evolution-sharp-0.18.0-respectlibdir.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-dotnet/evolution-sharp/files/evolution-sharp-0.18.0-respectlibdir.patch b/dev-dotnet/evolution-sharp/files/evolution-sharp-0.18.0-respectlibdir.patch
new file mode 100644
index 000000000000..ee6b6311b5f8
--- /dev/null
+++ b/dev-dotnet/evolution-sharp/files/evolution-sharp-0.18.0-respectlibdir.patch
@@ -0,0 +1,35 @@
+Index: evolution-sharp-0.18.0/evolution/Makefile.am
+===================================================================
+--- evolution-sharp-0.18.0.orig/evolution/Makefile.am
++++ evolution-sharp-0.18.0/evolution/Makefile.am
+@@ -92,14 +92,14 @@ all: $(ASSEMBLY) $(TEST_TARGETS)
+
+ install-data-local:
+ @if test -n '$(TARGET)'; then \
+- echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE) /root $(DESTDIR)$(prefix)/lib"; \
+- $(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE) /root $(DESTDIR)$(prefix)/lib || exit 1; \
++ echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE) /root $(DESTDIR)$(libdir)"; \
++ $(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE) /root $(DESTDIR)$(libdir) || exit 1; \
+ fi
+
+ uninstall-local:
+ @if test -n '$(TARGET)'; then \
+- echo "$(GACUTIL) /u $(ASSEMBLY_NAME) /package $(PACKAGE) /root $(DESTDIR)$(prefix)/lib"; \
+- $(GACUTIL) /u $(ASSEMBLY_NAME) /package $(PACKAGE) /root $(DESTDIR)$(prefix)/lib || exit 1; \
++ echo "$(GACUTIL) /u $(ASSEMBLY_NAME) /package $(PACKAGE) /root $(DESTDIR)$(libdir)"; \
++ $(GACUTIL) /u $(ASSEMBLY_NAME) /package $(PACKAGE) /root $(DESTDIR)$(libdir) || exit 1; \
+ fi
+
+ evolution-sharp.snk: $(top_srcdir)/evolution-sharp.snk
+Index: evolution-sharp-0.18.0/evolution-sharp.pc.in
+===================================================================
+--- evolution-sharp-0.18.0.orig/evolution-sharp.pc.in
++++ evolution-sharp-0.18.0/evolution-sharp.pc.in
+@@ -1,5 +1,6 @@
+ prefix=@prefix@
+-libdir=${prefix}/lib
++exec_prefix=@exec_prefix@
++libdir=@libdir@
+
+ Name: Evolution#
+ Description: Evolution# - Evolution .NET Binding