summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-03-01 02:52:22 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-03-01 02:52:22 +0000
commitfafe6933b78589f33e439d9b4fd8f98464e01f47 (patch)
tree8491e4c42bc32a846700c8d90f17617003727988 /dev-db
parentVersion bump for beta channel release. (diff)
downloadgentoo-2-fafe6933b78589f33e439d9b4fd8f98464e01f47.tar.gz
gentoo-2-fafe6933b78589f33e439d9b4fd8f98464e01f47.tar.bz2
gentoo-2-fafe6933b78589f33e439d9b4fd8f98464e01f47.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/ChangeLog8
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.2.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index cc2bc1684037..266ce7d46b6f 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.75 2012/02/21 02:42:51 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.76 2012/03/01 02:52:22 titanofold Exp $
+
+*pgadmin3-1.14.2 (01 Mar 2012)
+
+ 01 Mar 2012; Aaron W. Swenson <titanofold@gentoo.org>
+ +pgadmin3-1.14.2.ebuild:
+ Version bump.
21 Feb 2012; Aaron W. Swenson <titanofold@gentoo.org>
pgadmin3-1.12.3-r1.ebuild, pgadmin3-1.14.0.ebuild, pgadmin3-1.14.1.ebuild,
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.2.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.2.ebuild
new file mode 100644
index 000000000000..d6d2f5c2bc8a
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.14.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.2.ebuild,v 1.1 2012/03/01 02:52:22 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}