summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-12 20:06:27 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-12 20:06:27 +0000
commitf872bfc3838f550724059180059c1682bf757a5f (patch)
treed2c2229745767a4173af30195617e66831677e44 /dev-db
parentMask nano-2.3.3 as it fails to build with USE=-unicode, bug #512064 (diff)
downloadgentoo-2-f872bfc3838f550724059180059c1682bf757a5f.tar.gz
gentoo-2-f872bfc3838f550724059180059c1682bf757a5f.tar.bz2
gentoo-2-f872bfc3838f550724059180059c1682bf757a5f.zip
Enable multilib support, needed by sys-fs/samba.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/ctdb/ChangeLog9
-rw-r--r--dev-db/ctdb/ctdb-1.13-r1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-db/ctdb/ChangeLog b/dev-db/ctdb/ChangeLog
index c8a10d2106fa..39830afe25d2 100644
--- a/dev-db/ctdb/ChangeLog
+++ b/dev-db/ctdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/ctdb
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/ctdb/ChangeLog,v 1.37 2013/11/07 03:15:25 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/ctdb/ChangeLog,v 1.38 2014/06/12 20:06:27 mgorny Exp $
+
+*ctdb-1.13-r1 (12 Jun 2014)
+
+ 12 Jun 2014; Michał Górny <mgorny@gentoo.org> +ctdb-1.13-r1.ebuild:
+ Enable multilib support, needed by sys-fs/samba.
07 Nov 2013; Patrick Lauer <patrick@gentoo.org> ctdb-1.0.114_p1.ebuild,
ctdb-1.0.73.ebuild, ctdb-1.0.88.ebuild:
diff --git a/dev-db/ctdb/ctdb-1.13-r1.ebuild b/dev-db/ctdb/ctdb-1.13-r1.ebuild
new file mode 100644
index 000000000000..7c1d92048e72
--- /dev/null
+++ b/dev-db/ctdb/ctdb-1.13-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/ctdb/ctdb-1.13-r1.ebuild,v 1.1 2014/06/12 20:06:27 mgorny Exp $
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="A cluster implementation of the TDB database used to store temporary data."
+HOMEPAGE="http://ctdb.samba.org/"
+# upstream is too sexy for releases, grab tags from:
+# http://git.samba.org/?p=ctdb.git;a=summary
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/popt[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ldflags.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ epatch_user
+
+ # custom, broken Makefile
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir="${EPREFIX}/var/lib" \
+ --with-logdir="${EPREFIX}/var/log/${PN}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dohtml web/* doc/*.html
+}