summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2010-03-13 18:33:39 +0000
committerJesus Rivero <neurogeek@gentoo.org>2010-03-13 18:33:39 +0000
commitf72a4a82598c281199259428566b6e38bef867de (patch)
treea5c88073a5d9c42e51d46b67e084f6bdf73bae21 /dev-db
parentRename local variable. (diff)
downloadgentoo-2-f72a4a82598c281199259428566b6e38bef867de.tar.gz
gentoo-2-f72a4a82598c281199259428566b6e38bef867de.tar.bz2
gentoo-2-f72a4a82598c281199259428566b6e38bef867de.zip
Initial commit. Closes bug #290160
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/desktopcouch/ChangeLog11
-rw-r--r--dev-db/desktopcouch/desktopcouch-0.6.1.ebuild49
-rw-r--r--dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch23
-rw-r--r--dev-db/desktopcouch/metadata.xml9
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-db/desktopcouch/ChangeLog b/dev-db/desktopcouch/ChangeLog
new file mode 100644
index 000000000000..a3668f5e375f
--- /dev/null
+++ b/dev-db/desktopcouch/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-db/desktopcouch
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/ChangeLog,v 1.1 2010/03/13 18:33:38 neurogeek Exp $
+
+*desktopcouch-0.6.1 (13 Mar 2010)
+
+ 13 Mar 2010; Jesus Rivero <neurogeek@gentoo.org>
+ +desktopcouch-0.6.1.ebuild, +files/desktopcouch-setup_hardlinks.patch,
+ +metadata.xml:
+ Initial commit. Closes bug #290160.
+
diff --git a/dev-db/desktopcouch/desktopcouch-0.6.1.ebuild b/dev-db/desktopcouch/desktopcouch-0.6.1.ebuild
new file mode 100644
index 000000000000..585570851454
--- /dev/null
+++ b/dev-db/desktopcouch/desktopcouch-0.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/desktopcouch-0.6.1.ebuild,v 1.1 2010/03/13 18:33:38 neurogeek Exp $
+
+PYTHONDEPEND="2"
+EAPI="2"
+
+inherit distutils
+inherit eutils
+
+DESCRIPTION="Desktop-oriented interface to CouchDB"
+HOMEPAGE="https://launchpad.net/desktopcouch"
+SRC_URI="http://launchpad.net/desktopcouch/trunk/${PV}/+download/${P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-python/python-distutils-extra-2.12"
+RDEPEND=">=dev-db/couchdb-0.10.0
+ >=dev-python/gnome-keyring-python-2.22.3-r1
+ >=dev-python/couchdb-python-0.6
+ >=dev-python/oauth-1.0.1
+ >=dev-python/simplejson-2.0.9-r1
+ >=dev-python/twisted-8.2.0-r2
+ >=net-dns/avahi-0.6.24-r2[python]"
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-setup_hardlinks.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ exeinto "${ROOT}/usr/lib/${PN}"
+ doexe "/usr/lib/desktopcouch/desktopcouch-stop"
+ doexe "/usr/lib/desktopcouch/desktopcouch-service"
+
+ if use doc; then
+ insinto "${ROOT}/usr/share/doc/${PF}/api"
+ doins "desktopcouch/records/doc/records.txt"
+ doins "desktopcouch/records/doc/field_registry.txt"
+ doins "desktopcouch/contacts/schema.txt"
+
+ doman "docs/man/desktopcouch-pair.1"
+ fi
+
+}
diff --git a/dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch b/dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch
new file mode 100644
index 000000000000..40d12b4205d3
--- /dev/null
+++ b/dev-db/desktopcouch/files/desktopcouch-setup_hardlinks.patch
@@ -0,0 +1,23 @@
+--- setup.py.orig 2010-03-12 22:30:22.000000000 +0000
++++ setup.py 2010-03-12 22:42:57.000000000 +0000
+@@ -31,18 +31,11 @@
+ test_suite="runtests.get_test_suite",
+ packages=find_packages(),
+ scripts=['bin/desktopcouch-pair'],
+- data_files = [('/usr/lib/desktopcouch/', ['bin/desktopcouch-service',
+- 'bin/desktopcouch-stop']),
+- # Be sure all additions are reflected in MANIFEST.in !
+- ('/usr/share/doc/python-desktopcouch-records/api/',
+- ['desktopcouch/records/doc/records.txt',
+- 'desktopcouch/records/doc/field_registry.txt',
+- 'desktopcouch/contacts/schema.txt']),
++ data_files = [# Be sure all additions are reflected in MANIFEST.in !
+ ('/etc/xdg/desktop-couch/',
+ ['config/desktop-couch/compulsory-auth.ini']),
+ ('/usr/share/desktopcouch/', ['data/couchdb.tmpl']),
+- ('/usr/share/dbus-1/services/', ['org.desktopcouch.CouchDB.service']),
+- ('share/man/man1/', ['docs/man/desktopcouch-pair.1'])],
++ ('/usr/share/dbus-1/services/', ['org.desktopcouch.CouchDB.service']),],
+ cmdclass = { "build" : build_extra.build_extra,
+ "build_i18n" : build_i18n.build_i18n }
+ )
diff --git a/dev-db/desktopcouch/metadata.xml b/dev-db/desktopcouch/metadata.xml
new file mode 100644
index 000000000000..2ea988a46e81
--- /dev/null
+++ b/dev-db/desktopcouch/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+</pkgmetadata>