summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-19 01:57:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-19 01:57:02 +0000
commitec638647aa8a7e9c4a19c9aae175a8209a6ff290 (patch)
tree14fdfc388f7e4d0f21d60318774efac7d78165d7 /dev-db
parentfix pear include paths #45068 (diff)
downloadgentoo-2-ec638647aa8a7e9c4a19c9aae175a8209a6ff290.tar.gz
gentoo-2-ec638647aa8a7e9c4a19c9aae175a8209a6ff290.tar.bz2
gentoo-2-ec638647aa8a7e9c4a19c9aae175a8209a6ff290.zip
fix autogen funk #44980
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/edb/edb-1.0.3.ebuild37
-rw-r--r--dev-db/edb/files/autogen.sh39
2 files changed, 12 insertions, 64 deletions
diff --git a/dev-db/edb/edb-1.0.3.ebuild b/dev-db/edb/edb-1.0.3.ebuild
index 705bebbf9a15..938b62f247f2 100644
--- a/dev-db/edb/edb-1.0.3.ebuild
+++ b/dev-db/edb/edb-1.0.3.ebuild
@@ -1,39 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/edb/edb-1.0.3.ebuild,v 1.11 2003/07/24 00:39:50 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/edb/edb-1.0.3.ebuild,v 1.12 2004/03/19 01:56:42 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Enlightment Data Base"
+HOMEPAGE="http://enlightenment.org/"
SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.gz"
-HOMEPAGE="http://enlightenment.org"
-SLOT="0"
+
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
-RDEPEND="virtual/glibc"
-
-DEPEND="$RDEPEND
- sys-apps/which"
-
-src_unpack() {
- unpack ${A}
- cp ${FILESDIR}/autogen.sh ${S}
- chmod +x ${S}/autogen.sh
-}
+DEPEND="virtual/glibc"
src_compile() {
- ./autogen.sh --host=${CHOST} \
- --prefix=/usr \
- --enable-compat185 \
- --enable-dump185 \
- --enable-cxx
- assert
-
+ econf \
+ --enable-compat185 \
+ --enable-dump185 \
+ || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
- dodoc AUTHORS COPYING README
+ dodoc AUTHORS README
}
diff --git a/dev-db/edb/files/autogen.sh b/dev-db/edb/files/autogen.sh
deleted file mode 100644
index 4c1a662b02da..000000000000
--- a/dev-db/edb/files/autogen.sh
+++ /dev/null
@@ -1,39 +0,0 @@
-#! /bin/sh
-
-srcdir=`dirname $0`
-test -z "$srcdir" && srcdir=.
-
-THEDIR="`pwd`"
-cd "$srcdir"
-DIE=0
-
-abort () {
- echo "$1 not found or command failed. Aborting!"
- exit 1
-}
-
-set -x
-aclocal || abort "aclocal"
-libtoolize --ltdl --force --copy || abort "libtoolize"
-autoheader || abort "autoheader"
-automake --foreign --add-missing || abort "automake"
-autoconf || abort "autoconf"
-
-if test -z "$*"; then
- echo "I am going to run ./configure with no arguments - if you wish "
- echo "to pass any to it, please specify them on the $0 command line."
-fi
-
-cd "$THEDIR"
-
-$srcdir/configure "$@" || abort "configure"
-
-set +x
-
-echo "Now type:"
-echo
-echo "make"
-echo "make install"
-echo
-echo "have fun."
-