summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-05-06 07:56:32 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-05-06 07:56:32 +0000
commiteba92170be4fc67d533ab40846f37a318b6ca219 (patch)
treecf38456a16c74a44414f9a8e16634354325c383f /dev-db
parentversion bump (diff)
downloadgentoo-2-eba92170be4fc67d533ab40846f37a318b6ca219.tar.gz
gentoo-2-eba92170be4fc67d533ab40846f37a318b6ca219.tar.bz2
gentoo-2-eba92170be4fc67d533ab40846f37a318b6ca219.zip
Version bump redis to 2.2.6.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/ChangeLog7
-rw-r--r--dev-db/redis/redis-2.2.6.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index df38d02bf83b..9ccdfaca5e2c 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.14 2011/05/06 07:00:22 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.15 2011/05/06 07:56:32 djc Exp $
+
+*redis-2.2.6 (06 May 2011)
+
+ 06 May 2011; Dirkjan Ochtman <djc@gentoo.org> +redis-2.2.6.ebuild:
+ Version bump to 2.2.6.
06 May 2011; Dirkjan Ochtman <djc@gentoo.org> -files/configure.ac-1.02:
And one more.
diff --git a/dev-db/redis/redis-2.2.6.ebuild b/dev-db/redis/redis-2.2.6.ebuild
new file mode 100644
index 000000000000..a9fa25363365
--- /dev/null
+++ b/dev-db/redis/redis-2.2.6.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.2.6.ebuild,v 1.1 2011/05/06 07:56:32 djc Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A persistent caching system, key-value and data structures database."
+HOMEPAGE="http://code.google.com/p/redis/"
+SRC_URI="http://redis.googlecode.com/files/${PN}-${PV/_/-}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
+IUSE="tcmalloc test"
+SLOT="0"
+
+RDEPEND=""
+DEPEND=">=sys-devel/autoconf-2.63
+ tcmalloc? ( dev-util/google-perftools )
+ test? ( dev-lang/tcl )
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+REDIS_PIDDIR=/var/run/redis/
+REDIS_PIDFILE=${REDIS_PIDDIR}/redis.pid
+REDIS_DATAPATH=/var/lib/redis
+REDIS_LOGPATH=/var/log/redis
+REDIS_LOGFILE=${REDIS_LOGPATH}/redis.log
+
+pkg_setup() {
+ enewgroup redis 75 || die "problem adding 'redis' group"
+ enewuser redis 75 -1 ${REDIS_DATAPATH} redis || die "problem adding 'redis' user"
+ # set tcmalloc-variable for the build as specified in
+ # https://github.com/antirez/redis/blob/2.2/README. If build system gets
+ # better integrated into autotools, replace with append-flags and
+ # append-ldflags in src_configure()
+ use tcmalloc && export EXTRA_EMAKE="${EXTRA_EMAKE} USE_TCMALLOC=yes"
+}
+
+src_prepare() {
+ # now we will rewrite present Makefiles
+ local makefiles=""
+ for MKF in $(find -name 'Makefile' | cut -b 3-); do
+ mv "${MKF}" "${MKF}.in"
+ sed -i -e 's:$(CC):@CC@:g' \
+ -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
+ -e 's: $(DEBUG)::g' \
+ -e 's:$(OBJARCH)::g' \
+ -e 's:ARCH:TARCH:g' \
+ -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
+ "${MKF}.in" \
+ || die "Sed failed for ${MKF}"
+ makefiles+=" ${MKF}"
+ done
+ # autodetection of compiler and settings; generates the modified Makefiles
+ cp "${FILESDIR}"/configure.ac-2.2 configure.ac
+ sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
+ configure.ac || die "Sed failed for configure.ac"
+ eautoconf
+}
+
+src_install() {
+ # configuration file rewrites
+ insinto /etc/
+ sed -r \
+ -e "/^pidfile\>/s,/var.*,${REDIS_PIDFILE}," \
+ -e '/^daemonize\>/s,no,yes,' \
+ -e '/^# bind/s,^# ,,' \
+ -e '/^# maxmemory\>/s,^# ,,' \
+ -e '/^maxmemory\>/s,<bytes>,67108864,' \
+ -e "/^dbfilename\>/s,dump.rdb,${REDIS_DATAPATH}/dump.rdb," \
+ -e "/^dir\>/s, .*, ${REDIS_DATAPATH}/," \
+ -e '/^loglevel\>/s:debug:notice:' \
+ -e "/^logfile\>/s:stdout:${REDIS_LOGFILE}:" \
+ <redis.conf \
+ >redis.conf.gentoo
+ newins redis.conf.gentoo redis.conf
+ use prefix || fowners redis:redis /etc/redis.conf
+ fperms 0644 /etc/redis.conf
+
+ newconfd "${FILESDIR}/redis.confd" redis
+ newinitd "${FILESDIR}/redis.initd" redis
+
+ dodoc 00-RELEASENOTES BUGS Changelog CONTRIBUTING README TODO
+ dodoc design-documents/*
+ newdoc client-libraries/README README.client-libraries
+ docinto html
+ dodoc doc/*
+
+ dobin src/redis-cli || die "redis-cli could not be found"
+ dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump \
+ || die "some redis executables could not be found"
+ fperms 0750 /usr/sbin/redis-benchmark
+
+ if use prefix; then
+ diropts -m0750
+ else
+ diropts -m0750 -o redis -g redis
+ fi
+ keepdir ${REDIS_DATAPATH} ${REDIS_LOGPATH} ${REDIS_PIDDIR}
+}
+
+pkg_postinst() {
+ einfo "New features of Redis you want to consider enabling in redis.conf:"
+ einfo " * unix sockets (using this is highly recommended)"
+ einfo " * logging to syslog"
+ einfo " * VM aka redis' own swap mechanism"
+}