summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-13 06:33:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-13 06:33:58 +0000
commiteb1ef7cc63f612408045e3800447d8ede2bf3f77 (patch)
tree1674bfe6eb8d18be2188e3e024f1b47c1c43dbc9 /dev-db
parentBump tagsoup to 0.13 (diff)
downloadgentoo-2-eb1ef7cc63f612408045e3800447d8ede2bf3f77.tar.gz
gentoo-2-eb1ef7cc63f612408045e3800447d8ede2bf3f77.tar.bz2
gentoo-2-eb1ef7cc63f612408045e3800447d8ede2bf3f77.zip
Bump for #484640
(Portage version: 2.2.3/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libzdb/ChangeLog7
-rw-r--r--dev-db/libzdb/libzdb-2.12.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-db/libzdb/ChangeLog b/dev-db/libzdb/ChangeLog
index 0b13269ad132..0c79c185e75b 100644
--- a/dev-db/libzdb/ChangeLog
+++ b/dev-db/libzdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/libzdb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.15 2013/07/01 18:57:33 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.16 2013/09/13 06:33:58 patrick Exp $
+
+*libzdb-2.12 (13 Sep 2013)
+
+ 13 Sep 2013; Patrick Lauer <patrick@gentoo.org> +libzdb-2.12.ebuild:
+ Bump for #484640
*libzdb-2.11.3 (01 Jul 2013)
diff --git a/dev-db/libzdb/libzdb-2.12.ebuild b/dev-db/libzdb/libzdb-2.12.ebuild
new file mode 100644
index 000000000000..cdb6f9565a61
--- /dev/null
+++ b/dev-db/libzdb/libzdb-2.12.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.12.ebuild,v 1.1 2013/09/13 06:33:58 patrick Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A thread safe high level multi-database connection pool library"
+HOMEPAGE="http://www.tildeslash.com/libzdb/"
+SRC_URI="http://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc mysql postgres +sqlite ssl static-libs"
+REQUIRED_USE=" || ( postgres mysql sqlite )"
+
+RESTRICT=test
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( >=dev-db/sqlite-3.7:3[unlock-notify(+)] )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e "s|&& ./pool||g" test/Makefile.in || die
+}
+
+src_configure() {
+ ## TODO: check what --enable-optimized actually does
+ ## TODO: find someone with oracle db to add oci8 support
+ myconf=""
+ if [[ $(gcc-version) < 4.1 ]];then
+ myconf="${myconf} --disable-protected"
+ else
+ myconf="${myconf} --enable-protected"
+ fi
+
+ if use sqlite; then
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/ --enable-sqliteunlock"
+ else
+ myconf="${myconf} --without-sqlite"
+ fi
+
+ if use mysql; then
+ myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
+ else
+ myconf="${myconf} --without-postgresql"
+ fi
+
+ econf \
+ $(use_enable debug profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ --without-oci \
+ ${myconf}
+}
+
+src_compile() {
+ default_src_compile
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the --disable-static flag only skips .a
+ use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
+
+ dodoc AUTHORS CHANGES README
+ if use doc;then
+ dohtml -r "${S}/doc/api-docs"/*
+ fi
+}
+
+src_test() {
+ emake verify
+}