summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-07-02 23:10:01 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-07-02 23:10:01 +0000
commite5b35e46b61cfb64c713a4ab947d1694b0a340ab (patch)
tree54c428668924a6fc5b43a139f61614817046f5ae /dev-db
parentDon't depend on virtual/libc as it's pointless. (diff)
downloadgentoo-2-e5b35e46b61cfb64c713a4ab947d1694b0a340ab.tar.gz
gentoo-2-e5b35e46b61cfb64c713a4ab947d1694b0a340ab.tar.bz2
gentoo-2-e5b35e46b61cfb64c713a4ab947d1694b0a340ab.zip
Remove old version.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.3.5-r13
-rw-r--r--dev-db/sqlite/sqlite-3.3.5-r1.ebuild98
3 files changed, 5 insertions, 102 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 6762eb111a52..768302d117ce 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.156 2007/06/28 05:02:42 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.157 2007/07/02 23:10:01 betelgeuse Exp $
+
+ 02 Jul 2007; Petteri Räty <betelgeuse@gentoo.org>
+ -sqlite-3.3.5-r1.ebuild:
+ Remove old version.
28 Jun 2007; Joshua Kinard <kumba@gentoo.org> sqlite-3.3.17.ebuild:
Stable on mips, per #182013.
diff --git a/dev-db/sqlite/files/digest-sqlite-3.3.5-r1 b/dev-db/sqlite/files/digest-sqlite-3.3.5-r1
deleted file mode 100644
index 12d99a9330a8..000000000000
--- a/dev-db/sqlite/files/digest-sqlite-3.3.5-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 dd2a7b6f2a07a4403a0b5e17e8ed5b88 sqlite-3.3.5.tar.gz 1651536
-RMD160 7dd7c1d2a2f10132a4ef0f6972ddca4d5767b9d6 sqlite-3.3.5.tar.gz 1651536
-SHA256 e81d1176960a14459f9ff492b2c4fb1e2b55d0b2c82fd225dbc37afd02334256 sqlite-3.3.5.tar.gz 1651536
diff --git a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
deleted file mode 100644
index 298ccba1c1eb..000000000000
--- a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.19 2007/06/14 17:37:58 betelgeuse Exp $
-
-inherit eutils alternatives
-
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-
-DESCRIPTION="SQLite: an SQL Database Engine in a C Library."
-HOMEPAGE="http://www.sqlite.org/"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz"
-LICENSE="as-is"
-SLOT="3"
-IUSE="debug doc nothreadsafe tcl"
-
-DEPEND="doc? ( dev-lang/tcl )
- tcl? ( dev-lang/tcl )"
-
-RDEPEND="tcl? ( dev-lang/tcl )"
-
-SOURCE="/usr/bin/lemon"
-ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-
-RESTRICT="!tcl? ( test )"
-
-src_unpack() {
- # test
- if has test ${FEATURES}; then
- if ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl; then
- ewarn "You must enable the tcl use flag if you want to run the test"
- ewarn "suite."
- eerror "Testsuite will not be run."
- fi
- fi
-
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/sqlite-3.3.3-tcl-fix.patch
- epatch "${FILESDIR}"/sqlite-3-test-fix-3.3.4.patch
-
- epatch "${FILESDIR}"/sandbox-fix1.patch
- epatch "${FILESDIR}"/sandbox-fix2.patch
-
- # Fix broken tests that are not portable to 64bit arches
- epatch "${FILESDIR}"/sqlite-64bit-test-fix.patch
- epatch "${FILESDIR}"/sqlite-64bit-test-fix2.patch
-
- epunt_cxx
-}
-
-src_compile() {
- local myconf="--enable-incore-db --enable-tempdb-in-ram --enable-cross-thread-connections"
-
- econf ${myconf} \
- $(use_enable debug) \
- $(use_enable !nothreadsafe threadsafe) \
- $(use_enable tcl) \
- || die "econf failed"
-
- emake all || die "emake all failed"
-
- if use doc ; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_test() {
- if use tcl ; then
- if has userpriv ${FEATURES} ; then
- cd "${S}"
- if use debug ; then
- emake fulltest || die "some test failed"
- else
- emake test || die "some test failed"
- fi
- fi
- fi
-}
-
-src_install () {
- make \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)" \
- install \
- || die "make install failed"
-
- newbin lemon lemon-${SLOT}
-
- dodoc README VERSION
- doman sqlite3.1
-
- use doc && dohtml doc/*.html doc/*.txt doc/*.png
-}