summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2014-03-11 22:26:44 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2014-03-11 22:26:44 +0000
commitd2deab9bdbfc4317b0932b0ea3f5ca53e10bda55 (patch)
tree03371195d38b42b185c294c2599288f6de67bd14 /dev-db
parentStable for amd64 wrt bug #503784 (diff)
downloadgentoo-2-d2deab9bdbfc4317b0932b0ea3f5ca53e10bda55.tar.gz
gentoo-2-d2deab9bdbfc4317b0932b0ea3f5ca53e10bda55.tar.bz2
gentoo-2-d2deab9bdbfc4317b0932b0ea3f5ca53e10bda55.zip
4.1.1 is not actually compatible with <dev-db/postgresql-9.0. Updated POSTGRES_COMPAT to include 9.3. Fixes bug 499006.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pygresql/ChangeLog9
-rw-r--r--dev-db/pygresql/pygresql-4.1.1-r1.ebuild74
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-db/pygresql/ChangeLog b/dev-db/pygresql/ChangeLog
index 838e9536f72b..1ec347457486 100644
--- a/dev-db/pygresql/ChangeLog
+++ b/dev-db/pygresql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/pygresql
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.70 2014/01/27 11:28:53 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.71 2014/03/11 22:26:44 titanofold Exp $
+
+*pygresql-4.1.1-r1 (11 Mar 2014)
+
+ 11 Mar 2014; Aaron W. Swenson <titanofold@gentoo.org>
+ +pygresql-4.1.1-r1.ebuild:
+ 4.1.1 is not actually compatible with <dev-db/postgresql-9.0. Updated
+ POSTGRES_COMPAT to include 9.3. Fixes bug 499006.
27 Jan 2014; Aaron W. Swenson <titanofold@gentoo.org> -pygresql-3.8.1.ebuild,
-pygresql-4.0.ebuild:
diff --git a/dev-db/pygresql/pygresql-4.1.1-r1.ebuild b/dev-db/pygresql/pygresql-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..41e87ac41d6d
--- /dev/null
+++ b/dev-db/pygresql/pygresql-4.1.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-4.1.1-r1.ebuild,v 1.1 2014/03/11 22:26:44 titanofold Exp $
+
+EAPI=5
+
+POSTGRES_COMPAT=( 9.{0,1,2,3} )
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tgz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="|| (
+ dev-db/postgresql-base:9.3
+ dev-db/postgresql-base:9.2
+ dev-db/postgresql-base:9.1
+ dev-db/postgresql-base:9.0
+)"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# Verify that the currently selected PostgreSQL slot is set to one of
+# the slots defined in POSTGRES_COMPAT.
+postgres_check_slot() {
+ if ! declare -p POSTGRES_COMPAT &>/dev/null; then
+ die 'POSTGRES_COMPAT not declared.'
+ fi
+
+# Don't die because we can't run postgresql-config during pretend.
+[[ "$EBUILD_PHASE" = "pretend" && -z "$(which postgresql-config 2> /dev/null)" ]] \
+ && return 0
+
+ local res=$(echo ${POSTGRES_COMPAT[@]} \
+ | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
+
+ if [[ "$res" -eq "0" ]] ; then
+ eerror "PostgreSQL slot must be set to one of: "
+ eerror " ${POSTGRES_COMPAT[@]}"
+ return 1
+ fi
+
+ return 0
+}
+
+pkg_pretend() {
+ postgres_check_slot
+}
+
+pkg_setup() {
+ postgres_check_slot || die
+}
+
+python_install_all() {
+ local DOCS=( docs/*.txt )
+ distutils-r1_python_install_all
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/*
+ dohtml docs/*.{html,css}
+ fi
+}