summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-24 15:08:38 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-24 15:08:38 +0000
commitcf3455ba08292fd2fd15fdb0978ec0f1c1801d9b (patch)
treea83470d3dfc5c9aa6f683f4f3947f2a023f7f341 /dev-db
parentUSE flag change qt->qt3/qt4 bug #137785 (diff)
downloadgentoo-2-cf3455ba08292fd2fd15fdb0978ec0f1c1801d9b.tar.gz
gentoo-2-cf3455ba08292fd2fd15fdb0978ec0f1c1801d9b.tar.bz2
gentoo-2-cf3455ba08292fd2fd15fdb0978ec0f1c1801d9b.zip
USE flag change qt->qt3/qt4 bug #137785
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/unixODBC/ChangeLog7
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild10
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.11.ebuild12
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.2.ebuild10
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild12
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.6.ebuild10
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.8.ebuild12
7 files changed, 39 insertions, 34 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 3b623faa2638..fb6d483d8915 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/unixODBC
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.54 2006/01/14 08:16:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.55 2006/06/24 15:08:38 cardoe Exp $
+
+ 24 Jun 2006; Doug Goldstein <cardoe@gentoo.org> unixODBC-2.2.2.ebuild,
+ unixODBC-2.2.6.ebuild, unixODBC-2.2.6-r1.ebuild, unixODBC-2.2.8.ebuild,
+ unixODBC-2.2.11.ebuild, unixODBC-2.2.11-r1.ebuild:
+ USE flag change qt->qt3/qt4 bug #137785
14 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+files/unixODBC-2.2.11-flex.patch, unixODBC-2.2.11-r1.ebuild:
diff --git a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
index 93385cad974f..9ea8b670bf5b 100644
--- a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.11 2006/01/14 08:16:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.12 2006/06/24 15:08:38 cardoe Exp $
inherit eutils
@@ -11,15 +11,15 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha ~amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="qt gnome"
+IUSE="qt3 gnome"
DEPEND="virtual/libc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
gnome? ( gnome-base/gnome-libs )
- qt? ( =x11-libs/qt-3* )"
+ qt3? ( =x11-libs/qt-3* )"
-# the configure.in patch is required for 'use qt'
+# the configure.in patch is required for 'use qt3'
src_unpack() {
unpack ${P}.tar.gz
cd "${S}"
@@ -37,7 +37,7 @@ src_unpack() {
src_compile() {
local myconf
- if use qt && ! use mips;
+ if use qt3 && ! use mips;
then
myconf="--enable-gui=yes --x-libraries=/usr/lib "
else
diff --git a/dev-db/unixODBC/unixODBC-2.2.11.ebuild b/dev-db/unixODBC/unixODBC-2.2.11.ebuild
index 4148c96a3a57..41877afce764 100644
--- a/dev-db/unixODBC/unixODBC-2.2.11.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11.ebuild,v 1.4 2005/07/25 15:38:13 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11.ebuild,v 1.5 2006/06/24 15:08:38 cardoe Exp $
inherit eutils gnuconfig
@@ -11,15 +11,15 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="qt gnome"
+IUSE="qt3 gnome"
DEPEND="virtual/libc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
gnome? ( gnome-base/gnome-libs )
- qt? ( =x11-libs/qt-3* )"
+ qt3? ( =x11-libs/qt-3* )"
-# the configure.in patch is required for 'use qt'
+# the configure.in patch is required for 'use qt3'
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -36,7 +36,7 @@ src_unpack() {
src_compile() {
local myconf
- if use qt && ! use mips;
+ if use qt3 && ! use mips;
then
myconf="--enable-gui=yes --x-libraries=/usr/lib "
else
diff --git a/dev-db/unixODBC/unixODBC-2.2.2.ebuild b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
index 98774290bf04..d8ccd3c6aa12 100644
--- a/dev-db/unixODBC/unixODBC-2.2.2.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.21 2005/07/07 04:31:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.22 2006/06/24 15:08:38 cardoe Exp $
inherit eutils
@@ -11,12 +11,12 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~hppa ~alpha amd64"
-IUSE="qt"
+IUSE="qt3"
DEPEND="virtual/libc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
- qt? ( =x11-libs/qt-3* )"
+ qt3? ( =x11-libs/qt-3* )"
src_unpack() {
unpack ${A}
@@ -30,7 +30,7 @@ src_unpack() {
src_compile() {
local myconf
- if use qt ; then
+ if use qt3 ; then
myconf="--enable-gui=yes"
else
myconf="--enable-gui=no"
diff --git a/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
index 2caecb8a2748..7336d7cc1cf3 100644
--- a/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild,v 1.12 2005/07/07 04:31:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild,v 1.13 2006/06/24 15:08:38 cardoe Exp $
inherit eutils
@@ -11,15 +11,15 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~hppa ~alpha ~amd64 ~sparc"
-IUSE="qt gnome"
+IUSE="qt3 gnome"
DEPEND="virtual/libc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
gnome? ( gnome-base/gnome-libs )
- qt? ( =x11-libs/qt-3* )"
+ qt3? ( =x11-libs/qt-3* )"
-# the configure.in patch is required for 'use qt'
+# the configure.in patch is required for 'use qt3'
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -33,7 +33,7 @@ src_unpack() {
src_compile() {
local myconf
- if use qt ; then
+ if use qt3 ; then
myconf="--enable-gui=yes --x-libraries=/usr/lib "
else
myconf="--enable-gui=no"
diff --git a/dev-db/unixODBC/unixODBC-2.2.6.ebuild b/dev-db/unixODBC/unixODBC-2.2.6.ebuild
index e5a45845b110..08febb0fb03c 100644
--- a/dev-db/unixODBC/unixODBC-2.2.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6.ebuild,v 1.18 2005/07/07 04:31:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6.ebuild,v 1.19 2006/06/24 15:08:38 cardoe Exp $
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -9,18 +9,18 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc hppa alpha amd64 sparc ia64"
-IUSE="qt gnome"
+IUSE="qt3 gnome"
DEPEND="virtual/libc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
- qt? ( =x11-libs/qt-3* )
+ qt3? ( =x11-libs/qt-3* )
gnome? ( gnome-base/gnome-libs )"
src_compile() {
local myconf
- if use qt
+ if use qt3
then
myconf="--enable-gui=yes --x-libraries=/usr/lib --x-includes=/usr/include/X11"
else
diff --git a/dev-db/unixODBC/unixODBC-2.2.8.ebuild b/dev-db/unixODBC/unixODBC-2.2.8.ebuild
index b2e453601c02..431e1c5b94ea 100644
--- a/dev-db/unixODBC/unixODBC-2.2.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.8.ebuild,v 1.21 2005/07/07 04:31:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.8.ebuild,v 1.22 2006/06/24 15:08:38 cardoe Exp $
inherit eutils gnuconfig multilib
@@ -11,17 +11,17 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ppc ~sparc mips ~alpha arm hppa ~amd64 s390 ppc64"
-IUSE="qt gnome"
+IUSE="qt3 gnome"
DEPEND="virtual/libc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
!mips? (
gnome? ( gnome-base/gnome-libs )
- qt? ( =x11-libs/qt-3* )
+ qt3? ( =x11-libs/qt-3* )
)"
-# the configure.in patch is required for 'use qt'
+# the configure.in patch is required for 'use qt3'
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -36,7 +36,7 @@ src_unpack() {
src_compile() {
local myconf
- if use qt && ! use mips
+ if use qt3 && ! use mips
then
myconf="--enable-gui=yes --x-libraries=/usr/$(get_libdir) "
else