summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-03-01 23:38:35 +0000
committerDonny Davies <woodchip@gentoo.org>2003-03-01 23:38:35 +0000
commitbb9a442e339334587c26b7f61774919febb0fd8d (patch)
tree7fa8b95e11c99dc754a11cd577e26b84c3587a8a /dev-db
parenterrno build fix, configure fixes (diff)
downloadgentoo-2-bb9a442e339334587c26b7f61774919febb0fd8d.tar.gz
gentoo-2-bb9a442e339334587c26b7f61774919febb0fd8d.tar.bz2
gentoo-2-bb9a442e339334587c26b7f61774919febb0fd8d.zip
glibc errno build fix; fix readline configure
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog5
-rw-r--r--dev-db/mysql/mysql-3.23.55.ebuild12
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 3f6a36bae0f4..6d28b66e5ca0 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.38 2003/03/01 23:32:39 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.39 2003/03/01 23:38:34 woodchip Exp $
*mysql-4.0.11a (01 Mar 2003)
@@ -20,6 +20,9 @@
*mysql-3.23.55 (29 Jan 2003)
+ 01 Mar 2003; Donny Davies <woodchip@gentoo.org> : mysql-3.23.55.ebuild :
+ Add a build fix for glibc-2.3.2_pre. Fix readline configure flags, sigh.
+
06 Feb 2003; Will Woods <wwoods@gentoo.org>: mysql-3.23.54a.ebuild, mysql-3.23.54a.ebuild
Disable berkdb on alpha, since it's not supported there.
diff --git a/dev-db/mysql/mysql-3.23.55.ebuild b/dev-db/mysql/mysql-3.23.55.ebuild
index d9993946735b..6c6f2718c4a7 100644
--- a/dev-db/mysql/mysql-3.23.55.ebuild
+++ b/dev-db/mysql/mysql-3.23.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.55.ebuild,v 1.4 2003/02/23 09:08:32 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.55.ebuild,v 1.5 2003/03/01 23:38:35 woodchip Exp $
# bug #11681; get b0rked code when using -march=k6 with this package.
inherit flag-o-matic
@@ -64,8 +64,9 @@ src_compile() {
use berkdb && myconf="${myconf} --with-berkeley-db=./bdb" \
|| myconf="${myconf} --without-berkeley-db"
fi
- use readline && myconf="${myconf} --with-readline"
- use readline || myconf="${myconf} --without-readline"
+ #readline pair reads backwards on purpose, DONT change it around, Ok?
+ use readline && myconf="${myconf} --without-readline"
+ use readline || myconf="${myconf} --with-readline"
use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
use static || myconf="${myconf} --enable-shared --enable-static"
use tcpd && myconf="${myconf} --with-libwrap"
@@ -77,8 +78,11 @@ src_compile() {
[ -n "${DEBUGBUILD}" ] && myconf="${myconf} --with-debug"
[ -n "${DEBUGBUILD}" ] || myconf="${myconf} --without-debug"
+ #glibc-2.3.2_pre fix; bug #16496
+ export CFLAGS="${CFLAGS} -DHAVE_ERRNO_AS_DEFINE=1"
+
# the compiler flags are as per their "official" spec ;-)
- einfo "myconf is $myconf"
+ einfo "\$myconf is $myconf"
CFLAGS="${CFLAGS/-O?/} -O3" \
CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
econf \