summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-12-02 15:33:37 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-12-02 15:33:37 +0000
commitac304d0608be7f37806a3d9d041ecb53b91aa415 (patch)
treec4a70afee7ad758848e6e9680c501b3d35da5a99 /dev-db
parentversion bumps for security bug 531408 (diff)
downloadgentoo-2-ac304d0608be7f37806a3d9d041ecb53b91aa415.tar.gz
gentoo-2-ac304d0608be7f37806a3d9d041ecb53b91aa415.tar.bz2
gentoo-2-ac304d0608be7f37806a3d9d041ecb53b91aa415.zip
fix #529050
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/ChangeLog6
-rw-r--r--dev-db/redis/files/redis-2.8.17-config.patch46
-rw-r--r--dev-db/redis/files/redis.initd-48
-rw-r--r--dev-db/redis/redis-2.8.17.ebuild5
4 files changed, 58 insertions, 7 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index ea9a7ee5541b..a9ee13b660d3 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.85 2014/10/08 09:46:26 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.86 2014/12/02 15:33:37 ultrabug Exp $
+
+ 02 Dec 2014; Ultrabug <ultrabug@gentoo.org> redis-2.8.17.ebuild,
+ +files/redis-2.8.17-config.patch, files/redis.initd-4:
+ fix daemonization wrt #529050
*redis-2.8.17 (08 Oct 2014)
diff --git a/dev-db/redis/files/redis-2.8.17-config.patch b/dev-db/redis/files/redis-2.8.17-config.patch
new file mode 100644
index 000000000000..c9f6b2af172b
--- /dev/null
+++ b/dev-db/redis/files/redis-2.8.17-config.patch
@@ -0,0 +1,46 @@
+--- a/redis.conf 2014-12-02 16:22:38.722433643 +0100
++++ b/redis.conf 2014-12-02 16:22:16.252249350 +0100
+@@ -38,7 +38,7 @@
+
+ # When running daemonized, Redis writes a pid file in /var/run/redis.pid by
+ # default. You can specify a custom pid file location here.
+-pidfile /var/run/redis.pid
++pidfile /run/redis/redis.pid
+
+ # Accept connections on the specified port, default is 6379.
+ # If port 0 is specified Redis will not listen on a TCP socket.
+@@ -61,7 +61,7 @@
+ # Examples:
+ #
+ # bind 192.168.1.100 10.0.0.1
+-# bind 127.0.0.1
++bind 127.0.0.1
+
+ # Specify the path for the Unix socket that will be used to listen for
+ # incoming connections. There is no default, so Redis will not listen
+@@ -100,7 +100,7 @@
+ # Specify the log file name. Also the empty string can be used to force
+ # Redis to log on the standard output. Note that if you use standard
+ # output for logging but daemonize, logs will be sent to /dev/null
+-logfile ""
++logfile /var/log/redis/redis.log
+
+ # To enable logging to the system logger, just set 'syslog-enabled' to yes,
+ # and optionally update the other syslog parameters to suit your needs.
+@@ -184,7 +184,7 @@
+ # The Append Only File will also be created inside this directory.
+ #
+ # Note that you must specify a directory here, not a file name.
+-dir ./
++dir /var/lib/redis/
+
+ ################################# REPLICATION #################################
+
+@@ -403,6 +403,7 @@
+ # output buffers (but this is not needed if the policy is 'noeviction').
+ #
+ # maxmemory <bytes>
++maxmemory 67108864
+
+ # MAXMEMORY POLICY: how Redis will select what to remove when maxmemory
+ # is reached. You can select among five behaviors:
diff --git a/dev-db/redis/files/redis.initd-4 b/dev-db/redis/files/redis.initd-4
index f75867da79f2..38cbfd8f6575 100644
--- a/dev-db/redis/files/redis.initd-4
+++ b/dev-db/redis/files/redis.initd-4
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/files/redis.initd-4,v 1.1 2014/10/08 09:46:26 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/files/redis.initd-4,v 1.2 2014/12/02 15:33:37 ultrabug Exp $
REDIS_DIR=${REDIS_DIR:-/var/lib/redis}
REDIS_CONF=${REDIS_CONF:-/etc/redis.conf}
@@ -9,10 +9,10 @@ REDIS_GROUP=${REDIS_GROUP:-redis}
REDIS_TIMEOUT=${REDIS_TIMEOUT:-30}
command=/usr/sbin/redis-server
-start_stop_daemon_args="--chdir \"${REDIS_DIR}\"
- --user ${REDIS_USER} --group ${REDIS_GROUP}"
-command_args="${REDIS_OPTS}"
pidfile=${REDIS_PID:-/run/redis/redis.pid}
+start_stop_daemon_args="--background --make-pidfile --pidfile ${pidfile}
+ --chdir \"${REDIS_DIR}\" --user ${REDIS_USER} --group ${REDIS_GROUP}"
+command_args="${REDIS_OPTS}"
depend() {
use net localmount logger
diff --git a/dev-db/redis/redis-2.8.17.ebuild b/dev-db/redis/redis-2.8.17.ebuild
index d14a6c8acb61..5719f1943647 100644
--- a/dev-db/redis/redis-2.8.17.ebuild
+++ b/dev-db/redis/redis-2.8.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.17.ebuild,v 1.1 2014/10/08 09:46:26 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.17.ebuild,v 1.2 2014/12/02 15:33:37 ultrabug Exp $
EAPI=5
@@ -32,7 +32,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.8.3-{shared,config}.patch
+ epatch "${FILESDIR}"/${PN}-2.8.3-shared.patch
+ epatch "${FILESDIR}"/${PN}-2.8.17-config.patch
epatch "${FILESDIR}"/${PN}-2.8.13-sharedlua.patch
# Copy lua modules into build dir