summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-01-22 02:49:57 +0000
committerJeroen Roovers <jer@gentoo.org>2010-01-22 02:49:57 +0000
commita6551ea3b0cc5036961fb490cb80cb38d0aaf75d (patch)
tree0023c2b2c73b76b5a4ffd79a52b75e388131a95e /dev-db
parentKeyword ~amd64-linux/~x86-linux (diff)
downloadgentoo-2-a6551ea3b0cc5036961fb490cb80cb38d0aaf75d.tar.gz
gentoo-2-a6551ea3b0cc5036961fb490cb80cb38d0aaf75d.tar.bz2
gentoo-2-a6551ea3b0cc5036961fb490cb80cb38d0aaf75d.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tokyocabinet/ChangeLog7
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index 17d66367f596..8ce2d57811b5 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.19 2010/01/12 17:58:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.20 2010/01/22 02:49:57 jer Exp $
+
+*tokyocabinet-1.4.42 (22 Jan 2010)
+
+ 22 Jan 2010; Jeroen Roovers <jer@gentoo.org> +tokyocabinet-1.4.42.ebuild:
+ Version bump.
12 Jan 2010; Jeroen Roovers <jer@gentoo.org> tokyocabinet-1.4.41.ebuild:
Stable for HPPA (bug #290660).
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild
new file mode 100644
index 000000000000..dcaf0592a4a9
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.42.ebuild,v 1.1 2010/01/22 02:49:57 jer Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://1978th.net/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ dodoc example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ dodoc doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}