summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-07-29 22:12:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-07-29 22:12:28 +0000
commit9ae0cdab7f856f203f827f7baba2d74dc61431a8 (patch)
tree6e0912bd992749c41b3cb8d24dcf520f4fafd357 /dev-db
parentVersion bump (diff)
downloadgentoo-2-9ae0cdab7f856f203f827f7baba2d74dc61431a8.tar.gz
gentoo-2-9ae0cdab7f856f203f827f7baba2d74dc61431a8.tar.bz2
gentoo-2-9ae0cdab7f856f203f827f7baba2d74dc61431a8.zip
Bump
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/kyotocabinet/ChangeLog7
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.69.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index 6185cfb69307..15984d836944 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.11 2011/06/18 17:17:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.12 2011/07/29 22:12:28 patrick Exp $
+
+*kyotocabinet-1.2.69 (29 Jul 2011)
+
+ 29 Jul 2011; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.69.ebuild:
+ Bump
*kyotocabinet-1.2.62 (18 Jun 2011)
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.69.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.69.ebuild
new file mode 100644
index 000000000000..f224403a7393
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.69.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.69.ebuild,v 1.1 2011/07/29 22:12:28 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples static-libs"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_configure-1.2.62.patch"
+ sed -ie "/ldconfig/d" Makefile.in
+ sed -ie "/DOCDIR/d" Makefile.in
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable !static-libs shared) \
+ --enable-lzma --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}