summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-11 17:30:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-11 17:30:22 +0000
commit966dd10eb2d8ac63b7f7366fc3b576a6d6accde1 (patch)
treefb46c5e04c9a9daf818ffaa1b12ef0c5ea0b632c /dev-db
parentDetect the gcc version in a really saner conditional. (diff)
downloadgentoo-2-966dd10eb2d8ac63b7f7366fc3b576a6d6accde1.tar.gz
gentoo-2-966dd10eb2d8ac63b7f7366fc3b576a6d6accde1.tar.bz2
gentoo-2-966dd10eb2d8ac63b7f7366fc3b576a6d6accde1.zip
Cleanup inherits and my_pv creation so it actualy works. Move pkg_setup to pkg_pretend and use default src install.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/ChangeLog7
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild21
2 files changed, 17 insertions, 11 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 0385cb08f5cf..78f18946fec8 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.64 2011/07/11 01:52:14 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.65 2011/07/11 17:30:22 scarabeus Exp $
+
+ 11 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ pgadmin3-1.14.0_beta1.ebuild:
+ Cleanup inherits and my_pv creation so it actualy works. Move pkg_setup to
+ pkg_pretend and use default src install.
*pgadmin3-1.14.0_beta1 (11 Jul 2011)
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild
index 14a4b98e365d..afe02aa2d733 100644
--- a/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild
+++ b/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild,v 1.1 2011/07/11 01:52:14 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.0_beta1.ebuild,v 1.2 2011/07/11 17:30:22 scarabeus Exp $
-EAPI="4"
+EAPI=4
WX_GTK_VER="2.8"
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
-inherit autotools multilib versionator wxwidgets
-
-MY_PV=$(replace_version_separator 3 '-')
+inherit autotools wxwidgets
DESCRIPTION="wxWidgets GUI for PostgreSQL."
HOMEPAGE="http://www.pgadmin.org/"
-SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${PN}-${MY_PV}.tar.gz"
+SRC_URI="mirror://postgresql/${PN}/release/v${MY_PV}/src/${MY_P}.tar.gz"
LICENSE="Artistic"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
@@ -25,9 +25,9 @@ DEPEND="x11-libs/wxGTK:2.8[X]
>=dev-libs/libxslt-1.1"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
-pkg_setup() {
+pkg_pretend() {
local pgslot=$(postgresql-config show)
if [[ ${pgslot//.} < 84 ]] ; then
@@ -43,12 +43,13 @@ src_prepare() {
}
src_configure() {
- econf --with-wx-version=2.8 \
+ econf \
+ --with-wx-version=2.8 \
$(use_enable debug)
}
src_install() {
- emake DESTDIR="${D}" install
+ default
newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png