summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-10 17:41:47 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-10 17:41:47 +0000
commit86a62fe47638d0793c148865b7bdc63d0355bfc1 (patch)
tree6e1e5d86d4ecf17ec2ea1c17e26a299e4b99778c /dev-db
parentVersion bump. (diff)
downloadgentoo-2-86a62fe47638d0793c148865b7bdc63d0355bfc1.tar.gz
gentoo-2-86a62fe47638d0793c148865b7bdc63d0355bfc1.tar.bz2
gentoo-2-86a62fe47638d0793c148865b7bdc63d0355bfc1.zip
Re-add a stable-compatible version patched against the unicode bug
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/virtuoso-server/ChangeLog8
-rw-r--r--dev-db/virtuoso-server/virtuoso-server-6.1.3-r2.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-db/virtuoso-server/ChangeLog b/dev-db/virtuoso-server/ChangeLog
index 883da169f1bf..15f74fdeeaac 100644
--- a/dev-db/virtuoso-server/ChangeLog
+++ b/dev-db/virtuoso-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/virtuoso-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/virtuoso-server/ChangeLog,v 1.25 2011/11/24 00:53:23 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/virtuoso-server/ChangeLog,v 1.26 2011/12/10 17:41:47 dilfridge Exp $
+
+*virtuoso-server-6.1.3-r2 (10 Dec 2011)
+
+ 10 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +virtuoso-server-6.1.3-r2.ebuild:
+ Re-add a stable-compatible version patched against the unicode bug
*virtuoso-server-6.1.4 (24 Nov 2011)
diff --git a/dev-db/virtuoso-server/virtuoso-server-6.1.3-r2.ebuild b/dev-db/virtuoso-server/virtuoso-server-6.1.3-r2.ebuild
new file mode 100644
index 000000000000..039686d103c0
--- /dev/null
+++ b/dev-db/virtuoso-server/virtuoso-server-6.1.3-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/virtuoso-server/virtuoso-server-6.1.3-r2.ebuild,v 1.1 2011/12/10 17:41:47 dilfridge Exp $
+
+EAPI=4
+
+inherit virtuoso
+
+DESCRIPTION="Server binaries for Virtuoso, high-performance object-relational SQL database"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="kerberos ldap readline"
+
+# Bug 305077
+#RESTRICT="test"
+
+# Version restriction on sys-libs/zlib, bug #383349
+
+# zeroconf support looks like broken - disabling - last checked around 5.0.12
+# mono support fetches mono source and compiles it manually - disabling for now
+# mono? ( dev-lang/mono )
+COMMON_DEPEND="
+ dev-libs/libxml2:2
+ >=dev-libs/openssl-0.9.7i:0
+ <sys-libs/zlib-1.2.5.1-r1:0
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ readline? ( sys-libs/readline:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ <sys-apps/gawk-4.0.0
+ >=sys-devel/bison-2.3
+ >=sys-devel/flex-2.5.33
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-db/virtuoso-odbc-${PV}:${SLOT}
+"
+
+VOS_EXTRACT="
+ libsrc/Dk
+ libsrc/Thread
+ libsrc/Tidy
+ libsrc/Wi
+ libsrc/Xml.new
+ libsrc/langfunc
+ libsrc/odbcsdk
+ libsrc/plugin
+ libsrc/util
+ binsrc/virtuoso
+ binsrc/tests
+"
+
+DOCS=(AUTHORS ChangeLog CREDITS INSTALL NEWS README)
+
+PATCHES=( "${FILESDIR}/${P}-unicode.patch" )
+
+src_prepare() {
+ sed -e '/^lib_LTLIBRARIES\s*=.*/s/lib_/noinst_/' -i binsrc/virtuoso/Makefile.am \
+ || die "failed to disable installation of static lib"
+
+ virtuoso_src_prepare
+}
+
+src_configure() {
+ myconf+="
+ $(use_enable kerberos krb)
+ $(use_enable ldap openldap)
+ $(use_with readline)
+ --disable-static
+ --disable-hslookup
+ --disable-rendezvous
+ --without-iodbc
+ "
+
+ virtuoso_src_configure
+}
+
+src_install() {
+ virtuoso_src_install
+
+ # Rename isql executables (conflicts with unixODBC)
+ mv "${ED}/usr/bin/isql" "${ED}/usr/bin/isql-v" || die
+ mv "${ED}/usr/bin/isqlw" "${ED}/usr/bin/isqlw-v" || die
+
+ keepdir /var/lib/virtuoso/db
+}