summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-20 10:11:34 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-20 10:11:34 +0000
commit7b10106b8984eb75b6de70298be6f50fe6d8123c (patch)
tree2deffbfcdc6f78d3f99abfc150454a51da8c8e56 /dev-db
parentSome rearrangement in the ebuild for more legibility; econf needs no die (diff)
downloadgentoo-2-7b10106b8984eb75b6de70298be6f50fe6d8123c.tar.gz
gentoo-2-7b10106b8984eb75b6de70298be6f50fe6d8123c.tar.bz2
gentoo-2-7b10106b8984eb75b6de70298be6f50fe6d8123c.zip
Version Bump, #381341; thanks Eric Johnson for the ebuild
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/freetds/ChangeLog7
-rw-r--r--dev-db/freetds/freetds-0.91.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-db/freetds/ChangeLog b/dev-db/freetds/ChangeLog
index aaa7ebf66741..4523acaecf91 100644
--- a/dev-db/freetds/ChangeLog
+++ b/dev-db/freetds/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/freetds
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/ChangeLog,v 1.50 2011/09/20 09:51:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/ChangeLog,v 1.51 2011/09/20 10:11:34 jlec Exp $
+
+*freetds-0.91 (20 Sep 2011)
+
+ 20 Sep 2011; Justin Lecher <jlec@gentoo.org> +freetds-0.91.ebuild:
+ Version Bump, #381341; thanks Eric Johnson for the ebuild
20 Sep 2011; Justin Lecher <jlec@gentoo.org> freetds-0.64.ebuild,
freetds-0.82-r3.ebuild:
diff --git a/dev-db/freetds/freetds-0.91.ebuild b/dev-db/freetds/freetds-0.91.ebuild
new file mode 100644
index 000000000000..ca4c54e4a758
--- /dev/null
+++ b/dev-db/freetds/freetds-0.91.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/freetds-0.91.ebuild,v 1.1 2011/09/20 10:11:34 jlec Exp $
+
+EAPI=4
+
+inherit autotools
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~ppc-macos"
+DESCRIPTION="Tabular Datastream Library."
+HOMEPAGE="http://www.freetds.org/"
+SRC_URI="http://ibiblio.org/pub/Linux/ALPHA/freetds/stable/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="kerberos odbc iodbc mssql"
+RESTRICT="test"
+
+DEPEND="
+ iodbc? ( dev-db/libiodbc )
+ kerberos? ( virtual/krb5 )
+ odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # taken from a nightly build (20100522)
+ cp "${FILESDIR}/config.rpath" "${S}" || die
+
+ sed -ie 's:with_iodbc/include":with_iodbc/include/iodbc":' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ myconf="--with-tdsver=7.0 $(use_enable mssql msdblib)"
+
+ if use iodbc ; then
+ myconf="${myconf} --enable-odbc --with-iodbc=${EPREFIX}/usr"
+ elif use odbc ; then
+ myconf="${myconf} --enable-odbc --with-unixodbc=${EPREFIX}/usr"
+ fi
+ if use kerberos ; then
+ myconf="${myconf} --enable-krb5"
+ fi
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="doc/${PF}" install
+}