summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-01 09:15:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-01 09:15:25 +0000
commit718b719050ac3e71337d09d7705607cf136ec54c (patch)
tree0cd93ae6489d33d63f4f6c7646c015d328a7749d /dev-db
parentmake repoman happy. (diff)
downloadgentoo-2-718b719050ac3e71337d09d7705607cf136ec54c.tar.gz
gentoo-2-718b719050ac3e71337d09d7705607cf136ec54c.tar.bz2
gentoo-2-718b719050ac3e71337d09d7705607cf136ec54c.zip
Version bump per bug #240088, also handles new upstream source location and versioning.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-hardened-r4 x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/myodbc/ChangeLog11
-rw-r--r--dev-db/myodbc/myodbc-3.51.26_p1127.ebuild95
2 files changed, 104 insertions, 2 deletions
diff --git a/dev-db/myodbc/ChangeLog b/dev-db/myodbc/ChangeLog
index a2c3a286ec70..90510c3da6a8 100644
--- a/dev-db/myodbc/ChangeLog
+++ b/dev-db/myodbc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/myodbc
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/ChangeLog,v 1.15 2007/07/02 02:28:00 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/ChangeLog,v 1.16 2008/11/01 09:15:25 robbat2 Exp $
+
+*myodbc-3.51.26_p1127 (01 Nov 2008)
+
+ 01 Nov 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +myodbc-3.51.26_p1127.ebuild:
+ Version bump per bug #240088, also handles new upstream source location
+ and versioning.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> myodbc-3.51.12.ebuild:
(QA) RESTRICT clean up.
diff --git a/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild b/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild
new file mode 100644
index 000000000000..0aa6787209b6
--- /dev/null
+++ b/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.26_p1127.ebuild,v 1.1 2008/11/01 09:15:25 robbat2 Exp $
+
+MY_PN="mysql-connector-odbc"
+MY_P="${MY_PN}-${PV/_p/r}"
+DESCRIPTION="ODBC driver for MySQL"
+HOMEPAGE="http://www.mysql.com/products/myodbc/"
+SRC_URI="mirror://mysql/Downloads/Connector-ODBC/3.51/${MY_P}.tar.gz"
+RESTRICT="primaryuri"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc static"
+RDEPEND=">=virtual/mysql-4.0 dev-db/unixODBC sys-devel/m4"
+# perl is required for building docs
+DEPEND="${RDEPEND} doc? ( dev-lang/perl )"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf="--enable-static"
+ use static \
+ && myconf="${myconf} --disable-shared" \
+ || myconf="${myconf} --enable-shared"
+
+ myconf="${myconf} $(use_with doc docs) $(use_with debug)"
+ myconf="${myconf} --disable-gui"
+ #TODO: the configure test against qt 4 enter in an endless loop
+ #myconf="${myconf} $(use_enable qt gui)"
+
+ econf \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/myodbc \
+ --localstatedir=/var/lib/myodbc \
+ --with-mysql-libs=/usr/lib/mysql \
+ --with-mysql-includes=/usr/include/mysql \
+ --with-odbc-ini=/etc/unixODBC/odbc.ini \
+ --with-unixODBC=/usr \
+ --enable-myodbc3i \
+ --enable-myodbc3m \
+ --disable-test \
+ --without-samples \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ einstall \
+ libexecdir=${D}/usr/sbin \
+ sysconfdir=${D}/etc/myodbc \
+ localstatedir=${D}/var/lib/myodbc
+ dodoc INSTALL RELEASE-NOTES README
+}
+
+pkg_config() {
+ [ "${ROOT}" != "/" ] && \
+ die "Sorry, non-standard \$ROOT setting is not supported :-("
+
+ for i in odbc.ini odbcinst.ini; do
+ einfo "Building $i"
+ /usr/bin/m4 -D__PN__=${PN} -D__PF__=${PF} ${FILESDIR}/${i}.m4 >${T}/${i}
+ done;
+
+ local msg='MySQL ODBC driver'
+ local drivers=$(/usr/bin/odbcinst -q -d)
+ if echo $drivers | grep -vq "^\[${PN}\]$" ; then
+ ebegin "Installing ${msg}"
+ /usr/bin/odbcinst -i -d -f ${T}/odbcinst.ini
+ rc=$?
+ eend $rc
+ [ $rc -ne 0 ] && die
+ else
+ einfo "Skipping already installed ${msg}"
+ fi
+
+ local sources=$(/usr/bin/odbcinst -q -s)
+ msg='sample MySQL ODBC DSN'
+ if echo $sources | grep -vq "^\[${PN}-test\]$"; then
+ ebegin "Installing ${msg}"
+ /usr/bin/odbcinst -i -s -l -f ${T}/odbc.ini
+ rc=$?
+ eend $rc
+ [ $rc -ne 0 ] && die
+ else
+ einfo "Skipping already installed ${msg}"
+ fi
+}
+
+pkg_postinst() {
+ elog "If this is a new install, please run the following command"
+ elog "to configure the MySQL ODBC drivers and sources:"
+ elog "emerge --config =${CATEGORY}/${PF}"
+}