summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-21 00:33:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-21 00:33:56 +0000
commit6c1cf50af442bc51cf589c79b9df22865e531278 (patch)
treecfc1b093e246140753b23b276f9486fe5f92b272 /dev-db
parentUpdate masking for ltsp. (diff)
downloadgentoo-2-6c1cf50af442bc51cf589c79b9df22865e531278.tar.gz
gentoo-2-6c1cf50af442bc51cf589c79b9df22865e531278.tar.bz2
gentoo-2-6c1cf50af442bc51cf589c79b9df22865e531278.zip
Version bump. Documentation seems to be no longer available.
(Portage version: 13655-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/sqlite-3.6.15.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 643e2fbde0d5..6702080e5b12 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.253 2009/05/28 20:53:11 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.254 2009/06/21 00:33:56 arfrever Exp $
+
+*sqlite-3.6.15 (21 Jun 2009)
+
+ 21 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sqlite-3.6.15.ebuild:
+ Version bump. Documentation seems to be no longer available.
28 May 2009; Ferris McCormick <fmccor@gentoo.org> sqlite-3.6.14.2.ebuild:
re-keyword for ~sparc, Bug #270867 Comment #8, #10.
diff --git a/dev-db/sqlite/sqlite-3.6.15.ebuild b/dev-db/sqlite/sqlite-3.6.15.ebuild
new file mode 100644
index 000000000000..39e79143da62
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.6.15.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.15.ebuild,v 1.1 2009/06/21 00:33:56 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib versionator
+
+DESCRIPTION="an SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug soundex tcl +threadsafe"
+RESTRICT="!tcl? ( test )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if has test ${FEATURES} ; then
+ if ! has userpriv ${FEATURES} ; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl ; then
+ ewarn "You must enable the tcl use flag if you want to run the testsuite."
+ eerror "Testsuite will not be run."
+ fi
+ fi
+}
+
+src_prepare() {
+ # note: this sandbox fix is no longer needed with sandbox-1.3+
+ epatch "${FILESDIR}"/sandbox-fix2.patch
+
+ epunt_cxx
+}
+
+src_configure() {
+ # Enable column metadata, bug #266651
+ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+ # not available via configure and requested in bug #143794
+ use soundex && append-cppflags -DSQLITE_SOUNDEX
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable threadsafe) \
+ $(use_enable threadsafe cross-thread-connections) \
+ $(use_enable tcl)
+}
+
+src_compile() {
+ emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
+}
+
+src_test() {
+ if has userpriv ${FEATURES} ; then
+ local test=test
+ use debug && test=fulltest
+ emake ${test} || die "some test(s) failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)/${P}" \
+ install \
+ || die "emake install failed"
+
+ doman sqlite3.1 || die "doman sqlite3.1 failed"
+}