summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-03-07 16:25:45 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-03-07 16:25:45 +0000
commit65054e1392640b165bafd489c4d24b7e76793aee (patch)
treea16222678e40c197ce9102279b951f1fcfc6036d /dev-db
parentAdd ~x86-fbsd (diff)
downloadgentoo-2-65054e1392640b165bafd489c4d24b7e76793aee.tar.gz
gentoo-2-65054e1392640b165bafd489c4d24b7e76793aee.tar.bz2
gentoo-2-65054e1392640b165bafd489c4d24b7e76793aee.zip
must not set ABI for non-multilib-able archs at all
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog6
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild8
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
index 13e1126df019..bbb59335ebfa 100644
--- a/dev-db/oracle-instantclient-jdbc/ChangeLog
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/oracle-instantclient-jdbc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.31 2012/03/07 15:33:54 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.32 2012/03/07 16:25:45 haubi Exp $
+
+ 07 Mar 2012; Michael Haubenwallner <haubi@gentoo.org>
+ oracle-instantclient-jdbc-11.2.0.3.ebuild:
+ must not set ABI for non-multilib-able archs at all
07 Mar 2012; Michael Haubenwallner <haubi@gentoo.org>
oracle-instantclient-jdbc-11.2.0.3.ebuild:
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild
index 699f980c170d..3cbe3cfd4a7d 100644
--- a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild,v 1.2 2012/03/07 15:33:54 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild,v 1.3 2012/03/07 16:25:45 haubi Exp $
EAPI="4"
@@ -53,8 +53,10 @@ set_abivars() {
MY_A=${!MY_A}
# abi sourcedir
MY_S="${S}/${abi}/instantclient_11_2"
+ # ABI might not need to be set at all
+ [[ -n ${ABI} ]] && MY_ABI=${abi} || MY_ABI=
# abi libdir
- MY_LIBDIR=$(ABI=${abi} get_libdir)
+ MY_LIBDIR=$(ABI=${MY_ABI} get_libdir)
}
pkg_nofetch() {
@@ -96,7 +98,7 @@ src_install() {
cd "${MY_S}" || die
- ABI=${abi} dolib.so lib*$(get_libname)*
+ ABI=${MY_ABI} dolib.so lib*$(get_libname)*
insinto "${oracle_home}"/${MY_LIBDIR}
doins *.jar