summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-05-05 15:30:51 +0000
committerPeter Volkov <pva@gentoo.org>2007-05-05 15:30:51 +0000
commit604ed9b31d80f162897c446928fa941b4984cee0 (patch)
tree2406ef4ed94b8a7e16c04c59085d43976f0714ad /dev-db
parentUse RDEPEND instead of DEPEND (diff)
downloadgentoo-2-604ed9b31d80f162897c446928fa941b4984cee0.tar.gz
gentoo-2-604ed9b31d80f162897c446928fa941b4984cee0.tar.bz2
gentoo-2-604ed9b31d80f162897c446928fa941b4984cee0.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.583
-rw-r--r--dev-db/gigabase/gigabase-3.58.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index dc4179a9204a..ce82a2f1a1de 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.24 2007/04/08 09:43:52 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.25 2007/05/05 15:30:51 pva Exp $
+
+*gigabase-3.58 (05 May 2007)
+
+ 05 May 2007; <pva@gentoo.org> +gigabase-3.58.ebuild:
+ Version bump.
08 Apr 2007; Christian Faulhammer <opfer@gentoo.org> gigabase-3.54.ebuild:
stable amd64, bug 168564
diff --git a/dev-db/gigabase/files/digest-gigabase-3.58 b/dev-db/gigabase/files/digest-gigabase-3.58
new file mode 100644
index 000000000000..7dc55ec6c74e
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.58
@@ -0,0 +1,3 @@
+MD5 ccc5218018fec4fe2a6b1c3722c5c26b gigabase-3.58.tar.gz 1421459
+RMD160 c6e681efb80bc3deecaf7441fc84aee4424b9bdd gigabase-3.58.tar.gz 1421459
+SHA256 19d0fe6354285f3085b51a8a180c1381320da3deb1bc61e833829bb3bda9c2e0 gigabase-3.58.tar.gz 1421459
diff --git a/dev-db/gigabase/gigabase-3.58.ebuild b/dev-db/gigabase/gigabase-3.58.ebuild
new file mode 100644
index 000000000000..1b0b02713e7d
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.58.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.58.ebuild,v 1.1 2007/05/05 15:30:51 pva Exp $
+
+inherit eutils libtool multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}"/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}