summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2010-12-15 20:17:01 +0000
committerJesus Rivero <neurogeek@gentoo.org>2010-12-15 20:17:01 +0000
commit5e85cb4adccc72fae60d261131f2145e6989fa19 (patch)
tree602e7263b700b85f89cf23a1fa7e81c578c0a9ac /dev-db
parentAnothe linking fix (diff)
downloadgentoo-2-5e85cb4adccc72fae60d261131f2145e6989fa19.tar.gz
gentoo-2-5e85cb4adccc72fae60d261131f2145e6989fa19.tar.bz2
gentoo-2-5e85cb4adccc72fae60d261131f2145e6989fa19.zip
Version bump. Closes bug #333375
(Portage version: 2.2_rc95/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/desktopcouch/ChangeLog10
-rw-r--r--dev-db/desktopcouch/desktopcouch-0.6.9_beta.ebuild59
-rw-r--r--dev-db/desktopcouch/files/desktopcouch-0.6.9b-drop_ubuntuone_support.patch12
-rw-r--r--dev-db/desktopcouch/files/desktopcouch-0.6.9b-setup_hardlinks.patch32
4 files changed, 112 insertions, 1 deletions
diff --git a/dev-db/desktopcouch/ChangeLog b/dev-db/desktopcouch/ChangeLog
index 20fc19b669d0..01ebdcc511f7 100644
--- a/dev-db/desktopcouch/ChangeLog
+++ b/dev-db/desktopcouch/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/desktopcouch
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/ChangeLog,v 1.4 2010/04/27 18:45:43 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/ChangeLog,v 1.5 2010/12/15 20:17:01 neurogeek Exp $
+
+*desktopcouch-0.6.9_beta (15 Dec 2010)
+
+ 15 Dec 2010; Jesus Rivero <neurogeek@gentoo.org>
+ +desktopcouch-0.6.9_beta.ebuild,
+ +files/desktopcouch-0.6.9b-drop_ubuntuone_support.patch,
+ +files/desktopcouch-0.6.9b-setup_hardlinks.patch:
+ Version bump. Closes bug #333375
27 Apr 2010; Jesus Rivero <neurogeek@gentoo.org>
-desktopcouch-0.6.1-r1.ebuild:
diff --git a/dev-db/desktopcouch/desktopcouch-0.6.9_beta.ebuild b/dev-db/desktopcouch/desktopcouch-0.6.9_beta.ebuild
new file mode 100644
index 000000000000..5fe8ba7c8220
--- /dev/null
+++ b/dev-db/desktopcouch/desktopcouch-0.6.9_beta.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/desktopcouch/desktopcouch-0.6.9_beta.ebuild,v 1.1 2010/12/15 20:17:01 neurogeek Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+inherit distutils eutils multilib
+
+DESCRIPTION="Desktop-oriented interface to CouchDB"
+HOMEPAGE="https://launchpad.net/desktopcouch"
+SRC_URI="http://launchpad.net/desktopcouch/trunk/${MY_PV}/+download/${MY_P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-python/python-distutils-extra-2.12"
+RDEPEND=">=dev-db/couchdb-0.10.0
+ >=dev-python/gnome-keyring-python-2.22.3-r1
+ <dev-python/couchdb-python-0.7
+ >=dev-python/oauth-1.0.1
+ >=dev-python/simplejson-2.0.9-r1
+ >=dev-python/twisted-8.2.0-r2
+ >=net-dns/avahi-0.6.24-r2[python]"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${MY_P}-setup_hardlinks.patch"
+ epatch "${FILESDIR}/${MY_P}-drop_ubuntuone_support.patch"
+}
+
+src_install() {
+ python_convert_shebangs -r 2 "bin/"
+
+ distutils_src_install
+
+ exeinto "/usr/$(get_libdir)/${PN}"
+ doexe "bin/desktopcouch-stop"
+ doexe "bin/desktopcouch-service"
+ doexe "bin/desktopcouch-get-port"
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}/api"
+ doins "desktopcouch/records/doc/records.txt"
+ doins "desktopcouch/records/doc/field_registry.txt"
+ doins "desktopcouch/contacts/schema.txt"
+
+ doman "docs/man/desktopcouch-pair.1"
+ fi
+}
diff --git a/dev-db/desktopcouch/files/desktopcouch-0.6.9b-drop_ubuntuone_support.patch b/dev-db/desktopcouch/files/desktopcouch-0.6.9b-drop_ubuntuone_support.patch
new file mode 100644
index 000000000000..3f0b9a239fb4
--- /dev/null
+++ b/dev-db/desktopcouch/files/desktopcouch-0.6.9b-drop_ubuntuone_support.patch
@@ -0,0 +1,12 @@
+#We dont have ubuntu_sso package in the tree. Maybe this patch
+#can be dropped later on.
+#Jesus Rivero <neurogeek>
+#Dec. 15, 2010
+--- desktopcouch/replication_services/__init__.py.orig 2010-12-15 09:31:29.000000000 -0500
++++ desktopcouch/replication_services/__init__.py 2010-12-15 09:30:53.000000000 -0500
+@@ -1,4 +1,4 @@
+ """Modules imported here are available as services."""
+
+-import ubuntuone
++#import ubuntuone
+ import example
diff --git a/dev-db/desktopcouch/files/desktopcouch-0.6.9b-setup_hardlinks.patch b/dev-db/desktopcouch/files/desktopcouch-0.6.9b-setup_hardlinks.patch
new file mode 100644
index 000000000000..ed90ec0c32ca
--- /dev/null
+++ b/dev-db/desktopcouch/files/desktopcouch-0.6.9b-setup_hardlinks.patch
@@ -0,0 +1,32 @@
+--- setup.py.orig 2010-12-15 08:55:27.000000000 -0500
++++ setup.py 2010-12-15 09:05:32.000000000 -0500
+@@ -31,19 +31,21 @@
+ test_suite="runtests.get_test_suite",
+ packages=find_packages(),
+ scripts=['bin/desktopcouch-pair'],
+- data_files = [('/usr/lib/desktopcouch/', ['bin/desktopcouch-service',
+- 'bin/desktopcouch-get-port',
+- 'bin/desktopcouch-stop']),
++ data_files = [
++# data_files = [('/usr/lib/desktopcouch/', ['bin/desktopcouch-service',
++# 'bin/desktopcouch-get-port',
++# 'bin/desktopcouch-stop']),
+ # Be sure all additions are reflected in MANIFEST.in !
+- ('/usr/share/doc/python-desktopcouch-records/api/',
+- ['desktopcouch/records/doc/records.txt',
+- 'desktopcouch/records/doc/field_registry.txt',
+- 'desktopcouch/contacts/schema.txt']),
++# ('/usr/share/doc/python-desktopcouch-records/api/',
++# ['desktopcouch/records/doc/records.txt',
++# 'desktopcouch/records/doc/field_registry.txt',
++# 'desktopcouch/contacts/schema.txt']),
+ ('/etc/xdg/desktop-couch/',
+ ['config/desktop-couch/compulsory-auth.ini']),
+ ('/usr/share/desktopcouch/', ['data/couchdb.tmpl']),
+ ('/usr/share/dbus-1/services/', ['org.desktopcouch.CouchDB.service']),
+- ('share/man/man1/', ['docs/man/desktopcouch-pair.1'])],
++# ('share/man/man1/', ['docs/man/desktopcouch-pair.1'])],
++ ],
+ cmdclass = { "build" : build_extra.build_extra,
+ "build_i18n" : build_i18n.build_i18n }
+ )