summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2006-06-23 21:09:23 +0000
committerAnders Rune Jensen <arj@gentoo.org>2006-06-23 21:09:23 +0000
commit5c2d34f3809663b13e9edad7a18781cba27c787a (patch)
tree0987449e745468e8110c118e27f8a99fe0057fe9 /dev-db
parentStable on sparc (diff)
downloadgentoo-2-5c2d34f3809663b13e9edad7a18781cba27c787a.tar.gz
gentoo-2-5c2d34f3809663b13e9edad7a18781cba27c787a.tar.bz2
gentoo-2-5c2d34f3809663b13e9edad7a18781cba27c787a.zip
new version
(Portage version: 2.1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.3.63
-rw-r--r--dev-db/sqlite/sqlite-3.3.6.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index ee4b62127feb..aac8db93bf74 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.114 2006/06/21 20:37:06 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.115 2006/06/23 21:09:23 arj Exp $
+
+*sqlite-3.3.6 (23 Jun 2006)
+
+ 23 Jun 2006; Anders Rune Jensen <arj@gentoo.org> +sqlite-3.3.6.ebuild:
+ New version fixes #137466
21 Jun 2006; Markus Rothe <corsair@gentoo.org> sqlite-2.8.16-r4.ebuild,
sqlite-3.3.5-r1.ebuild:
diff --git a/dev-db/sqlite/files/digest-sqlite-3.3.6 b/dev-db/sqlite/files/digest-sqlite-3.3.6
new file mode 100644
index 000000000000..4e900e49e778
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-3.3.6
@@ -0,0 +1,3 @@
+MD5 a2cb1fafad5c2587e513dcbd18ace097 sqlite-3.3.6.tar.gz 1671437
+RMD160 37d140d5670b39a7da79f9f3d2ac31c521d90676 sqlite-3.3.6.tar.gz 1671437
+SHA256 32be612f762338fa61ec41a566ca56fb989416df99380acadbf37a5e16a05796 sqlite-3.3.6.tar.gz 1671437
diff --git a/dev-db/sqlite/sqlite-3.3.6.ebuild b/dev-db/sqlite/sqlite-3.3.6.ebuild
new file mode 100644
index 000000000000..86f3ce006edc
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.3.6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.6.ebuild,v 1.1 2006/06/23 21:09:23 arj Exp $
+
+inherit eutils alternatives
+
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
+IUSE="nothreadsafe doc tcltk debug"
+
+DEPEND="virtual/libc
+ doc? ( dev-lang/tcl )
+ tcltk? ( dev-lang/tcl )"
+
+SOURCE="/usr/bin/lemon"
+ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+
+src_unpack() {
+ # test
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ ewarn "Testsuite will not be run."
+ fi
+ if ! use tcltk; then
+ ewarn "The tcltk useflag must be enabled to run tests."
+ ewarn "Testsuite will not be run."
+ fi
+ fi
+
+ unpack ${A}
+
+ cd ${P}
+ epatch ${FILESDIR}/sqlite-3.3.3-tcl-fix.patch
+ epatch ${FILESDIR}/sqlite-3-test-fix-3.3.4.patch
+
+ epatch ${FILESDIR}/sandbox-fix1.patch
+ epatch ${FILESDIR}/sandbox-fix2.patch
+
+ # Fix broken tests that are not portable to 64 arches
+ epatch ${FILESDIR}/sqlite-64bit-test-fix.patch
+ epatch ${FILESDIR}/sqlite-64bit-test-fix2.patch
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--enable-incore-db --enable-tempdb-in-ram --enable-cross-thread-connections"
+
+ if ! use nothreadsafe; then
+ myconf="${myconf} --enable-threadsafe"
+ else
+ myconf="${myconf} --disable-threadsafe"
+ fi
+
+ if ! use tcltk; then
+ myconf="${myconf} --disable-tcl"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf ${myconf} || die
+ emake all || die
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ if use tcltk ; then
+ if has usepriv ${FEATURES} ; then
+ cd ${S}
+ if use debug; then
+ emake fulltest || die "some test failed"
+ else
+ emake test || die "some test failed"
+ fi
+ fi
+ fi
+}
+
+src_install () {
+ make \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)" \
+ install || die
+
+ newbin lemon lemon-${SLOT}
+
+ dodoc README VERSION
+ doman sqlite3.1
+
+ if use doc; then
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+ fi
+}