summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-02 08:55:33 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-02 08:55:33 +0000
commit5711eaa099d91efd281e02d5554e9926ed490b29 (patch)
treee9f336542b7c0fed2a07ac1262984e405884b255 /dev-db
parentCleanup ebuild and add ppc/ppc64 love for KDE 4. (diff)
downloadgentoo-2-5711eaa099d91efd281e02d5554e9926ed490b29.tar.gz
gentoo-2-5711eaa099d91efd281e02d5554e9926ed490b29.tar.bz2
gentoo-2-5711eaa099d91efd281e02d5554e9926ed490b29.zip
Fixed postgresql-8.3 issue, bug #239594. Removed old revisions.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgmecab/ChangeLog9
-rw-r--r--dev-db/pgmecab/files/pgmecab-1.1-postgres83.patch20
-rw-r--r--dev-db/pgmecab/pgmecab-1.1-r2.ebuild (renamed from dev-db/pgmecab/pgmecab-1.1-r1.ebuild)13
-rw-r--r--dev-db/pgmecab/pgmecab-1.1.ebuild29
4 files changed, 36 insertions, 35 deletions
diff --git a/dev-db/pgmecab/ChangeLog b/dev-db/pgmecab/ChangeLog
index 43b706e56226..f29f5b8fd123 100644
--- a/dev-db/pgmecab/ChangeLog
+++ b/dev-db/pgmecab/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/pgmecab
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/ChangeLog,v 1.3 2008/08/14 23:54:50 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/ChangeLog,v 1.4 2008/11/02 08:55:33 matsuu Exp $
+
+*pgmecab-1.1-r2 (02 Nov 2008)
+
+ 02 Nov 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/pgmecab-1.1-postgres83.patch, -pgmecab-1.1.ebuild,
+ -pgmecab-1.1-r1.ebuild, +pgmecab-1.1-r2.ebuild:
+ Fixed postgresql-8.3 issue, bug #239594. Removed old revisions.
*pgmecab-1.1-r1 (14 Aug 2008)
diff --git a/dev-db/pgmecab/files/pgmecab-1.1-postgres83.patch b/dev-db/pgmecab/files/pgmecab-1.1-postgres83.patch
new file mode 100644
index 000000000000..30d2e87a8e2f
--- /dev/null
+++ b/dev-db/pgmecab/files/pgmecab-1.1-postgres83.patch
@@ -0,0 +1,20 @@
+--- pgmecab.c.orig 2008-10-05 13:24:34.000000000 +0200
++++ pgmecab.c 2008-10-05 13:25:17.000000000 +0200
+@@ -24,7 +24,7 @@
+ static Datum returnEmptyStr()
+ {
+ text* emptyVal = (text*) palloc(VARHDRSZ);
+- VARATT_SIZEP(emptyVal) = VARHDRSZ;
++ SET_VARLENA_LEN(emptyVal, VARHDRSZ);
+ PG_RETURN_TEXT_P(emptyVal);
+ }
+
+@@ -90,7 +90,7 @@
+
+ /* 返すためのメモリ確保 */
+ text* return_val = (text *) palloc(VARHDRSZ + mecab_result_size * sizeof(char));
+- VARATT_SIZEP(return_val) = VARHDRSZ + mecab_result_size * sizeof(char);
++ SET_VARLENA_LEN(return_val, VARHDRSZ + mecab_result_size * sizeof(char));
+
+ /* 結果をコピー */
+ memcpy((void*)VARDATA(return_val), mecab_result, mecab_result_size);
diff --git a/dev-db/pgmecab/pgmecab-1.1-r1.ebuild b/dev-db/pgmecab/pgmecab-1.1-r2.ebuild
index 1d7f215e5eca..ac7d91f144d3 100644
--- a/dev-db/pgmecab/pgmecab-1.1-r1.ebuild
+++ b/dev-db/pgmecab/pgmecab-1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/pgmecab-1.1-r1.ebuild,v 1.1 2008/08/14 23:54:50 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/pgmecab-1.1-r2.ebuild,v 1.1 2008/11/02 08:55:33 matsuu Exp $
inherit eutils
@@ -8,18 +8,19 @@ DESCRIPTION="PostgreSQL function to Wakachigaki for Japanese words"
HOMEPAGE="http://www.emaki.minidns.net/Programming/postgres/index.html"
SRC_URI="http://www.emaki.minidns.net/Programming/postgres/${P}.tar.bz2"
-DEPEND="app-text/mecab
- >=virtual/postgresql-server-7.4"
-
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+DEPEND="app-text/mecab
+ >=virtual/postgresql-server-7.4"
+
src_unpack () {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-postgres83.patch"
}
src_compile() {
@@ -28,4 +29,6 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" USE_PGXS=1 install || die
+
+ dodoc README.pgmecab
}
diff --git a/dev-db/pgmecab/pgmecab-1.1.ebuild b/dev-db/pgmecab/pgmecab-1.1.ebuild
deleted file mode 100644
index 8638dc608e5f..000000000000
--- a/dev-db/pgmecab/pgmecab-1.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/pgmecab-1.1.ebuild,v 1.2 2008/05/21 15:56:55 dev-zero Exp $
-
-DESCRIPTION="PostgreSQL function to Wakachigaki for Japanese words"
-HOMEPAGE="http://www.emaki.minidns.net/Programming/postgres/index.html"
-SRC_URI="http://www.emaki.minidns.net/Programming/postgres/${P}.tar.bz2"
-
-DEPEND="app-text/mecab
- >=virtual/postgresql-server-7.4"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_unpack () {
- unpack ${A}
- cd ${S}
- sed -i -e 's:^MECAB_CONFIG_PATH.*$:MECAB_CONFIG_PATH=/usr/bin/mecab-config:' Makefile
-}
-
-src_compile() {
- make USE_PGXS=1
-}
-
-src_install() {
- make DESTDIR=${D} USE_PGXS=1 install
-}