summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-05-30 03:42:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-05-30 03:42:10 +0000
commit4dde6d00dab15eed9ed4535aac1a79a4e155d850 (patch)
tree1399448de1654efb193f824e1a991465a76bea41 /dev-db
parentKeywording assp-1.9 again (diff)
downloadgentoo-2-4dde6d00dab15eed9ed4535aac1a79a4e155d850.tar.gz
gentoo-2-4dde6d00dab15eed9ed4535aac1a79a4e155d850.tar.bz2
gentoo-2-4dde6d00dab15eed9ed4535aac1a79a4e155d850.zip
Bump for #417955
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/kyotocabinet/ChangeLog7
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.76.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index 865d97db26b9..43c10c878fe2 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.17 2012/05/11 14:36:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.18 2012/05/30 03:42:10 patrick Exp $
+
+*kyotocabinet-1.2.76 (30 May 2012)
+
+ 30 May 2012; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.76.ebuild:
+ Bump for #417955
*kyotocabinet-1.2.75 (11 May 2012)
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.76.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.76.ebuild
new file mode 100644
index 000000000000..29e880998e7a
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.76.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.76.ebuild,v 1.1 2012/05/30 03:42:10 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples static-libs"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_configure-1.2.62.patch"
+ sed -ie "/ldconfig/d" Makefile.in
+ sed -ie "/DOCDIR/d" Makefile.in
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable !static-libs shared) \
+ --enable-lzma --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}