summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-04-06 20:48:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-04-06 20:48:47 +0000
commit4b675b018ac267520dc738404133158e059f792e (patch)
treea64fb13fbcda294d62c32dba08c346fd975ffff4 /dev-db
parentwtf, I left out all the new fam stuff entirely. Sorry about. Thanks Magnade (diff)
downloadgentoo-2-4b675b018ac267520dc738404133158e059f792e.tar.gz
gentoo-2-4b675b018ac267520dc738404133158e059f792e.tar.bz2
gentoo-2-4b675b018ac267520dc738404133158e059f792e.zip
cleanups and remove redundant/useless patch
(Portage version: 1.585-cvs)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqsh/ChangeLog6
-rw-r--r--dev-db/sqsh/files/config.patch24
-rw-r--r--dev-db/sqsh/sqsh-2.1-r1.ebuild38
3 files changed, 21 insertions, 47 deletions
diff --git a/dev-db/sqsh/ChangeLog b/dev-db/sqsh/ChangeLog
index dbbbee96fac9..85d161401aef 100644
--- a/dev-db/sqsh/ChangeLog
+++ b/dev-db/sqsh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqsh
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/ChangeLog,v 1.11 2005/01/01 17:43:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/ChangeLog,v 1.12 2005/04/06 20:48:47 seemant Exp $
+
+ 06 Apr 2005; Seemant Kulleen <seemant@gentoo.org> -files/config.patch,
+ sqsh-2.1-r1.ebuild:
+ cleanups and remove redundant/useless patch
29 Jun 2004; Aron Griffis <agriffis@gentoo.org> sqsh-2.1-r1.ebuild,
sqsh-2.1.ebuild:
diff --git a/dev-db/sqsh/files/config.patch b/dev-db/sqsh/files/config.patch
deleted file mode 100644
index d7936bd302d5..000000000000
--- a/dev-db/sqsh/files/config.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-59,60c59,60
-< /* #undef HAVE_STRCASECMP */
-< /* #undef HAVE_STRERROR */
----
-> #define HAVE_STRCASECMP 1
-> #define HAVE_STRERROR 1
-62,67c62,67
-< /* #undef HAVE_STRFTIME */
-< /* #undef HAVE_MEMCPY */
-< /* #undef HAVE_MEMMOVE */
-< /* #undef HAVE_LOCALTIME */
-< /* #undef HAVE_TIMELOCAL */
-< /* #undef HAVE_STRCHR */
----
-> #define HAVE_STRFTIME 1
-> #define HAVE_MEMCPY 1
-> #define HAVE_MEMMOVE 1
-> #define HAVE_LOCALTIME 1
-> #define HAVE_TIMELOCAL 1
-> #define HAVE_STRCHR 1
-69c69
-< /* #undef HAVE_GETTIMEOFDAY */
----
-> #define HAVE_GETTIMEOFDAY 1
diff --git a/dev-db/sqsh/sqsh-2.1-r1.ebuild b/dev-db/sqsh/sqsh-2.1-r1.ebuild
index acad1aaa14c2..884aa0a0052e 100644
--- a/dev-db/sqsh/sqsh-2.1-r1.ebuild
+++ b/dev-db/sqsh/sqsh-2.1-r1.ebuild
@@ -1,42 +1,36 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/sqsh-2.1-r1.ebuild,v 1.8 2005/01/01 17:43:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/sqsh-2.1-r1.ebuild,v 1.9 2005/04/06 20:48:47 seemant Exp $
+
+inherit eutils
DESCRIPTION="Replacement for the venerable 'isql' program supplied by Sybase."
HOMEPAGE="http://www.sqsh.org/"
+SRC_URI="http://www.sqsh.org/${P}-src.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+IUSE="readline X motif"
+KEYWORDS="x86 ~amd64"
+
DEPEND="dev-db/freetds
readline? ( sys-libs/readline )
X? ( virtual/x11 )
motif? ( x11-libs/openmotif )
virtual/libc"
-SLOT="0"
-SRC_URI="http://www.sqsh.org/${P}-src.tar.gz"
-KEYWORDS="x86 ~amd64"
-IUSE="readline X motif"
src_compile() {
export SYBASE=/usr
local myconf
- use readline \
- && myconf="${myconf} --with-readline"
-
- use X \
- && myconf="${myconf} --with-x"
-
- use motif \
- && myconf="${myconf} --with-motif"
-
- ./configure \
- ${myconf} \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ use motif && myconf="--with-motif"
+
+ econf \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die
- patch src/config.h ${FILESDIR}/config.patch
emake SQSHRC_GLOBAL=/etc/sqshrc || die
}
@@ -50,7 +44,7 @@ src_install () {
infodir=${D}/usr/share/info \
install install.man || die
# fix the silly placement of sqshrc
- mkdir -p ${D}/etc
+ dodir /etc
mv ${D}/usr/etc/sqshrc ${D}/etc/
rmdir ${D}/usr/etc
dodoc COPYING INSTALL README doc/*