summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-15 15:30:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-15 15:30:38 +0000
commit43a7075c116f68ded226f17f625cf55c9231b428 (patch)
tree5b9f9b17b722f57e1ce8cdd8fdec4d50c8cfc865 /dev-db
parentAdd ~sparc for testing, thanks to Tiago Cunha --- Bug #205908. (diff)
downloadgentoo-2-43a7075c116f68ded226f17f625cf55c9231b428.tar.gz
gentoo-2-43a7075c116f68ded226f17f625cf55c9231b428.tar.bz2
gentoo-2-43a7075c116f68ded226f17f625cf55c9231b428.zip
Add MySQL-5.0.54 to the tree. Unlike some of the intervening releases, this one actually works and passes both the testsuite and my own tests.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog10
-rw-r--r--dev-db/mysql/files/digest-mysql-5.0.546
-rw-r--r--dev-db/mysql/mysql-5.0.54.ebuild62
3 files changed, 76 insertions, 2 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 526adc0e442e..b9d6f2fe3bbc 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.436 2007/11/18 13:50:41 corsair Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.437 2008/01/15 15:30:38 robbat2 Exp $
+
+*mysql-5.0.54 (15 Jan 2008)
+
+ 15 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.0.54.ebuild:
+ Add MySQL-5.0.54 to the tree. Unlike some of the intervening releases, this
+ one actually works and passes both the testsuite and my own tests.
18 Nov 2007; Markus Rothe <corsair@gentoo.org> mysql-5.0.44-r2.ebuild:
Stable on ppc64; bug #198988
diff --git a/dev-db/mysql/files/digest-mysql-5.0.54 b/dev-db/mysql/files/digest-mysql-5.0.54
new file mode 100644
index 000000000000..c599f54a2522
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-5.0.54
@@ -0,0 +1,6 @@
+MD5 9079ced91e23c4c7aa54891448055b70 mysql-5.0.54.tar.gz 27397332
+RMD160 50898b7339cad1339cfdcf01e75c8e851d837d80 mysql-5.0.54.tar.gz 27397332
+SHA256 d3431038e594c6e6b480d2d7a24bca7166bb5e593c9d807140257ed06b105a66 mysql-5.0.54.tar.gz 27397332
+MD5 cbf7ee02288d2c4fe991b0d27a18b844 mysql-extras-20080115.tar.bz2 107545
+RMD160 bfd437a5ef455aaa4601ed2ae2d4ca9604ceaa34 mysql-extras-20080115.tar.bz2 107545
+SHA256 7c36516dca51b74f5e42a3388ff122623e6203f40cb23bed36b0bf942ac1db4b mysql-extras-20080115.tar.bz2 107545
diff --git a/dev-db/mysql/mysql-5.0.54.ebuild b/dev-db/mysql/mysql-5.0.54.ebuild
new file mode 100644
index 000000000000..479e2eb041f9
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.54.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.1 2008/01/15 15:30:38 robbat2 Exp $
+
+MY_EXTRAS_VER="20080115"
+SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if ! hasq "userpriv" ${FEATURES} ; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Broken in 5.0.42" ;;
+
+ 5.0.44|5.0.45|5.0.46|5.0.48|5.0.50|5.0.52|5.0.54)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.44-54 on big-endian boxes only" ;;
+
+ esac
+
+ # We run the test protocols seperately
+ make -j1 test-ns force=--force
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force=--force
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}