summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-10 04:25:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-10 04:25:29 +0000
commit40a67e220654ba3965cf0e87ffcf2a1a970c4249 (patch)
tree78352cb9ccca05549781a14a46bab2aa7053c7bd /dev-db
parentBump (diff)
downloadgentoo-2-40a67e220654ba3965cf0e87ffcf2a1a970c4249.tar.gz
gentoo-2-40a67e220654ba3965cf0e87ffcf2a1a970c4249.tar.bz2
gentoo-2-40a67e220654ba3965cf0e87ffcf2a1a970c4249.zip
Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql-docs/ChangeLog8
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.4_beta3.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index d2dbe377023c..6253431f11ac 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql-docs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.248 2014/09/19 10:42:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.249 2014/10/10 04:25:29 patrick Exp $
+
+*postgresql-docs-9.4_beta3 (10 Oct 2014)
+
+ 10 Oct 2014; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-docs-9.4_beta3.ebuild:
+ Bump
19 Sep 2014; Agostino Sarubbo <ago@gentoo.org> -postgresql-docs-9.0.16.ebuild,
-postgresql-docs-9.0.17.ebuild, -postgresql-docs-9.1.12.ebuild,
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.4_beta3.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.4_beta3.ebuild
new file mode 100644
index 000000000000..5e21e2f567e5
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.4_beta3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.4_beta3.ebuild,v 1.1 2014/10/10 04:25:29 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+S="${WORKDIR}/postgresql-${MY_PV}"
+SRC_URI="mirror://postgresql/source/v${MY_PV}/postgresql-${MY_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+#S="${WORKDIR}/postgresql-${PV}"
+#SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}