summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-02-06 14:07:36 +0000
committerBrian Evans <grknight@gentoo.org>2015-02-06 14:07:36 +0000
commit2e8a655710fd564b959c764b90d34ba5f6941d3a (patch)
tree05fb2ca32a0ef277698107e4bda5d00c75a86582 /dev-db
parentOld. (diff)
downloadgentoo-2-2e8a655710fd564b959c764b90d34ba5f6941d3a.tar.gz
gentoo-2-2e8a655710fd564b959c764b90d34ba5f6941d3a.tar.bz2
gentoo-2-2e8a655710fd564b959c764b90d34ba5f6941d3a.zip
Version bump with security fixes; drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D1F781EFF9F4A3B6)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mariadb-galera/ChangeLog9
-rw-r--r--dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild123
-rw-r--r--dev-db/mariadb-galera/mariadb-galera-10.0.14.ebuild123
-rw-r--r--dev-db/mariadb-galera/mariadb-galera-10.0.16.ebuild (renamed from dev-db/mariadb-galera/mariadb-galera-10.0.15.ebuild)18
4 files changed, 23 insertions, 250 deletions
diff --git a/dev-db/mariadb-galera/ChangeLog b/dev-db/mariadb-galera/ChangeLog
index 815143e779ee..bf0202fe50b6 100644
--- a/dev-db/mariadb-galera/ChangeLog
+++ b/dev-db/mariadb-galera/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/mariadb-galera
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/ChangeLog,v 1.12 2015/01/28 17:41:06 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/ChangeLog,v 1.13 2015/02/06 14:07:36 grknight Exp $
+
+*mariadb-galera-10.0.16 (06 Feb 2015)
+
+ 06 Feb 2015; Brian Evans <grknight@gentoo.org> +mariadb-galera-10.0.16.ebuild,
+ -mariadb-galera-10.0.13.ebuild, -mariadb-galera-10.0.14.ebuild,
+ -mariadb-galera-10.0.15.ebuild:
+ Version bump with security fixes; drop old
28 Jan 2015; Brian Evans <grknight@gentoo.org> metadata.xml:
Drop old USE description
diff --git a/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild b/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild
deleted file mode 100644
index d634c6aba0a2..000000000000
--- a/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild,v 1.4 2014/10/06 17:44:30 grknight Exp $
-
-EAPI="5"
-MY_EXTRAS_VER="20140903-1928Z"
-WSREP_REVISION="25"
-
-inherit toolchain-funcs mysql-multilib
-# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
-
-# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~amd64 ~x86"
-
-# When MY_EXTRAS is bumped, the index should be revised to exclude these.
-EPATCH_EXCLUDE=''
-
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
-RDEPEND="${RDEPEND}"
-
-# Please do not add a naive src_unpack to this ebuild
-# If you want to add a single patch, copy the ebuild to an overlay
-# and create your own mysql-extras tarball, looking at 000_index.txt
-
-# Official test instructions:
-# USE='-cluster embedded extraengine perl ssl static-libs community' \
-# FEATURES='test userpriv -usersandbox' \
-# ebuild mariadb-galera-X.X.XX.ebuild \
-# digest clean package
-multilib_src_test() {
-
- if ! multilib_is_native_abi ; then
- einfo "Server tests not available on non-native abi".
- return 0;
- fi
-
- local TESTDIR="${BUILD_DIR}/mysql-test"
- local retstatus_unit
- local retstatus_tests
-
- # Bug #213475 - MySQL _will_ object strenously if your machine is named
- # localhost. Also causes weird failures.
- [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
-
- if ! use "minimal" ; then
-
- if [[ $UID -eq 0 ]]; then
- die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
- fi
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- addpredict /this-dir-does-not-exist/t9.MYI
-
- # Run CTest (test-units)
- cmake-utils_src_test
- retstatus_unit=$?
- [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
-
- # Ensure that parallel runs don't die
- export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- # You may set this by hand.
- # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
- export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
-
- # create directories because mysqladmin might right out of order
- mkdir -p "${T}"/var-tests{,/log}
-
- # These are failing in MariaDB 10.0 for now and are believed to be
- # false positives:
- #
- # main.information_schema, binlog.binlog_statement_insert_delayed,
- # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
- # funcs_1.is_columns_mysql
- # fails due to USE=-latin1 / utf8 default
- #
- # main.mysql_client_test, main.mysql_client_test_nonblock
- # mina.mysql_client_test_comp:
- # segfaults at random under Portage only, suspect resource limits.
- #
- # innodb.innodb_simulate_comp_failures_small
- # Has a very long timeout requirement to be consistent
- # Upstream bug MDEV-6546
- #
-
- for t in main.mysql_client_test main.mysql_client_test_nonblock \
- main.mysql_client_test_comp \
- binlog.binlog_statement_insert_delayed main.information_schema \
- main.mysqld--help innodb.innodb_simulate_comp_failures_small \
- funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
- mysql-multilib_disable_test "$t" "False positives in Gentoo"
- done
-
- # Run mysql tests
- pushd "${TESTDIR}"
-
- # run mysql-test tests
- # Skip all CONNECT engine tests until upstream respondes to how to reference data files
- perl mysql-test-run.pl --force --vardir="${T}/var-tests" \
- --skip-test=connect
- retstatus_tests=$?
- [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- popd
-
- # Cleanup is important for these testcases.
- pkill -9 -f "${S}/ndb" 2>/dev/null
- pkill -9 -f "${S}/sql" 2>/dev/null
-
- failures=""
- [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
- [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- [[ -z "$failures" ]] || die "Test failures: $failures"
- einfo "Tests successfully completed"
- else
-
- einfo "Skipping server tests due to minimal build."
- fi
-}
diff --git a/dev-db/mariadb-galera/mariadb-galera-10.0.14.ebuild b/dev-db/mariadb-galera/mariadb-galera-10.0.14.ebuild
deleted file mode 100644
index 8524a9412680..000000000000
--- a/dev-db/mariadb-galera/mariadb-galera-10.0.14.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/mariadb-galera-10.0.14.ebuild,v 1.1 2014/10/20 23:54:49 grknight Exp $
-
-EAPI="5"
-MY_EXTRAS_VER="20141019-1948Z"
-WSREP_REVISION="25"
-
-inherit toolchain-funcs mysql-multilib
-# only to make repoman happy. it is really set in the eclass
-IUSE="$IUSE"
-
-# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~amd64 ~x86"
-
-# When MY_EXTRAS is bumped, the index should be revised to exclude these.
-EPATCH_EXCLUDE=''
-
-DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
-RDEPEND="${RDEPEND}"
-
-# Please do not add a naive src_unpack to this ebuild
-# If you want to add a single patch, copy the ebuild to an overlay
-# and create your own mysql-extras tarball, looking at 000_index.txt
-
-# Official test instructions:
-# USE='-cluster embedded extraengine perl ssl static-libs community' \
-# FEATURES='test userpriv -usersandbox' \
-# ebuild mariadb-galera-X.X.XX.ebuild \
-# digest clean package
-multilib_src_test() {
-
- if ! multilib_is_native_abi ; then
- einfo "Server tests not available on non-native abi".
- return 0;
- fi
-
- local TESTDIR="${BUILD_DIR}/mysql-test"
- local retstatus_unit
- local retstatus_tests
-
- # Bug #213475 - MySQL _will_ object strenously if your machine is named
- # localhost. Also causes weird failures.
- [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
-
- if ! use "minimal" ; then
-
- if [[ $UID -eq 0 ]]; then
- die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
- fi
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- addpredict /this-dir-does-not-exist/t9.MYI
-
- # Run CTest (test-units)
- cmake-utils_src_test
- retstatus_unit=$?
- [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
-
- # Ensure that parallel runs don't die
- export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
- # You may set this by hand.
- # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
- export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
-
- # create directories because mysqladmin might right out of order
- mkdir -p "${T}"/var-tests{,/log}
-
- # These are failing in MariaDB 10.0 for now and are believed to be
- # false positives:
- #
- # main.information_schema, binlog.binlog_statement_insert_delayed,
- # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
- # funcs_1.is_columns_mysql
- # fails due to USE=-latin1 / utf8 default
- #
- # main.mysql_client_test, main.mysql_client_test_nonblock
- # mina.mysql_client_test_comp:
- # segfaults at random under Portage only, suspect resource limits.
- #
- # wsrep.variables:
- # Expects the sys-cluster/galera library to be installed and configured
- #
- # wsrep.foreign_key:
- # Issues a configuration deprecation warning which does not affect data
- #
-
- for t in main.mysql_client_test main.mysql_client_test_nonblock \
- main.mysql_client_test_comp \
- binlog.binlog_statement_insert_delayed main.information_schema \
- main.mysqld--help wsrep.variables wsrep.foreign_key \
- funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
- mysql-multilib_disable_test "$t" "False positives in Gentoo"
- done
-
- # Run mysql tests
- pushd "${TESTDIR}"
-
- # run mysql-test tests
- perl mysql-test-run.pl --force --vardir="${T}/var-tests"
- retstatus_tests=$?
- [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- popd
-
- # Cleanup is important for these testcases.
- pkill -9 -f "${S}/ndb" 2>/dev/null
- pkill -9 -f "${S}/sql" 2>/dev/null
-
- failures=""
- [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
- [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
- has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
-
- [[ -z "$failures" ]] || die "Test failures: $failures"
- einfo "Tests successfully completed"
- else
-
- einfo "Skipping server tests due to minimal build."
- fi
-}
diff --git a/dev-db/mariadb-galera/mariadb-galera-10.0.15.ebuild b/dev-db/mariadb-galera/mariadb-galera-10.0.16.ebuild
index ed6b1c581d1e..0d6812f4faf0 100644
--- a/dev-db/mariadb-galera/mariadb-galera-10.0.15.ebuild
+++ b/dev-db/mariadb-galera/mariadb-galera-10.0.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/mariadb-galera-10.0.15.ebuild,v 1.1 2014/12/16 02:02:07 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/mariadb-galera-10.0.16.ebuild,v 1.1 2015/02/06 14:07:36 grknight Exp $
EAPI="5"
MY_EXTRAS_VER="20141215-0144Z"
@@ -94,13 +94,25 @@ multilib_src_test() {
mysql-multilib_disable_test "$t" "False positives in Gentoo"
done
+ for t in rpl.rpl_heartbeat_ssl rpl.rpl_ssl rpl.rpl_ssl1 main.ssl_cipher \
+ main.ssl_8k_key main.openssl_6975 main.openssl_1 main.ssl main.ssl_compress \
+ main.ssl_connect; do
+ mysql-multilib_disable_test "$t" "Disabled due to expired certificate"
+ done
+
+ for t in wsrep.binlog_format wsrep.pool_of_threads wsrep.mdev_6832 ; do
+ mysql-multilib_disable_test "$t" "Skipped for MDEV-7544"
+ done
+
# Run mysql tests
pushd "${TESTDIR}"
# run mysql-test tests
# The PATH addition is required for the galera suite to find the sst scripts
+ # Skipping galera tests for now until MDEV-7544 is resovled
+ WSREP_LOG_DIR="${T}/var-tests/wsrep" \
PATH="${BUILD_DIR}/scripts:${PATH}" \
- perl mysql-test-run.pl --force --vardir="${T}/var-tests"
+ perl mysql-test-run.pl --force --vardir="${T}/var-tests" --skip-test=galera
retstatus_tests=$?
[[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"