summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-03-07 14:25:23 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-03-07 14:25:23 +0000
commit26a64d17b9229fa166c099f2f82f7f4ab08c7005 (patch)
tree1242717cb161382424c63fdc368e9e85f66dd8fa /dev-db
parentRevbump. Use EAPI 4. Update homepage. (diff)
downloadgentoo-2-26a64d17b9229fa166c099f2f82f7f4ab08c7005.tar.gz
gentoo-2-26a64d17b9229fa166c099f2f82f7f4ab08c7005.tar.bz2
gentoo-2-26a64d17b9229fa166c099f2f82f7f4ab08c7005.zip
Revbump. Use EAPI 4. Update homepage. Drop useless postinst info.
Add multilib support. RDEPEND on _same_ version of oracle-instantclient-basic. (Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog10
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild109
2 files changed, 118 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
index abe078e4f143..b7421f128df1 100644
--- a/dev-db/oracle-instantclient-jdbc/ChangeLog
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/oracle-instantclient-jdbc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.29 2012/02/09 14:24:42 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.30 2012/03/07 14:25:23 haubi Exp $
+
+*oracle-instantclient-jdbc-11.2.0.3 (07 Mar 2012)
+
+ 07 Mar 2012; Michael Haubenwallner <haubi@gentoo.org>
+ +oracle-instantclient-jdbc-11.2.0.3.ebuild:
+ Revbump. Use EAPI 4. Update homepage. Drop useless postinst info.
+ Add multilib support.
+ RDEPEND on _same_ version of oracle-instantclient-basic.
09 Feb 2012; Michael Haubenwallner <haubi@gentoo.org> metadata.xml:
Taking over maintainership.
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild
new file mode 100644
index 000000000000..68232a8b0f67
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.3.ebuild,v 1.1 2012/03/07 14:25:23 haubi Exp $
+
+EAPI="4"
+
+inherit eutils
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN/oracle-/}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: JDBC supplement"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+ x86? ( ${MY_A_x86} )
+ amd64? ( ${MY_A_amd64} multilib? ( ${MY_A_x86} ) )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="fetch"
+IUSE="multilib"
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"
+
+default_abi() {
+ [[ ${DEFAULT_ABI} == 'default' ]] && echo ${ARCH} || echo ${DEFAULT_ABI}
+}
+
+abi_list() {
+ if use multilib; then
+ echo ${MULTILIB_ABIS}
+ elif [[ ${DEFAULT_MULTILIB} == default ]]; then
+ # no multilib-able platform
+ echo ${ARCH}
+ else
+ echo ${DEFAULT_ABI}
+ fi
+ return 0
+}
+
+set_abivars() {
+ local abi=$1
+ # platform name
+ MY_PLAT=MY_PLAT_${abi}
+ MY_PLAT=${!MY_PLAT}
+ # runtime distfile
+ MY_A=MY_A_${abi}
+ MY_A=${!MY_A}
+ # abi sourcedir
+ MY_S="${S}/${abi}/instantclient_11_2"
+ # abi libdir
+ MY_LIBDIR=$(ABI=${abi} get_libdir)
+}
+
+pkg_nofetch() {
+ eerror "Please go to"
+ eerror " ${HOMEPAGE%/*}/index-097480.html"
+ eerror " and download"
+ local abi
+ for abi in $(abi_list)
+ do
+ set_abivars ${abi}
+ eerror "Instant Client for ${MY_PLAT}"
+ eerror " JDBC: ${MY_A}"
+ done
+ eerror "After downloading, put them in:"
+ eerror " ${DISTDIR}/"
+}
+
+src_unpack() {
+ local abi
+ for abi in $(abi_list)
+ do
+ set_abivars ${abi}
+ mkdir -p "${MY_S%/*}" || die
+ cd "${MY_S%/*}" || die
+ unpack ${MY_A}
+ done
+}
+
+src_install() {
+ # all binaries go here
+ local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client
+ into "${oracle_home}"
+
+ local abi
+ for abi in $(abi_list)
+ do
+ set_abivars ${abi}
+ einfo "Installing runtime for ${MY_PLAT} ..."
+
+ cd "${MY_S}" || die
+
+ ABI=${abi} dolib.so lib*$(get_libname)*
+
+ insinto "${oracle_home}"/${MY_LIBDIR}
+ doins *.jar
+
+ eend $?
+ done
+}