summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-05-06 06:59:23 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-05-06 06:59:23 +0000
commit1fc3c375103efb65498a71e4231bc480cc7f6aa7 (patch)
tree31d426013a7b72ec2d4d45d2472aa35469a0fad3 /dev-db
parentFix wrong usage of python eclass, #366137 (diff)
downloadgentoo-2-1fc3c375103efb65498a71e4231bc480cc7f6aa7.tar.gz
gentoo-2-1fc3c375103efb65498a71e4231bc480cc7f6aa7.tar.bz2
gentoo-2-1fc3c375103efb65498a71e4231bc480cc7f6aa7.zip
Remove old redis versions.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/ChangeLog7
-rw-r--r--dev-db/redis/files/01-dont-print-pid-on-startup.diff17
-rw-r--r--dev-db/redis/redis-1.2.6.ebuild120
-rw-r--r--dev-db/redis/redis-2.2.0_rc4.ebuild110
4 files changed, 6 insertions, 248 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index 23bacc5766fe..70736b092993 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.12 2011/04/07 12:36:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.13 2011/05/06 06:59:22 djc Exp $
+
+ 06 May 2011; Dirkjan Ochtman <djc@gentoo.org>
+ -files/01-dont-print-pid-on-startup.diff, -redis-1.2.6.ebuild,
+ -redis-2.2.0_rc4.ebuild:
+ Remove old versions.
07 Apr 2011; Fabian Groffen <grobian@gentoo.org> redis-2.2.2.ebuild:
Fix for Darwin, thanks Sven Schwyn bug #353516, marked ~x86-solaris
diff --git a/dev-db/redis/files/01-dont-print-pid-on-startup.diff b/dev-db/redis/files/01-dont-print-pid-on-startup.diff
deleted file mode 100644
index 1e42fe1688a6..000000000000
--- a/dev-db/redis/files/01-dont-print-pid-on-startup.diff
+++ /dev/null
@@ -1,17 +0,0 @@
-
-Don't print pid of forked process on startup. This change was also made
-upstream in 20f5b3886761a0ba963fee435bba90dd09bd5bd5.
-
- -- Chris Lamb <lamby@debian.org> Thu, 14 Jan 2010 15:48:04 +0000
-
-diff -urNad /tmp/bp-build/redis-1.2.0.orig/redis.c /tmp/bp-build/redis-1.2.0/redis.c
---- redis-1.2.0.orig/redis.c 2010-01-14 15:46:33.000000000 +0000
-+++ redis-1.2.0/redis.c 2010-01-14 15:46:51.000000000 +0000
-@@ -6215,7 +6215,6 @@
- FILE *fp;
-
- if (fork() != 0) exit(0); /* parent exits */
-- printf("New pid: %d\n", getpid());
- setsid(); /* create a new session */
-
- /* Every output goes to /dev/null. If Redis is daemonized but
diff --git a/dev-db/redis/redis-1.2.6.ebuild b/dev-db/redis/redis-1.2.6.ebuild
deleted file mode 100644
index bbc0b904981b..000000000000
--- a/dev-db/redis/redis-1.2.6.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-1.2.6.ebuild,v 1.2 2011/01/26 02:25:32 robbat2 Exp $
-
-EAPI=2
-
-inherit autotools eutils
-
-DESCRIPTION="Persistent distributed key-value data caching system."
-HOMEPAGE="http://code.google.com/p/redis/"
-SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="test? ( dev-lang/tcl )"
-
-REDIS_PIDDIR=/var/run/redis/
-REDIS_PIDFILE=${REDIS_PIDDIR}/redis.pid
-REDIS_DATAPATH=/var/lib/redis
-REDIS_LOGPATH=/var/log/redis
-REDIS_LOGFILE=${REDIS_LOGPATH}/redis.log
-
-pkg_setup() {
- enewgroup redis 75 || die "problem adding 'redis' group"
- enewuser redis 75 -1 ${REDIS_DATAPATH} redis || die "problem adding 'redis' user"
-}
-
-src_prepare() {
- # Borrowed from debian
- epatch "${FILESDIR}"/01-dont-print-pid-on-startup.diff
- # Now autotoolize this
- cp "${FILESDIR}"/configure.ac-1.02 configure.ac
- mv Makefile Makefile.in
- sed -i \
- -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:ARCH:GCC_ARCH_FLAG:g' \
- -e 's:PROF:GCC_PROF_FLAG:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- Makefile.in \
- || die "sed failed!"
-
- eautoreconf
-}
-
-src_install() {
- # configuration file rewrites
- insinto /etc/
- sed -r \
- -e "/^pidfile\>/s,/var.*,${REDIS_PIDFILE}," \
- -e '/^daemonize\>/s,no,yes,' \
- -e '/^# bind/s,^# ,,' \
- -e '/^# maxmemory\>/s,^# ,,' \
- -e '/^maxmemory\>/s,<bytes>,67108864,' \
- -e "/^dbfilename\>/s,dump.rdb,${REDIS_DATAPATH}/dump.rdb," \
- -e "/^dir\>/s, .*, ${REDIS_DATAPATH}/," \
- -e '/^loglevel\>/s:debug:notice:' \
- -e "/^logfile\>/s:stdout:${REDIS_LOGFILE}:" \
- <redis.conf \
- >redis.conf.gentoo
- newins redis.conf.gentoo redis.conf
- fowners root:redis /etc/redis.conf
- fperms 0640 /etc/redis.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd" redis
-
- dodoc 00-RELEASENOTES BETATESTING.txt BUGS Changelog README TODO
- newdoc client-libraries/README README.client-libraries
- dohtml doc/*
-
- dobin redis-benchmark redis-cli
- dosbin redis-server
-
- diropts -m0750 -o redis -g redis
- keepdir ${REDIS_DATAPATH} ${REDIS_LOGPATH} ${REDIS_PIDDIR}
-}
-
-src_test() {
- local PORT=$(((RANDOM % 32767)+32768))
- local PIDFILE=redis-test.pid
- einfo "Preparing redis test config"
- # The port number is hardcoded in lots of places
- sed -r <redis.conf >redis-test.conf \
- -e "/^pidfile/s~ .*~ ${PIDFILE}~" \
- -e '/^daemonize/s~ no~ yes~' \
- -e "/^port/s~ [0-9]+~ ${PORT}~" \
- -e '/^(# )?bind/s,^,#,g' \
- -e '/\<bind\>/abind 127.0.0.1' \
- || die "Failed to build test server config"
- # The port number is hardcoded in lots of places
- for i in test-redis.tcl redis.tcl ; do
- sed -r <$i >${i/.tcl/-${PORT}.tcl} \
- -e "/^source redis.tcl/s,redis.tcl,redis-${PORT}.tcl,g" \
- -e "/6379/s~6379~${PORT}~" \
- || die "Failed to build test client config ($i)"
- done
- einfo "Starting test server"
- ./redis-server redis-test.conf
- rc1=$?
- sleep 2
- [[ $rc1 -ne 0 ]] && die "Failed to start redis server!"
- pidof redis-server | fgrep -f ${PIDFILE}
- rc1=$?
- [[ $rc1 -ne 0 ]] && die "Could not find started redis server!"
- unset rc1
-
- einfo "Starting redis tests"
- tclsh test-redis-$PORT.tcl
- rc1=$?
- kill -9 $(<${PIDFILE})
- rc2=$?
- [[ $rc1 -ne 0 ]] && die "Failed testsuite"
- [[ $rc2 -ne 0 ]] && die "Failed to shut down redis server"
-}
diff --git a/dev-db/redis/redis-2.2.0_rc4.ebuild b/dev-db/redis/redis-2.2.0_rc4.ebuild
deleted file mode 100644
index 60d8c2566d6c..000000000000
--- a/dev-db/redis/redis-2.2.0_rc4.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.2.0_rc4.ebuild,v 1.3 2011/01/26 02:43:30 robbat2 Exp $
-
-EAPI="2"
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://code.google.com/p/redis/"
-SRC_URI="http://redis.googlecode.com/files/${PN}-${PV/_/-}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~x86-macos"
-IUSE="tcmalloc test"
-SLOT="0"
-
-RDEPEND=""
-DEPEND=">=sys-devel/autoconf-2.63
- tcmalloc? ( dev-util/google-perftools )
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-REDIS_PIDDIR=/var/run/redis/
-REDIS_PIDFILE=${REDIS_PIDDIR}/redis.pid
-REDIS_DATAPATH=/var/lib/redis
-REDIS_LOGPATH=/var/log/redis
-REDIS_LOGFILE=${REDIS_LOGPATH}/redis.log
-
-pkg_setup() {
- enewgroup redis 75 || die "problem adding 'redis' group"
- enewuser redis 75 -1 ${REDIS_DATAPATH} redis || die "problem adding 'redis' user"
- # set tcmalloc-variable for the build as specified in
- # https://github.com/antirez/redis/blob/2.2/README. If build system gets
- # better integrated into autotools, replace with append-flags and
- # append-ldflags in src_configure()
- use tcmalloc && export EXTRA_EMAKE="${EXTRA_EMAKE} USE_TCMALLOC=yes"
-}
-
-src_prepare() {
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_install() {
- # configuration file rewrites
- insinto /etc/
- sed -r \
- -e "/^pidfile\>/s,/var.*,${REDIS_PIDFILE}," \
- -e '/^daemonize\>/s,no,yes,' \
- -e '/^# bind/s,^# ,,' \
- -e '/^# maxmemory\>/s,^# ,,' \
- -e '/^maxmemory\>/s,<bytes>,67108864,' \
- -e "/^dbfilename\>/s,dump.rdb,${REDIS_DATAPATH}/dump.rdb," \
- -e "/^dir\>/s, .*, ${REDIS_DATAPATH}/," \
- -e '/^loglevel\>/s:debug:notice:' \
- -e "/^logfile\>/s:stdout:${REDIS_LOGFILE}:" \
- <redis.conf \
- >redis.conf.gentoo
- newins redis.conf.gentoo redis.conf
- use prefix || fowners redis:redis /etc/redis.conf
- fperms 0644 /etc/redis.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd" redis
-
- dodoc 00-RELEASENOTES BUGS Changelog CONTRIBUTING README TODO
- dodoc design-documents/*
- newdoc client-libraries/README README.client-libraries
- docinto html
- dodoc doc/*
-
- dobin src/redis-cli \
- || die "the redis command line client could not be found"
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump \
- || die "some redis executables could not be found"
- fperms 0750 /usr/sbin/redis-benchmark
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir ${REDIS_DATAPATH} ${REDIS_LOGPATH} ${REDIS_PIDDIR}
-}
-
-pkg_postinst() {
- einfo "New features of Redis you want to consider enabling in redis.conf:"
- einfo " * unix sockets (using this is highly recommended)"
- einfo " * logging to syslog"
- einfo " * VM aka redis' own swap mechanism"
-}