summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-26 10:55:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-26 10:55:03 +0000
commit1629fdfcf009b41713e4603c192850da7c8055f8 (patch)
tree444042ed9fb609cf7b87b2e355bdcae012d85f00 /dev-db
parentFix build with graphviz-2.22, bug 261674 (diff)
downloadgentoo-2-1629fdfcf009b41713e4603c192850da7c8055f8.tar.gz
gentoo-2-1629fdfcf009b41713e4603c192850da7c8055f8.tar.bz2
gentoo-2-1629fdfcf009b41713e4603c192850da7c8055f8.zip
Version bump.
(Portage version: 13625-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/sqlite-3.6.14.2.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index f35b0a0fc484..bba1ac61baa0 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.249 2009/05/24 17:41:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.250 2009/05/26 10:55:03 arfrever Exp $
+
+*sqlite-3.6.14.2 (26 May 2009)
+
+ 26 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sqlite-3.6.14.2.ebuild:
+ Version bump.
24 May 2009; Markus Meier <maekke@gentoo.org> sqlite-3.6.13.ebuild:
x86 stable, bug #269998
diff --git a/dev-db/sqlite/sqlite-3.6.14.2.ebuild b/dev-db/sqlite/sqlite-3.6.14.2.ebuild
new file mode 100644
index 000000000000..314a9bb12583
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.6.14.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.14.2.ebuild,v 1.1 2009/05/26 10:55:03 arfrever Exp $
+
+EAPI="1"
+
+inherit eutils flag-o-matic multilib versionator
+
+DESCRIPTION="an SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+DOC_BASE="$(get_version_component_range 1-3)"
+DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz
+ doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh -sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc soundex tcl +threadsafe"
+RESTRICT="!tcl? ( test )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+pkg_setup() {
+ if has test ${FEATURES} ; then
+ if ! has userpriv ${FEATURES} ; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl ; then
+ ewarn "You must enable the tcl use flag if you want to run the testsuite."
+ eerror "Testsuite will not be run."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # note: this sandbox fix is no longer needed with sandbox-1.3+
+ epatch "${FILESDIR}"/sandbox-fix2.patch
+
+ epunt_cxx
+}
+
+src_compile() {
+ # Enable column metadata, bug #266651
+ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+ # not available via configure and requested in bug #143794
+ use soundex && append-cppflags -DSQLITE_SOUNDEX
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable threadsafe) \
+ $(use_enable threadsafe cross-thread-connections) \
+ $(use_enable tcl)
+ emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
+}
+
+src_test() {
+ if has userpriv ${FEATURES} ; then
+ local test=test
+ use debug && test=fulltest
+ emake ${test} || die "some test(s) failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)/${P}" \
+ install \
+ || die "emake install failed"
+
+ doman sqlite3.1 || die
+
+ if use doc ; then
+ # Naming scheme changes randomly between - and _ in releases
+ # http://www.sqlite.org/cvstrac/tktview?tn=3523
+ dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die
+ fi
+}