summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-08 23:07:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-08 23:07:47 +0000
commit07990f363c630ca81dc6096a3fb97d20dfd911bd (patch)
tree07cf5e99d55617d7ce0c5aaa0837a417038f7f06 /dev-db
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-07990f363c630ca81dc6096a3fb97d20dfd911bd.tar.gz
gentoo-2-07990f363c630ca81dc6096a3fb97d20dfd911bd.tar.bz2
gentoo-2-07990f363c630ca81dc6096a3fb97d20dfd911bd.zip
add inherit eutils
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/firebird/firebird-1.5.0.ebuild40
-rw-r--r--dev-db/libiodbc/libiodbc-3.51.2.ebuild9
2 files changed, 27 insertions, 22 deletions
diff --git a/dev-db/firebird/firebird-1.5.0.ebuild b/dev-db/firebird/firebird-1.5.0.ebuild
index b46b872b5cfe..324d34757187 100644
--- a/dev-db/firebird/firebird-1.5.0.ebuild
+++ b/dev-db/firebird/firebird-1.5.0.ebuild
@@ -1,39 +1,43 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.0.ebuild,v 1.3 2004/04/03 22:54:57 mksoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.0.ebuild,v 1.4 2004/04/08 23:07:09 vapier Exp $
+
+inherit flag-o-matic eutils
-DESCRIPTION="A relational database offering many ANSI SQL-92 features"
extra_ver="4290"
-SRC_URI="mirror://sourceforge/${PN}/${P}.${extra_ver}.tar.bz2"
-S=${WORKDIR}/${P}.${extra_ver}
+DESCRIPTION="A relational database offering many ANSI SQL-92 features"
HOMEPAGE="http://firebird.sourceforge.net/"
-SLOT="0"
+SRC_URI="mirror://sourceforge/${PN}/${P}.${extra_ver}.tar.bz2"
+
LICENSE="MPL-1.1"
+SLOT="0"
KEYWORDS="~x86"
IUSE="inetd"
+RESTRICT="nouserpriv"
+
DEPEND="virtual/glibc
inetd? ( virtual/inetd )"
-RESTRICT="nouserpriv"
-inherit flag-o-matic
-# fix bug #33584
-strip-flags "-funroll-loops"
+S=${WORKDIR}/${P}.${extra_ver}
+
+pkg_setup() {
+ enewgroup firebird 450
+ enewuser firebird 450 /bin/bash /opt/firebird firebird
+}
src_compile() {
+ # fix bug #33584
+ strip-flags -funroll-loops
+
local myconf
myconf="${myconf} --prefix=/opt/firebird"
myconf="${myconf} --with-editline"
- [ -z "`use inetd`" ] && myconf="${myconf} --enable-superserver"
+ use inetd || myconf="${myconf} --enable-superserver"
./autogen.sh ${myconf} || die "couldn't run autogen.sh"
make || die "error during make"
}
-pkg_setup() {
- enewgroup firebird 450
- enewuser firebird 450 /bin/bash /opt/firebird firebird
-}
-
src_install() {
cd ${S}/gen
make -f Makefile.install tarfile || or die "Can't create buildroot tar file"
@@ -49,7 +53,7 @@ src_install() {
rm -r ${D}/opt/firebird/{README,WhatsNew,doc,misc}
rm -r ${D}/opt/firebird/examples
- if [ -n "`use inetd`" ]; then
+ if use inetd ; then
insinto /etc/xinetd.d ; newins ${FILESDIR}/${P}.xinetd firebird
else
exeinto /etc/init.d ; newexe ${FILESDIR}/${PN}.init.d firebird
@@ -75,7 +79,7 @@ src_install() {
chmod a=rx isql
chmod a=rx qli
- [ -n "`use inetd`" ] && chmod ug=rxs,o= ${D}/opt/firebird/bin/{fb_lock_mgr,gds_drop,fb_inet_server}
+ use inetd && chmod ug=rxs,o= ${D}/opt/firebird/bin/{fb_lock_mgr,gds_drop,fb_inet_server}
chmod u=rw,go=r ${D}/opt/firebird/{aliases.conf,firebird.conf}
chmod ug=rw,o= ${D}/opt/firebird/{security.fdb,help/help.fdb}
@@ -107,7 +111,7 @@ pkg_postinst() {
einfo " already have (if any)."
einfo
- if [ -z "`use inetd`" ]
+ if ! use inetd
then
einfo "3. You've built the stand alone deamon version,"
einfo " SuperServer. If you were using pre 1.5.0 ebuilds"
diff --git a/dev-db/libiodbc/libiodbc-3.51.2.ebuild b/dev-db/libiodbc/libiodbc-3.51.2.ebuild
index 92fd1b03b298..16340cde8a4c 100644
--- a/dev-db/libiodbc/libiodbc-3.51.2.ebuild
+++ b/dev-db/libiodbc/libiodbc-3.51.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.51.2.ebuild,v 1.1 2004/03/04 13:18:59 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.51.2.ebuild,v 1.2 2004/04/08 23:07:47 vapier Exp $
+
+inherit eutils
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.iodbc.org/"
@@ -20,14 +22,13 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/libiodbc-3.51.2_install_symlink.diff
- cd ${S}
}
src_compile() {
local myconf
myconf="--with-layout=gentoo"
- if [ "`use gtk`" ]
+ if use gtk
then
myconf="$myconf --enable-gui=yes"
else
@@ -41,7 +42,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- #dodoc AUTHORS COPYING ChangeLog NEWS README*
+ #dodoc AUTHORS ChangeLog NEWS README*
#find doc/ -name "Makefile*" -exec rm '{}' \;
#dohtml doc/*
#prepalldocs