summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2013-12-31 18:30:45 +0000
committerJesus Rivero <neurogeek@gentoo.org>2013-12-31 18:30:45 +0000
commit9f982ec35a6c936f88e7c7ee42c2025ab386ac0c (patch)
treee4c0aecd57239d66a8e66795b19d58f2d341892c /dev-db/unixODBC
parentVersion bump to 1.3.0, bug 494900. (diff)
downloadgentoo-2-9f982ec35a6c936f88e7c7ee42c2025ab386ac0c.tar.gz
gentoo-2-9f982ec35a6c936f88e7c7ee42c2025ab386ac0c.tar.bz2
gentoo-2-9f982ec35a6c936f88e7c7ee42c2025ab386ac0c.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux i686, signed Manifest commit with key 1F6F0683)
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog7
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index cc451b1673fd..d6bbd51a05cf 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/unixODBC
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.114 2013/03/03 23:36:12 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.115 2013/12/31 18:30:45 neurogeek Exp $
+
+*unixODBC-2.3.2 (31 Dec 2013)
+
+ 31 Dec 2013; Jesus Rivero <neurogeek@gentoo.org> +unixODBC-2.3.2.ebuild:
+ Version bump
*unixODBC-2.3.1-r1 (03 Mar 2013)
diff --git a/dev-db/unixODBC/unixODBC-2.3.2.ebuild b/dev-db/unixODBC/unixODBC-2.3.2.ebuild
new file mode 100644
index 000000000000..c42a68c30bf2
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.3.2.ebuild,v 1.1 2013/12/31 18:30:45 neurogeek Exp $
+
+EAPI=5
+inherit libtool
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ >=sys-libs/readline-6.1
+ >=sys-libs/ncurses-5.7-r7
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --enable-iconv \
+ $(use_enable static-libs static) \
+ $(use_enable !minimal drivers) \
+ $(use_enable !minimal driverc) \
+ $(use_with unicode iconv-char-enc UTF8) \
+ $(use_with unicode iconv-ucode-enc UTF16LE)
+}
+
+src_install() {
+ default
+
+ use prefix && dodoc README*
+ use odbcmanual && dohtml -a css,gif,html,sql,vsd -r doc/*
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}