summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-09-17 16:10:12 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-09-17 16:10:12 +0000
commit957298d23b96bdca1bb24a8d828cdee2b0cdfa55 (patch)
treefcdee04ed736d0ef50bb71d3079ef90608a233b0 /dev-db/tora
parentRe-add setup script (#284955). (diff)
downloadgentoo-2-957298d23b96bdca1bb24a8d828cdee2b0cdfa55.tar.gz
gentoo-2-957298d23b96bdca1bb24a8d828cdee2b0cdfa55.tar.bz2
gentoo-2-957298d23b96bdca1bb24a8d828cdee2b0cdfa55.zip
Version bump, #284360
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog8
-rw-r--r--dev-db/tora/tora-1.3.22.ebuild77
-rw-r--r--dev-db/tora/tora-1.3.23.ebuild86
-rw-r--r--dev-db/tora/tora-2.1.0.ebuild (renamed from dev-db/tora/tora-2.0.0.ebuild)9
4 files changed, 8 insertions, 172 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index b9a7e11cb252..2418de824994 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.70 2009/06/26 18:41:53 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.71 2009/09/17 16:10:12 dertobi123 Exp $
+
+*tora-2.1.0 (17 Sep 2009)
+
+ 17 Sep 2009; Tobias Scherbaum <dertobi123@gentoo.org> -tora-1.3.22.ebuild,
+ -tora-1.3.23.ebuild, -tora-2.0.0.ebuild, +tora-2.1.0.ebuild:
+ Version bump, #284360
26 Jun 2009; Tobias Scherbaum <dertobi123@gentoo.org> tora-2.0.0.ebuild:
Really apply the patch for gcc-4.4.
diff --git a/dev-db/tora/tora-1.3.22.ebuild b/dev-db/tora/tora-1.3.22.ebuild
deleted file mode 100644
index a0011fb30c58..000000000000
--- a/dev-db/tora/tora-1.3.22.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.22.ebuild,v 1.1 2008/03/21 10:04:27 dertobi123 Exp $
-
-inherit eutils kde-functions
-
-IUSE="kde oracle debug oci8-instant-client xinerama"
-DESCRIPTION="TOra - Toolkit For Oracle"
-HOMEPAGE="http://tora.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-
-RDEPEND="${DEPEND}
- xinerama? ( x11-libs/libXinerama )"
-
-DEPEND="=x11-libs/qt-3*
- dev-lang/perl
- <x11-libs/qscintilla-2.1
- kde? ( >=kde-base/kdelibs-3.1
- kde-base/arts )
- xinerama? ( x11-proto/xineramaproto )
- oci8-instant-client? ( dev-db/oracle-instantclient-basic )"
-
-pkg_setup() {
- if use oracle && [ -z "$ORACLE_HOME" ] ; then
- eerror "ORACLE_HOME variable is not set."
- eerror
- eerror "You must install Oracle >= 8i client for Linux in"
- eerror "order to compile TOra with Oracle support."
- eerror
- eerror "Otherwise specify -oracle in your USE variable."
- eerror
- eerror "You can download the Oracle software from"
- eerror "http://otn.oracle.com/software/content.html"
- die
- fi
-}
-
-src_compile() {
- set-qtdir 3
- set-kdedir 3
-
- # Need to fake out Qt or we'll get sandbox problems
- REALHOME="$HOME"
- mkdir -p "$T"/fakehome/.kde
- mkdir -p "$T"/fakehome/.qt
- export HOME="$T/fakehome"
- addwrite "${QTDIR}/etc/settings"
-
- local myconf
- myconf="${myconf} $(use_with kde)"
- myconf="${myconf} $(use_with oracle)"
- myconf="${myconf} $(use_with xinerama)"
-
- if use oci8-instant-client; then
- myconf="$myconf --with-instant-client"
- fi
-
- myconf="$myconf --with-qt-dir=/usr/qt/3"
-
- #./configure $myconf || die "configure failed"
- econf $myconf || die "configure failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}"
- dodoc BUGS INSTALL NEWS README TODO
-
- insinto /usr/share/applications
- doins "${FILESDIR}"/${PN}.desktop
- insinto /usr/share/pixmaps
- doins "${FILESDIR}"/${PN}.png
-}
diff --git a/dev-db/tora/tora-1.3.23.ebuild b/dev-db/tora/tora-1.3.23.ebuild
deleted file mode 100644
index 1df39b9d5362..000000000000
--- a/dev-db/tora/tora-1.3.23.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.23.ebuild,v 1.1 2008/06/16 18:21:35 dertobi123 Exp $
-
-inherit eutils kde-functions
-
-IUSE="kde oracle debug oci8-instant-client xinerama"
-DESCRIPTION="TOra - Toolkit For Oracle"
-HOMEPAGE="http://tora.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-1-3-end-of-life.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-
-RDEPEND="${DEPEND}
- xinerama? ( x11-libs/libXinerama )"
-
-DEPEND="=x11-libs/qt-3*
- dev-lang/perl
- <x11-libs/qscintilla-2.1
- kde? ( >=kde-base/kdelibs-3.1
- kde-base/arts )
- xinerama? ( x11-proto/xineramaproto )
- oci8-instant-client? ( dev-db/oracle-instantclient-basic )"
-
-S="${WORKDIR}/${PN}-1-3-end-of-life"
-
-pkg_setup() {
- if use oracle && [ -z "$ORACLE_HOME" ] ; then
- eerror "ORACLE_HOME variable is not set."
- eerror
- eerror "You must install Oracle >= 8i client for Linux in"
- eerror "order to compile TOra with Oracle support."
- eerror
- eerror "Otherwise specify -oracle in your USE variable."
- eerror
- eerror "You can download the Oracle software from"
- eerror "http://otn.oracle.com/software/content.html"
- die
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-gcc43.patch"
-}
-
-src_compile() {
- set-qtdir 3
- set-kdedir 3
-
- # Need to fake out Qt or we'll get sandbox problems
- REALHOME="$HOME"
- mkdir -p "$T"/fakehome/.kde
- mkdir -p "$T"/fakehome/.qt
- export HOME="$T/fakehome"
- addwrite "${QTDIR}/etc/settings"
-
- local myconf
- myconf="${myconf} $(use_with kde)"
- myconf="${myconf} $(use_with oracle)"
- myconf="${myconf} $(use_with xinerama)"
-
- if use oci8-instant-client; then
- myconf="$myconf --with-instant-client"
- fi
-
- myconf="$myconf --with-qt-dir=/usr/qt/3"
-
- #./configure $myconf || die "configure failed"
- econf $myconf || die "configure failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}"
- dodoc BUGS INSTALL NEWS README TODO
-
- insinto /usr/share/applications
- doins "${FILESDIR}"/${PN}.desktop
- insinto /usr/share/pixmaps
- doins "${FILESDIR}"/${PN}.png
-}
diff --git a/dev-db/tora/tora-2.0.0.ebuild b/dev-db/tora/tora-2.1.0.ebuild
index 0cbbb1dc368f..c0078ef10a83 100644
--- a/dev-db/tora/tora-2.0.0.ebuild
+++ b/dev-db/tora/tora-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.0.0.ebuild,v 1.5 2009/06/26 18:41:53 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-2.1.0.ebuild,v 1.1 2009/09/17 16:10:12 dertobi123 Exp $
EAPI=2
@@ -41,10 +41,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch "${FILESDIR}/${P}-gcc44.patch"
-}
-
src_configure() {
# Need to fake out Qt or we'll get sandbox problems
REALHOME="$HOME"
@@ -53,9 +49,6 @@ src_configure() {
export HOME="$T/fakehome"
addwrite "${QTDIR}/etc/settings"
- # Remove files generated with qt-4.4 moc
- rm src/{moc_*.cpp,ui_*ui.h} || die "rm failed"
-
local myconf
if use oracle; then