summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-08-01 21:00:15 +0000
committerBrian Evans <grknight@gentoo.org>2014-08-01 21:00:15 +0000
commit5944be740d1dcb4c49dc55a92764fa15c4f4aff5 (patch)
tree3b8fb2ec82c3c4903a6b323ec9b6b281e5c0576d /dev-db/tokumx
parentFix hardened installation in PAX_MARKINGS=XT mode (bug #518734). (diff)
downloadgentoo-2-5944be740d1dcb4c49dc55a92764fa15c4f4aff5.tar.gz
gentoo-2-5944be740d1dcb4c49dc55a92764fa15c4f4aff5.tar.bz2
gentoo-2-5944be740d1dcb4c49dc55a92764fa15c4f4aff5.zip
Revision bump to use less bundled libs and fix documentation install. Ack by chainsaw
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/tokumx')
-rw-r--r--dev-db/tokumx/ChangeLog10
-rw-r--r--dev-db/tokumx/files/tokumx-disable-bundled-libs.patch11
-rw-r--r--dev-db/tokumx/tokumx-1.5.0-r1.ebuild71
3 files changed, 90 insertions, 2 deletions
diff --git a/dev-db/tokumx/ChangeLog b/dev-db/tokumx/ChangeLog
index d163174f64f4..c13d25443582 100644
--- a/dev-db/tokumx/ChangeLog
+++ b/dev-db/tokumx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/tokumx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokumx/ChangeLog,v 1.1 2014/08/01 13:08:05 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokumx/ChangeLog,v 1.2 2014/08/01 21:00:15 grknight Exp $
+
+*tokumx-1.5.0-r1 (01 Aug 2014)
+
+ 01 Aug 2014; <grknight@gentoo.org> +files/tokumx-disable-bundled-libs.patch,
+ +tokumx-1.5.0-r1.ebuild:
+ Revision bump to use less bundled libs and fix documentation install. Ack by
+ chainsaw
*tokumx-1.5.0 (01 Aug 2014)
@@ -8,4 +15,3 @@
+files/1.5.0-Werror.diff, +metadata.xml:
Initial attempt at packaging TokuMX community edition. Improvement requests
welcomed in bug reports, particularly with patches.
-
diff --git a/dev-db/tokumx/files/tokumx-disable-bundled-libs.patch b/dev-db/tokumx/files/tokumx-disable-bundled-libs.patch
new file mode 100644
index 000000000000..66d8db3980fa
--- /dev/null
+++ b/dev-db/tokumx/files/tokumx-disable-bundled-libs.patch
@@ -0,0 +1,11 @@
+diff -auwrN a/src/third_party/ft-index/CMakeLists.txt b/src/third_party/ft-index/CMakeLists.txt
+--- a/src/third_party/ft-index/CMakeLists.txt 2014-08-01 04:37:33.000000000 -0400
++++ b/src/third_party/ft-index/CMakeLists.txt 2014-08-01 10:38:28.134869689 -0400
+@@ -35,7 +35,6 @@
+ include(TokuFeatureDetection)
+ include(TokuSetupCompiler)
+ include(TokuSetupCTest)
+-include(TokuThirdParty)
+
+ set(TOKU_CMAKE_SCRIPT_DIR "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+ include(TokuMergeLibs)
diff --git a/dev-db/tokumx/tokumx-1.5.0-r1.ebuild b/dev-db/tokumx/tokumx-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..3e294c177ee1
--- /dev/null
+++ b/dev-db/tokumx/tokumx-1.5.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokumx/tokumx-1.5.0-r1.ebuild,v 1.1 2014/08/01 21:00:15 grknight Exp $
+
+EAPI=5
+CMAKE_BUILD_TYPE=Release
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 cmake-utils
+
+MY_P=${PN}-git-tag-${PV}
+
+DESCRIPTION="An open source, high-performance distribution of MongoDB"
+HOMEPAGE="http://www.tokutek.com/products/tokumx-for-mongodb/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="AGPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/jemalloc
+ >=dev-libs/boost-1.50[threads(+)]
+ >=dev-libs/libpcre-8.30[cxx]
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses
+ sys-libs/readline"
+
+S="${WORKDIR}/mongo"
+BUILD_DIR="${WORKDIR}/mongo/build"
+QA_PRESTRIPPED="/usr/lib64/libHotBackup.so"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-Werror.diff"
+ epatch "${FILESDIR}/${PN}-disable-bundled-libs.patch"
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -D TOKU_DEBUG_PARANOID=OFF
+ -D USE_VALGRIND=OFF
+ -D USE_BDB=OFF
+ -D BUILD_TESTING=OFF
+ -D TOKUMX_DISTNAME=${PV}
+ -D LIBJEMALLOC="jemalloc"
+ -D TOKUMX_STRIP_BINARIES=0
+ -D USE_SYSTEM_PCRE=1
+ -D USE_SYSTEM_BOOST=1
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Remove unnecessary files
+ rm -r "${D}usr/buildscripts" "${D}usr/scripts" "${D}usr/src" || die
+
+ # Correctly install this python script
+ python_foreach_impl python_doscript scripts/tokumxstat.py
+
+ # Clean up documentation installed to /usr
+ pushd "${D}usr/" || die
+ rm GNU-AGPL-3.0 LICENSE.txt NEWS README README.md README-TOKUDB README-TOKUKV SConstruct THIRD-PARTY-NOTICES || die
+ popd || die
+ dodoc README.md distsrc/NEWS distsrc/README distsrc/THIRD-PARTY-NOTICES
+ newdoc src/third_party/ft-index/README-TOKUDB README-TOKUKV
+}