summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-15 00:32:54 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-15 00:32:54 +0000
commitff493fb078443b877786a2c8fbe366117709a4db (patch)
treeff82b42c4e2ca1b29a9a51851716d19db60dab85 /dev-db/sqlite
parentwas missing (diff)
downloadgentoo-2-ff493fb078443b877786a2c8fbe366117709a4db.tar.gz
gentoo-2-ff493fb078443b877786a2c8fbe366117709a4db.tar.bz2
gentoo-2-ff493fb078443b877786a2c8fbe366117709a4db.zip
Integrated the new tcl-tk scheme. This hasn't been tested much, so people
using these applications, please try it out. I've done this to advance the new scheme and start the testing of it. It's a good thing that tcl and tk are seperated, and the earlier the better.
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/sqlite-2.1.3-r1.ebuild41
-rw-r--r--dev-db/sqlite/sqlite-2.2.1.ebuild5
2 files changed, 2 insertions, 44 deletions
diff --git a/dev-db/sqlite/sqlite-2.1.3-r1.ebuild b/dev-db/sqlite/sqlite-2.1.3-r1.ebuild
deleted file mode 100644
index c26789fcd15b..000000000000
--- a/dev-db/sqlite/sqlite-2.1.3-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.1.3-r1.ebuild,v 1.2 2002/01/13 23:50:19 azarah Exp $
-
-S=${WORKDIR}/sqlite
-DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
-SRC_URI="http://www.hwaci.com/sw/sqlite/${P}.tar.gz"
-HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
-
-DEPEND="virtual/glibc
- dev-lang/tcl-tk"
-
-src_compile() {
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --sysconfdir=/etc || die
-
- emake || die
- make doc || die
-}
-
-src_install () {
-
- dodir /usr/{bin,include,lib}
-
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- sysconfdir=${D}/etc \
- install || die
-
- dobin lemon
-
- dodoc README VERSION
- docinto html
- dodoc doc/*.html doc/*.txt doc/*.png
-}
diff --git a/dev-db/sqlite/sqlite-2.2.1.ebuild b/dev-db/sqlite/sqlite-2.2.1.ebuild
index 88dc9ec9fa2b..7b22661c05a6 100644
--- a/dev-db/sqlite/sqlite-2.2.1.ebuild
+++ b/dev-db/sqlite/sqlite-2.2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.2.1.ebuild,v 1.2 2002/01/13 23:50:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.2.1.ebuild,v 1.3 2002/01/15 00:32:54 gbevin Exp $
S=${WORKDIR}/sqlite
DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
@@ -9,8 +9,7 @@ SRC_URI="http://www.hwaci.com/sw/sqlite/${P}.tar.gz"
HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
DEPEND="virtual/glibc
- dev-lang/tcl-tk"
-#should be: dev-lan/tcl
+ dev-lang/tcl"
src_compile() {