summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-12 19:31:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-12 19:31:17 +0000
commitdbc0d7b7f08ecd7052debfd2095eff111556c51c (patch)
treeb159a7e459b247ac1d2105483d1ac6cb81d9bdd3 /dev-db/sqlite
parentVersion bump. (diff)
downloadgentoo-2-dbc0d7b7f08ecd7052debfd2095eff111556c51c.tar.gz
gentoo-2-dbc0d7b7f08ecd7052debfd2095eff111556c51c.tar.bz2
gentoo-2-dbc0d7b7f08ecd7052debfd2095eff111556c51c.zip
Delete older ebuilds.
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/sandbox-fix2.patch14
-rw-r--r--dev-db/sqlite/sqlite-3.6.22-r2.ebuild138
-rw-r--r--dev-db/sqlite/sqlite-3.6.23.1-r1.ebuild153
-rw-r--r--dev-db/sqlite/sqlite-3.6.23.1.ebuild148
-rw-r--r--dev-db/sqlite/sqlite-3.7.0.ebuild153
5 files changed, 0 insertions, 606 deletions
diff --git a/dev-db/sqlite/files/sandbox-fix2.patch b/dev-db/sqlite/files/sandbox-fix2.patch
deleted file mode 100644
index cf051c427d1f..000000000000
--- a/dev-db/sqlite/files/sandbox-fix2.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- test/attach3.test~ 2005-03-29 05:11:00.000000000 +0200
-+++ test/attach3.test 2006-02-05 19:30:45.000000000 +0100
-@@ -226,11 +226,6 @@
- # Failure to attach leaves us in a workable state.
- # Ticket #811
- #
--do_test attach3-11.0 {
-- catchsql {
-- ATTACH DATABASE '/nodir/nofile.x' AS notadb;
-- }
--} {1 {unable to open database: /nodir/nofile.x}}
- do_test attach3-11.1 {
- catchsql {
- ATTACH DATABASE ':memory:' AS notadb;
diff --git a/dev-db/sqlite/sqlite-3.6.22-r2.ebuild b/dev-db/sqlite/sqlite-3.6.22-r2.ebuild
deleted file mode 100644
index 1c71b498a19b..000000000000
--- a/dev-db/sqlite/sqlite-3.6.22-r2.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.22-r2.ebuild,v 1.6 2010/03/14 16:47:43 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib versionator autotools
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl +threadsafe test"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- if use tcl || use test; then
- epatch "${FILESDIR}"/${P}-interix-fixes.patch
- epatch "${FILESDIR}"/${P}-dlopen.patch # bug 300836
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}"/${P}-interix-fixes-amalgamation.patch
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # We need to use secure-delete for firefox/thunderbird/xulrunner
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE=1 -DSQLITE_CHECK_PAGES=1 -DSQLITE_CORE=1
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if use debug; then
- append-cppflags -DSQLITE_DEBUG=1
- else
- append-cppflags -DNDEBUG
- fi
-
- local extensions_option
- if use tcl || use test; then
- extensions_option="load-extension"
- else
- extensions_option="dynamic-extensions"
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $({ use tcl || use test; } && echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.6.23.1-r1.ebuild b/dev-db/sqlite/sqlite-3.6.23.1-r1.ebuild
deleted file mode 100644
index 42c088d5a4cc..000000000000
--- a/dev-db/sqlite/sqlite-3.6.23.1-r1.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.1-r1.ebuild,v 1.2 2010/06/26 15:46:38 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- if use tcl || use test; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch" # bug 300836
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
-
- # Enable unlock notification
- if use unlock-notify; then
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
- fi
-
- local extensions_option
- if use tcl || use test; then
- extensions_option="load-extension"
- else
- extensions_option="dynamic-extensions"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]] ; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $({ use tcl || use test; } && echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.6.23.1.ebuild b/dev-db/sqlite/sqlite-3.6.23.1.ebuild
deleted file mode 100644
index 5d7cec7de1bd..000000000000
--- a/dev-db/sqlite/sqlite-3.6.23.1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.23.1.ebuild,v 1.9 2010/09/06 21:01:39 ranger Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl +threadsafe test"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- if use tcl || use test; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch" # bug 300836
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
-
- local extensions_option
- if use tcl || use test; then
- extensions_option="load-extension"
- else
- extensions_option="dynamic-extensions"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]] ; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $({ use tcl || use test; } && echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.7.0.ebuild b/dev-db/sqlite/sqlite-3.7.0.ebuild
deleted file mode 100644
index 7fe13060df1e..000000000000
--- a/dev-db/sqlite/sqlite-3.7.0.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.0.ebuild,v 1.1 2010/07/23 19:40:05 arfrever Exp $
-
-EAPI="3"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-
-SRC_URI="
- tcl? ( http://www.sqlite.org/${P}.tar.gz )
- !tcl? (
- test? ( http://www.sqlite.org/${P}.tar.gz )
- !test? ( http://www.sqlite.org/${PN}-amalgamation-${PV}.tar.gz )
- )
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- test? ( dev-lang/tcl )
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- if use tcl || use test; then
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes.patch"
- epatch "${FILESDIR}/${PN}-3.6.22-dlopen.patch" # bug 300836
- eautoreconf # dlopen.patch patches configure.ac
- else
- epatch "${FILESDIR}/${PN}-3.6.22-interix-fixes-amalgamation.patch"
- fi
-
- eautoreconf # for MiNT and interix
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if use tcl || use test; then
- # Normal tarball.
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- # Amalgamation tarball.
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Support FTS3, bug #207701
- if use fts3; then
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
- fi
-
- # Enable secure_delete pragma by default
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Support soundex, bug #143794
- if use soundex; then
- append-cppflags -DSQLITE_SOUNDEX
- fi
-
- # The amalgamation source doesn't have these via Makefile
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
-
- # Enable unlock notification
- if use unlock-notify; then
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
- fi
-
- local extensions_option
- if use tcl || use test; then
- extensions_option="load-extension"
- else
- extensions_option="dynamic-extensions"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]] ; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE=0
- fi
-
- # `configure` from amalgamation tarball doesn't support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $({ use tcl || use test; } && echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(use_enable threadsafe) \
- $(use tcl && echo --enable-tcl) \
- $(use !tcl && use test && echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test="test"
- use debug && test="fulltest"
- emake ${test} || die "Some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}