summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-10 14:00:00 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-10 14:00:00 +0000
commit91cc9ff66c7ed16569bcf6055604c2f71c03811d (patch)
tree58f6cd4faff5e9b867071d23349acd524df1079b /dev-db/sqlite
parentadded poedit (diff)
downloadgentoo-2-91cc9ff66c7ed16569bcf6055604c2f71c03811d.tar.gz
gentoo-2-91cc9ff66c7ed16569bcf6055604c2f71c03811d.tar.bz2
gentoo-2-91cc9ff66c7ed16569bcf6055604c2f71c03811d.zip
added tcl to deps and removed an old, left 2.0.8, not sure if it's ok to remove
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/digest-sqlite-2.1.3-r11
-rw-r--r--dev-db/sqlite/sqlite-2.1.3-r1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/digest-sqlite-2.1.3-r1 b/dev-db/sqlite/files/digest-sqlite-2.1.3-r1
new file mode 100644
index 000000000000..83e3fa51fb8f
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-2.1.3-r1
@@ -0,0 +1 @@
+MD5 d2661bb2c0832d7421ba4e737f0bf27b sqlite-2.1.3.tar.gz 614400
diff --git a/dev-db/sqlite/sqlite-2.1.3-r1.ebuild b/dev-db/sqlite/sqlite-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..03bfa920f926
--- /dev/null
+++ b/dev-db/sqlite/sqlite-2.1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.1.3-r1.ebuild,v 1.1 2002/01/10 14:00:00 hallski Exp $
+
+S=${WORKDIR}/sqlite
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.hwaci.com/sw/sqlite/${P}.tar.gz"
+HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
+
+DEPEND="virtual/glibc
+ dev-lang/tcl"
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc || die
+
+ emake || die
+ make doc || die
+}
+
+src_install () {
+
+ dodir /usr/{bin,include,lib}
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dobin lemon
+
+ dodoc README VERSION
+ docinto html
+ dodoc doc/*.html doc/*.txt doc/*.png
+}