summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-05 22:37:50 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-05 22:37:50 +0000
commit2e0c751c4b101ee842e5992105184de81e872073 (patch)
treed8d51deff3fc6a94bbd4c93458bc7553236ad219 /dev-db/sqlite
parentuse correct compiler wrt #450446 (diff)
downloadgentoo-2-2e0c751c4b101ee842e5992105184de81e872073.tar.gz
gentoo-2-2e0c751c4b101ee842e5992105184de81e872073.tar.bz2
gentoo-2-2e0c751c4b101ee842e5992105184de81e872073.zip
Add support for building static library, wrt bug #417907. Thanks to ari edelkind <edelkind-gentoo-bugzilla AT episec.com> for discovering this issue and providing patch
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/sqlite-3.7.15.1.ebuild8
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 876fbf179459..4048bf895d00 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.444 2013/01/01 19:02:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.445 2013/01/05 22:37:50 pinkbyte Exp $
+
+ 05 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> sqlite-3.7.15.1.ebuild:
+ Add support for building static library, wrt bug #417907. Thanks to ari
+ edelkind <edelkind-gentoo-bugzilla AT episec.com> for discovering this issue
+ and providing patch
01 Jan 2013; Raúl Porcel <armin76@gentoo.org> sqlite-3.7.14.1.ebuild:
s390/sh stable wrt #446522
diff --git a/dev-db/sqlite/sqlite-3.7.15.1.ebuild b/dev-db/sqlite/sqlite-3.7.15.1.ebuild
index 978ee0244b4f..53e4fb34b1f9 100644
--- a/dev-db/sqlite/sqlite-3.7.15.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.7.15.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.15.1.ebuild,v 1.1 2012/12/20 19:26:14 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.15.1.ebuild,v 1.2 2013/01/05 22:37:50 pinkbyte Exp $
EAPI="5"
@@ -22,7 +22,7 @@ SRC_URI="doc? ( http://sqlite.org/${PN}-doc-${DOC_PV}.zip )
LICENSE="public-domain"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc +extensions +fts3 icu +readline secure-delete soundex tcl test +threadsafe unlock-notify"
+IUSE="debug doc +extensions +fts3 icu +readline secure-delete soundex static-libs tcl test +threadsafe unlock-notify"
RDEPEND="icu? ( dev-libs/icu:= )
readline? ( sys-libs/readline )
@@ -123,9 +123,9 @@ src_configure() {
# `configure` from amalgamation tarball does not support
# --with-readline-inc and --(enable|disable)-tcl options.
econf \
- --disable-static \
$(use_enable extensions ${extensions_option}) \
$(use_enable readline) \
+ $(use_enable static-libs static) \
$(use_enable threadsafe) \
$(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
$(amalgamation || use_enable debug) \