summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-08-10 22:47:31 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2011-08-10 22:47:31 +0000
commitf6b02b2f5dc4af79dfa0322f6167fe54d2c7da5a (patch)
tree6f939e44e12bb39b76984b2a5b3c1dd77ce0aba8 /dev-db/slony1
parentTests fail without dbus session bus, restricted, bug 378101 (diff)
downloadgentoo-2-f6b02b2f5dc4af79dfa0322f6167fe54d2c7da5a.tar.gz
gentoo-2-f6b02b2f5dc4af79dfa0322f6167fe54d2c7da5a.tar.bz2
gentoo-2-f6b02b2f5dc4af79dfa0322f6167fe54d2c7da5a.zip
Fix LDFLAGS not being respected
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/ChangeLog8
-rw-r--r--dev-db/slony1/files/ldflags.patch29
-rw-r--r--dev-db/slony1/slony1-2.0.7-r1.ebuild74
3 files changed, 110 insertions, 1 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index e65c3425a14c..74706ad00d4c 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/slony1
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.24 2011/08/08 09:38:04 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.25 2011/08/10 22:47:31 titanofold Exp $
+
+*slony1-2.0.7-r1 (10 Aug 2011)
+
+ 10 Aug 2011; Aaron W. Swenson <titanofold@gentoo.org>
+ +slony1-2.0.7-r1.ebuild, +files/ldflags.patch:
+ Fix LDFLAGS not being respected
*slony1-2.0.7 (08 Aug 2011)
diff --git a/dev-db/slony1/files/ldflags.patch b/dev-db/slony1/files/ldflags.patch
new file mode 100644
index 000000000000..3aa486f10062
--- /dev/null
+++ b/dev-db/slony1/files/ldflags.patch
@@ -0,0 +1,29 @@
+diff -Naur a/Makefile.global.in b/Makefile.global.in
+--- a/Makefile.global.in 2011-07-11 17:19:57.000000000 -0400
++++ b/Makefile.global.in 2011-08-08 18:28:58.654658951 -0400
+@@ -85,7 +85,7 @@
+ subdir=$(slony_subdir)
+
+ override CPPFLAGS := -I${pgincludedir} -I${pgincludeserverdir} $(CPPFLAGS)
+-LDFLAGS = -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
++override LDFLAGS += -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
+
+ ifeq ($(GCC), yes)
+ CFLAGS += -Wall -Wmissing-prototypes -Wmissing-declarations
+diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+--- a/makefiles/Makefile.linux 2011-07-11 17:19:57.000000000 -0400
++++ b/makefiles/Makefile.linux 2011-08-09 07:52:47.071130982 -0400
+@@ -12,9 +12,9 @@
+ endif
+
+ %.so: %.o
+- $(CC) -shared -o $@ $<
++ $(CC) $(LDFLAGS) -shared -o $@ $<
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
+
+-sqlmansect = 7
+\ No newline at end of file
++sqlmansect = 7
diff --git a/dev-db/slony1/slony1-2.0.7-r1.ebuild b/dev-db/slony1/slony1-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..b7efa3af25cc
--- /dev/null
+++ b/dev-db/slony1/slony1-2.0.7-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.0.7-r1.ebuild,v 1.1 2011/08/10 22:47:31 titanofold Exp $
+
+EAPI="4"
+
+inherit eutils
+
+IUSE="doc perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+
+# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
+SRC_URI="http://main.slony.info/downloads/2.0/source/${P}.tar.bz2
+ http://main.slony.info/downloads/2.0/source/${P}-docs.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="|| (
+ dev-db/postgresql-base:9.0[threads]
+ dev-db/postgresql-base:8.4[threads]
+ dev-db/postgresql-base:8.3[threads]
+ dev-db/postgresql-base:9.1[threads]
+ )
+ || (
+ dev-db/postgresql-server:9.0
+ dev-db/postgresql-server:8.4
+ dev-db/postgresql-server:8.3
+ dev-db/postgresql-server:9.1
+ )
+ perl? ( dev-perl/DBD-Pg )
+"
+
+pkg_setup() {
+ local PGSLOT="$(postgresql-config show)"
+ if [[ ${PGSLOT//.} < 83 ]] ; then
+ eerror "You must build ${CATEGORY}/${PN} against PostgreSQL 8.3 or higher."
+ eerror "Set an appropriate slot with postgresql-config."
+ die "postgresql-config not set to 8.3 or higher."
+ fi
+
+ if [[ ${PGSLOT//.} > 90 ]] ; then
+ ewarn "You are building ${CATEGORY}/${PN} against a version of PostgreSQL greater than 9.0."
+ ewarn "This is neither supported here nor upstream."
+ ewarn "Any bugs you encounter should be reported upstream."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/ldflags.patch"
+}
+
+src_configure() {
+ econf $(use_with perl perltools)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+
+ doman "${S}"/doc/adminguide/man{1,7}/*
+
+ if use doc ; then
+ cd "${S}"/doc
+ dohtml -r *
+ fi
+
+ newinitd "${FILESDIR}"/slony1.init slony1
+ newconfd "${FILESDIR}"/slony1.conf slony1
+}