summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-17 05:26:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-17 05:26:17 +0000
commitf3f943f7845f60fde3cc357da7fab66399f664ec (patch)
tree254feca533ea81082d9b6692ccc6fc1c4074591d /dev-db/slony1
parentBump (diff)
downloadgentoo-2-f3f943f7845f60fde3cc357da7fab66399f664ec.tar.gz
gentoo-2-f3f943f7845f60fde3cc357da7fab66399f664ec.tar.bz2
gentoo-2-f3f943f7845f60fde3cc357da7fab66399f664ec.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/ChangeLog8
-rw-r--r--dev-db/slony1/slony1-2.1.3.ebuild73
2 files changed, 79 insertions, 2 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index bc79a70bfbc2..6a10c17bb775 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/slony1
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.38 2013/01/12 21:37:19 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.39 2013/03/17 05:26:17 patrick Exp $
+
+*slony1-2.1.3 (17 Mar 2013)
+
+ 17 Mar 2013; Patrick Lauer <patrick@gentoo.org> +slony1-2.1.3.ebuild:
+ Bump
*slony1-2.1.2 (12 Jan 2013)
@@ -169,4 +174,3 @@
+files/slony1_remove_jave.patch, +files/slony1.conf, +files/slony1.init,
+metadata.xml, +slony1-1.1.0_beta4.ebuild:
Initial import.
-
diff --git a/dev-db/slony1/slony1-2.1.3.ebuild b/dev-db/slony1/slony1-2.1.3.ebuild
new file mode 100644
index 000000000000..5b1793983925
--- /dev/null
+++ b/dev-db/slony1/slony1-2.1.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.1.3.ebuild,v 1.1 2013/03/17 05:26:17 patrick Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+IUSE="doc perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+
+# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
+MAJ_PV=$(get_version_component_range 1-2)
+SRC_URI="http://main.slony.info/downloads/${MAJ_PV}/source/${P}.tar.bz2
+ http://main.slony.info/downloads/${MAJ_PV}/source/${P}-docs.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="|| (
+ dev-db/postgresql-server:9.2
+ dev-db/postgresql-server:9.1
+ dev-db/postgresql-server:9.0
+ dev-db/postgresql-server:8.4
+ dev-db/postgresql-server:8.3
+ )
+ dev-db/postgresql-base[threads]
+ perl? ( dev-perl/DBD-Pg )
+"
+
+pkg_setup() {
+ local PGSLOT="$(postgresql-config show)"
+ if [[ ${PGSLOT//.} < 83 ]] ; then
+ eerror "You must build ${CATEGORY}/${PN} against PostgreSQL 8.3 or higher."
+ eerror "Set an appropriate slot with postgresql-config."
+ die "postgresql-config not set to 8.3 or higher."
+ fi
+
+# if [[ ${PGSLOT//.} > 90 ]] ; then
+# ewarn "You are building ${CATEGORY}/${PN} against a version of PostgreSQL greater than 9.0."
+# ewarn "This is neither supported here nor upstream."
+# ewarn "Any bugs you encounter should be reported upstream."
+# fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.1.2-ldflags.patch"
+}
+
+src_configure() {
+ local myconf
+ use perl && myconf='--with-perltools'
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+
+ doman "${S}"/doc/adminguide/man{1,7}/*
+
+ if use doc ; then
+ cd "${S}"/doc
+ dohtml -r *
+ fi
+
+ newinitd "${FILESDIR}"/slony1.init slony1
+ newconfd "${FILESDIR}"/slony1.conf slony1
+}