summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-06 09:28:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-06 09:28:17 +0000
commite66e6b53bd59545879d0bd50649afe382451e6c9 (patch)
treeebd8f64b73472f0a7a746f7b26be0fb1c5e2af83 /dev-db/slony1
parentdrop py2.6 add pypy support (diff)
downloadgentoo-2-e66e6b53bd59545879d0bd50649afe382451e6c9.tar.gz
gentoo-2-e66e6b53bd59545879d0bd50649afe382451e6c9.tar.bz2
gentoo-2-e66e6b53bd59545879d0bd50649afe382451e6c9.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/ChangeLog9
-rw-r--r--dev-db/slony1/slony1-2.2.2.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index 8c7e9a8d8019..4a8bcb90593e 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/slony1
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.47 2013/11/27 04:17:32 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.48 2014/05/06 09:28:17 patrick Exp $
+
+*slony1-2.2.2 (06 May 2014)
+
+ 06 May 2014; Patrick Lauer <patrick@gentoo.org> +slony1-2.2.2.ebuild:
+ Bump
*slony1-2.2.1 (27 Nov 2013)
diff --git a/dev-db/slony1/slony1-2.2.2.ebuild b/dev-db/slony1/slony1-2.2.2.ebuild
new file mode 100644
index 000000000000..f619b4377fa8
--- /dev/null
+++ b/dev-db/slony1/slony1-2.2.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.2.2.ebuild,v 1.1 2014/05/06 09:28:17 patrick Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+IUSE="doc perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+
+# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
+MAJ_PV=$(get_version_component_range 1-2)
+SRC_URI="http://main.slony.info/downloads/${MAJ_PV}/source/${P}.tar.bz2
+ http://main.slony.info/downloads/${MAJ_PV}/source/${P}-docs.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="|| (
+ dev-db/postgresql-server:9.3
+ dev-db/postgresql-server:9.2
+ dev-db/postgresql-server:9.1
+ dev-db/postgresql-server:9.0
+ dev-db/postgresql-server:8.4
+ dev-db/postgresql-server:8.3
+ )
+ dev-db/postgresql-base[threads]
+ perl? ( dev-perl/DBD-Pg )
+"
+
+pkg_setup() {
+ local PGSLOT="$(postgresql-config show)"
+ if [[ ${PGSLOT//.} < 83 ]] ; then
+ eerror "You must build ${CATEGORY}/${PN} against PostgreSQL 8.3 or higher."
+ eerror "Set an appropriate slot with postgresql-config."
+ die "postgresql-config not set to 8.3 or higher."
+ fi
+
+# if [[ ${PGSLOT//.} > 90 ]] ; then
+# ewarn "You are building ${CATEGORY}/${PN} against a version of PostgreSQL greater than 9.0."
+# ewarn "This is neither supported here nor upstream."
+# ewarn "Any bugs you encounter should be reported upstream."
+# fi
+}
+
+src_configure() {
+ local myconf
+ use perl && myconf='--with-perltools'
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc INSTALL README SAMPLE TODO UPGRADING share/slon.conf-sample
+
+ if use doc ; then
+ cd "${S}"/doc
+ dohtml -r *
+ fi
+
+ newinitd "${FILESDIR}"/slony1.init slony1
+ newconfd "${FILESDIR}"/slony1.conf slony1
+}