summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 16:18:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 16:18:30 +0000
commit67da60cb2a92febd71817b00a435d9953158febf (patch)
treef44b4200910370d172dc0566a39ec47f89ac9e72 /dev-db/pygresql
parentQA on ebuild style, specially shortend description (diff)
downloadgentoo-2-67da60cb2a92febd71817b00a435d9953158febf.tar.gz
gentoo-2-67da60cb2a92febd71817b00a435d9953158febf.tar.bz2
gentoo-2-67da60cb2a92febd71817b00a435d9953158febf.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS (bug #312141).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/pygresql')
-rw-r--r--dev-db/pygresql/ChangeLog6
-rw-r--r--dev-db/pygresql/pygresql-4.0.ebuild26
2 files changed, 20 insertions, 12 deletions
diff --git a/dev-db/pygresql/ChangeLog b/dev-db/pygresql/ChangeLog
index e59c25ef2847..abadebd5498a 100644
--- a/dev-db/pygresql/ChangeLog
+++ b/dev-db/pygresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/pygresql
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.49 2011/01/08 16:08:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.50 2011/01/08 16:18:30 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pygresql-4.0.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS (bug #312141).
08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pygresql-3.5.ebuild, pygresql-3.6.2.ebuild, pygresql-3.6.2-r1.ebuild,
diff --git a/dev-db/pygresql/pygresql-4.0.ebuild b/dev-db/pygresql/pygresql-4.0.ebuild
index 827226250257..7ae75ab1af93 100644
--- a/dev-db/pygresql/pygresql-4.0.ebuild
+++ b/dev-db/pygresql/pygresql-4.0.ebuild
@@ -1,35 +1,39 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-4.0.ebuild,v 1.3 2011/01/08 16:08:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-4.0.ebuild,v 1.4 2011/01/08 16:18:30 arfrever Exp $
EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit eutils distutils
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+inherit distutils
MY_P="PyGreSQL-${PV}"
DESCRIPTION="A Python interface for the PostgreSQL database."
-SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
HOMEPAGE="http://www.pygresql.org/"
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+
LICENSE="as-is"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
IUSE="doc"
DEPEND="dev-db/postgresql-base"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/*.txt"
+PYTHON_MODNAME="pg.py pgdb.py"
src_install() {
distutils_src_install
- dodoc docs/*.txt
-
- if use doc ; then
+ if use doc; then
insinto /usr/share/doc/${PF}/tutorial
- doins tutorial/*
- dohtml docs/*.{html,css}
+ doins tutorial/* || die "doins failed"
+ dohtml docs/*.{html,css} || die "dohtml failed"
fi
}