summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-09 21:40:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-09 21:40:31 +0000
commit5eff68bb0fc3d46cf82ae435dad176d0dc8223f3 (patch)
treef2bd28983a2e245b5d75367b881374cbc03be36e /dev-db/postgresql-base/files
parentCleaned and removed the eautoreconf since the Debian patch already applied it (diff)
downloadgentoo-2-5eff68bb0fc3d46cf82ae435dad176d0dc8223f3.tar.gz
gentoo-2-5eff68bb0fc3d46cf82ae435dad176d0dc8223f3.tar.bz2
gentoo-2-5eff68bb0fc3d46cf82ae435dad176d0dc8223f3.zip
Bump to 8.4.0. Fixes #276125
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/postgresql-base/files')
-rw-r--r--dev-db/postgresql-base/files/postgresql-8.4-base.patch142
-rw-r--r--dev-db/postgresql-base/files/postgresql-8.4-common.patch69
2 files changed, 211 insertions, 0 deletions
diff --git a/dev-db/postgresql-base/files/postgresql-8.4-base.patch b/dev-db/postgresql-base/files/postgresql-8.4-base.patch
new file mode 100644
index 000000000000..d2b51dd186db
--- /dev/null
+++ b/dev-db/postgresql-base/files/postgresql-8.4-base.patch
@@ -0,0 +1,142 @@
+diff -Naur postgresql-8.4.0.orig/contrib/Makefile postgresql-8.4.0/contrib/Makefile
+--- postgresql-8.4.0.orig/contrib/Makefile 2009-03-26 00:20:01.000000000 +0100
++++ postgresql-8.4.0/contrib/Makefile 2009-07-09 21:17:38.000000000 +0200
+@@ -5,46 +5,10 @@
+ include $(top_builddir)/src/Makefile.global
+
+ WANTED_DIRS = \
+- adminpack \
+- auto_explain \
+- btree_gin \
+- btree_gist \
+- chkpass \
+- citext \
+- cube \
+- dblink \
+- dict_int \
+- dict_xsyn \
+- earthdistance \
+- fuzzystrmatch \
+- hstore \
+- intagg \
+- intarray \
+- isn \
+- lo \
+- ltree \
+ oid2name \
+- pageinspect \
+- pg_buffercache \
+- pg_freespacemap \
+- pg_standby \
+- pg_stat_statements \
+- pg_trgm \
+ pgbench \
+- pgcrypto \
+- pgrowlocks \
+- pgstattuple \
+- seg \
+- spi \
+- tablefunc \
+- test_parser \
+- tsearch2 \
+ vacuumlo
+
+-ifeq ($(with_openssl),yes)
+-WANTED_DIRS += sslinfo
+-endif
+-
+ ifeq ($(with_ossp_uuid),yes)
+ WANTED_DIRS += uuid-ossp
+ endif
+diff -Naur postgresql-8.4.0.orig/src/backend/Makefile postgresql-8.4.0/src/backend/Makefile
+--- postgresql-8.4.0.orig/src/backend/Makefile 2009-01-01 18:23:34.000000000 +0100
++++ postgresql-8.4.0/src/backend/Makefile 2009-07-09 21:22:13.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ ##########################################################################
+
+-all: submake-libpgport postgres $(POSTGRES_IMP)
++all: someheaders
+
+ ifneq ($(PORTNAME), cygwin)
+ ifneq ($(PORTNAME), win32)
+@@ -105,7 +105,7 @@
+ endif # aix
+
+ # Update the commonly used headers before building the subdirectories
+-$(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
++someheaders $(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
+
+
+ # The postgres.o target is needed by the rule in Makefile.global that
+@@ -161,23 +161,7 @@
+
+ ##########################################################################
+
+-install: all installdirs install-bin
+-ifeq ($(PORTNAME), cygwin)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+-endif
+-endif
+-ifeq ($(PORTNAME), win32)
+-ifeq ($(MAKE_DLL), true)
+- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
+-endif
+-endif
+- $(MAKE) -C catalog install-data
+- $(MAKE) -C tsearch install-data
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
+- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample '$(DESTDIR)$(datadir)/recovery.conf.sample'
++install:
+
+ install-bin: postgres $(POSTGRES_IMP) installdirs
+ $(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
+diff -Naur postgresql-8.4.0.orig/src/bin/Makefile postgresql-8.4.0/src/bin/Makefile
+--- postgresql-8.4.0.orig/src/bin/Makefile 2009-01-01 18:23:53.000000000 +0100
++++ postgresql-8.4.0/src/bin/Makefile 2009-07-09 21:27:09.000000000 +0200
+@@ -13,8 +13,8 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-DIRS = initdb pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog
++DIRS = pg_dump \
++ psql scripts pg_config
+ ifeq ($(PORTNAME), win32)
+ DIRS+=pgevent
+ endif
+diff -Naur postgresql-8.4.0.orig/src/include/pg_config_manual.h postgresql-8.4.0/src/include/pg_config_manual.h
+--- postgresql-8.4.0.orig/src/include/pg_config_manual.h 2009-06-11 16:49:08.000000000 +0200
++++ postgresql-8.4.0/src/include/pg_config_manual.h 2009-07-09 21:27:44.000000000 +0200
+@@ -146,7 +146,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+diff -Naur postgresql-8.4.0.orig/src/Makefile postgresql-8.4.0/src/Makefile
+--- postgresql-8.4.0.orig/src/Makefile 2009-02-24 11:06:32.000000000 +0100
++++ postgresql-8.4.0/src/Makefile 2009-07-09 21:18:20.000000000 +0200
+@@ -15,16 +15,11 @@
+
+ all install installdirs uninstall distprep:
+ $(MAKE) -C port $@
+- $(MAKE) -C timezone $@
+ $(MAKE) -C backend $@
+- $(MAKE) -C backend/utils/mb/conversion_procs $@
+- $(MAKE) -C backend/snowball $@
+ $(MAKE) -C include $@
+ $(MAKE) -C interfaces $@
+ $(MAKE) -C bin $@
+- $(MAKE) -C pl $@
+ $(MAKE) -C makefiles $@
+- $(MAKE) -C test/regress $@
+
+ install: install-local
+
diff --git a/dev-db/postgresql-base/files/postgresql-8.4-common.patch b/dev-db/postgresql-base/files/postgresql-8.4-common.patch
new file mode 100644
index 000000000000..3ca9f6cd98c2
--- /dev/null
+++ b/dev-db/postgresql-base/files/postgresql-8.4-common.patch
@@ -0,0 +1,69 @@
+=== configure.in
+==================================================================
+--- configure.in 2009-06-27 02:14:47.000000000 +0200
++++ configure.in 2009-07-09 15:05:02.000000000 +0200
+@@ -19,10 +19,6 @@
+
+ AC_INIT([PostgreSQL], [8.4.0], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2009, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
+=== src/include/storage/s_lock.h
+==================================================================
+--- src/include/storage/s_lock.h 2009-01-01 18:24:01.000000000 +0100
++++ src/include/storage/s_lock.h 2009-07-09 15:03:08.000000000 +0200
+@@ -298,6 +298,29 @@
+
+ #endif /* __s390__ || __s390x__ */
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
+
+ #if defined(__sparc__) /* Sparc */
+ #define HAS_TEST_AND_SET
+=== src/makefiles/Makefile.darwin
+==================================================================
+--- src/makefiles/Makefile.darwin 2008-11-14 11:22:47.000000000 +0100
++++ src/makefiles/Makefile.darwin 2009-07-09 15:07:11.000000000 +0200
+@@ -5,7 +5,15 @@
+ CFLAGS_SL =
+
+ ifdef PGXS
++ifdef PGXS_IN_SERVER
++ifndef PGXS_WITH_SERVER
++BE_DLLLIBS= -bundle_loader $(top_builddir)/src/backend/postgres
++else
++BE_DLLLIBS= -bundle_loader ${PGXS_WITH_SERVER}
++endif
++else
+ BE_DLLLIBS= -bundle_loader $(bindir)/postgres
++endif
+ else
+ BE_DLLLIBS= -bundle_loader $(top_builddir)/src/backend/postgres
+ endif