summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-21 10:21:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-21 10:21:16 +0000
commit519fb6fafe26e3056d781361823fe3bbf2f2984b (patch)
treee3c1034960674f74938afab0f15ce56d27751bd7 /dev-db/postgis
parentFix for #304401, thanks to Aaron W. Swenson (diff)
downloadgentoo-2-519fb6fafe26e3056d781361823fe3bbf2f2984b.tar.gz
gentoo-2-519fb6fafe26e3056d781361823fe3bbf2f2984b.tar.bz2
gentoo-2-519fb6fafe26e3056d781361823fe3bbf2f2984b.zip
Bump for #304151, thanks to Michael Orlitzky for refining the deps
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/ChangeLog10
-rw-r--r--dev-db/postgis/postgis-1.4.0.ebuild11
-rw-r--r--dev-db/postgis/postgis-1.5.0.ebuild189
3 files changed, 203 insertions, 7 deletions
diff --git a/dev-db/postgis/ChangeLog b/dev-db/postgis/ChangeLog
index 7ea7b696fdf3..eaf6db92cef7 100644
--- a/dev-db/postgis/ChangeLog
+++ b/dev-db/postgis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgis
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/ChangeLog,v 1.41 2009/09/20 22:21:12 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/ChangeLog,v 1.42 2010/02/21 10:21:16 patrick Exp $
+
+*postgis-1.5.0 (21 Feb 2010)
+
+ 21 Feb 2010; Patrick Lauer <patrick@gentoo.org> postgis-1.4.0.ebuild,
+ +postgis-1.5.0.ebuild:
+ Bump for #304151, thanks to Michael Orlitzky for refining the deps
20 Sep 2009; Patrick Lauer <patrick@gentoo.org> postgis-1.4.0.ebuild:
Fixing deps, closes #285780
diff --git a/dev-db/postgis/postgis-1.4.0.ebuild b/dev-db/postgis/postgis-1.4.0.ebuild
index cecdb609a380..93f01d2206f3 100644
--- a/dev-db/postgis/postgis-1.4.0.ebuild
+++ b/dev-db/postgis/postgis-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-1.4.0.ebuild,v 1.2 2009/09/20 22:21:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-1.4.0.ebuild,v 1.3 2010/02/21 10:21:16 patrick Exp $
EAPI="1"
@@ -19,7 +19,8 @@ RDEPEND=">=virtual/postgresql-server-8.2
>=sci-libs/proj-4.5.0"
DEPEND="${RDEPEND}
- doc? ( app-text/docbook-xsl-stylesheets )"
+ doc? ( app-text/docbook-xsl-stylesheets
+ media-gfx/imagemagick )"
RESTRICT="test"
@@ -44,14 +45,14 @@ pkg_setup(){
src_compile(){
local myconf
if use doc; then
- myconf="${myconf} --with-xsl=$(ls "${ROOT}"usr/share/sgml/docbook/* | \
+ myconf="${myconf} --with-xsldir=$(ls "${ROOT}"usr/share/sgml/docbook/* | \
grep xsl\- | cut -d':' -f1)"
fi
econf --enable-autoconf \
--datadir=/usr/share/postgresql/contrib/ \
--libdir=/usr/$(get_libdir)/postgresql/ \
- --with-docdir=/usr/share/doc/${PF}/html/ \
+ --docdir=${D}/usr/share/doc/${PF}/html/ \
${myconf} ||\
die "Error: econf failed"
diff --git a/dev-db/postgis/postgis-1.5.0.ebuild b/dev-db/postgis/postgis-1.5.0.ebuild
new file mode 100644
index 000000000000..b4346ea89c2a
--- /dev/null
+++ b/dev-db/postgis/postgis-1.5.0.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-1.5.0.ebuild,v 1.1 2010/02/21 10:21:16 patrick Exp $
+
+EAPI="1"
+
+inherit eutils versionator
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="http://postgis.refractions.net"
+SRC_URI="http://postgis.refractions.net/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=">=virtual/postgresql-server-8.3
+ >=sci-libs/geos-3.2
+ >=sci-libs/proj-4.6.0
+ dev-libs/libxml2"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-xsl-stylesheets
+ media-gfx/imagemagick )"
+
+RESTRICT="test"
+
+pkg_setup(){
+ if [ ! -z "${PGUSER}" ]; then
+ eval unset PGUSER
+ fi
+ if [ ! -z "${PGDATABASE}" ]; then
+ eval unset PGDATABASE
+ fi
+ local tmp
+ tmp="$(portageq match / ${CATEGORY}/${PN} | cut -d'.' -f2)"
+ if [ "${tmp}" != "$(get_version_component_range 2)" ]; then
+ elog "You must soft upgrade your existing postgis enabled databases"
+ elog "by adding their names in the ${ROOT}conf.d/postgis_dbs file"
+ elog "then using 'emerge --config postgis'."
+ require_soft_upgrade="1"
+ ebeep 2
+ fi
+}
+
+src_compile(){
+ local myconf
+ if use doc; then
+ myconf="${myconf} --with-xsldir=$(ls "${ROOT}"usr/share/sgml/docbook/* | \
+ grep xsl\- | cut -d':' -f1)"
+ fi
+
+ econf --enable-autoconf \
+ --datadir=/usr/share/postgresql/contrib/ \
+ --libdir=/usr/$(get_libdir)/postgresql/ \
+ --docdir=${D}/usr/share/doc/${PF}/html/ \
+ ${myconf} ||\
+ die "Error: econf failed"
+
+ emake -j1 || die "Error: emake failed"
+
+ cd topology/
+ emake -j1 || die "Unable to build topology sql file"
+
+ if use doc ; then
+ cd "${S}"
+ emake -j1 docs || die "Unable to build documentation"
+ fi
+}
+
+src_install(){
+ dodir /usr/$(get_libdir)/postgresql /usr/share/postgresql/contrib/
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}/topology/"
+ emake DESTDIR="${D}" install || die "emake install topology failed"
+
+ cd "${S}"
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+ dobin ./utils/postgis_restore.pl
+
+ cd "${S}"
+ if use doc; then
+ emake DESTDIR="${D}" docs-install || die "emake install docs failed"
+ fi
+
+ echo "template_gis" > postgis_dbs
+ doconfd postgis_dbs
+
+ if [ ! -z "${require_soft_upgrade}" ]; then
+ grep "'C'" -B 4 "${D}"usr/share/postgresql/contrib/lwpostgis.sql | \
+ grep -v "'sql'" > \
+ "${D}"usr/share/postgresql/contrib/load_before_upgrade.sql
+ fi
+}
+
+pkg_postinst() {
+ elog "To create new (upgrade) spatial databases add their names in the"
+ elog "${ROOT}conf.d/postgis_dbs file, then use 'emerge --config postgis'."
+}
+
+pkg_config(){
+ einfo "Create or upgrade a spatial templates and databases."
+ einfo "Please add your databases names into ${ROOT}conf.d/postgis_dbs"
+ einfo "(templates name have to be prefixed with 'template')."
+ for i in $(cat "${ROOT}etc/conf.d/postgis_dbs"); do
+ source "${ROOT}"etc/conf.d/postgresql
+ PGDATABASE=${i}
+ eval set PGDATABASE=${i}
+ myuser="${PGUSER:-postgres}"
+ mydb="${PGDATABASE:-template_gis}"
+ eval set PGUSER=${myuser}
+
+ is_template=false
+ if [ "${mydb:0:8}" == "template" ];then
+ is_template=true
+ mytype="template database"
+ else
+ mytype="database"
+ fi
+
+ einfo
+ einfo "Using the user ${myuser} and the ${mydb} ${mytype}."
+
+ logfile=$(mktemp "${ROOT}tmp/error.log.XXXXXX")
+ safe_exit(){
+ eerror "Removing created ${mydb} ${mytype}"
+ dropdb -q -U "${myuser}" "${mydb}" ||\
+ (eerror "${1}"
+ die "Removing old db failed, you must do it manually")
+ eerror "Please read ${logfile} for more information."
+ die "${1}"
+ }
+
+ # if there is not a table or a template existing with the same name, create.
+ if [ -z "$(psql -U ${myuser} -l | grep "${mydb}")" ]; then
+ createdb -q -O ${myuser} -U ${myuser} ${mydb} ||\
+ die "Unable to create the ${mydb} ${mytype} as ${myuser}"
+ createlang -U ${myuser} plpgsql ${mydb}
+ if [ "$?" == 2 ]; then
+ safe_exit "Unable to createlang plpgsql ${mydb}."
+ fi
+ (psql -q -U ${myuser} ${mydb} -f \
+ "${ROOT}"usr/share/postgresql/contrib/lwpostgis.sql &&
+ psql -q -U ${myuser} ${mydb} -f \
+ "${ROOT}"usr/share/postgresql/contrib/spatial_ref_sys.sql) 2>\
+ "${logfile}"
+ if [ "$(grep -c ERROR "${logfile}")" \> 0 ]; then
+ safe_exit "Unable to load sql files."
+ fi
+ if ${is_template}; then
+ psql -q -U ${myuser} ${mydb} -c \
+ "UPDATE pg_database SET datistemplate = TRUE
+ WHERE datname = '${mydb}';
+ GRANT ALL ON table spatial_ref_sys, geometry_columns TO PUBLIC;" \
+ || die "Unable to create ${mydb}"
+ psql -q -U ${myuser} ${mydb} -c \
+ "VACUUM FREEZE;" || die "Unable to set VACUUM FREEZE option"
+ fi
+ else
+ if [ -e "${ROOT}"usr/share/postgresql/contrib/load_before_upgrade.sql ];
+ then
+ einfo "Updating the dynamic library references"
+ psql -q -f \
+ "${ROOT}"usr/share/postgresql/contrib/load_before_upgrade.sql\
+ 2> "${logfile}"
+ if [ "$(grep -c ERROR "${logfile}")" \> 0 ]; then
+ safe_exit "Unable to update references."
+ fi
+ fi
+ if [ -e "${ROOT}"usr/share/postgresql/contrib/lwpostgis_upgrade.sql ];
+ then
+ einfo "Running soft upgrade"
+ psql -q -U ${myuser} ${mydb} -f \
+ "${ROOT}"usr/share/postgresql/contrib/lwpostgis_upgrade.sql 2>\
+ "${logfile}"
+ if [ "$(grep -c ERROR "${logfile}")" \> 0 ]; then
+ safe_exit "Unable to run soft upgrade."
+ fi
+ fi
+ fi
+ if ${is_template}; then
+ einfo "You can now create a spatial database using :"
+ einfo "'createdb -T ${mydb} test'"
+ fi
+ done
+}