summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-01-06 06:18:19 +0000
committerTim Harder <radhermit@gentoo.org>2011-01-06 06:18:19 +0000
commitfdffc0c18cb9be43644bf752fdd9ac3c4239b298 (patch)
treee771dc0a4fc1bbefe288cc4c0dca99190a760cef /dev-db/phppgadmin
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-fdffc0c18cb9be43644bf752fdd9ac3c4239b298.tar.gz
gentoo-2-fdffc0c18cb9be43644bf752fdd9ac3c4239b298.tar.bz2
gentoo-2-fdffc0c18cb9be43644bf752fdd9ac3c4239b298.zip
Version bump for bug #349183. Bump to EAPI 3, explicitly set DEPEND, remove unnecessary pkg_setup phase, and don't install the LICENSE file.
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/ChangeLog10
-rw-r--r--dev-db/phppgadmin/phppgadmin-5.0.2.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-db/phppgadmin/ChangeLog b/dev-db/phppgadmin/ChangeLog
index 73be3af5e1d4..b37fc5606005 100644
--- a/dev-db/phppgadmin/ChangeLog
+++ b/dev-db/phppgadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/phppgadmin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.89 2010/11/05 04:24:45 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.90 2011/01/06 06:18:19 radhermit Exp $
+
+*phppgadmin-5.0.2 (06 Jan 2011)
+
+ 06 Jan 2011; Tim Harder <radhermit@gentoo.org> +phppgadmin-5.0.2.ebuild:
+ Version bump for bug #349183. Bump to EAPI 3, explicitly set DEPEND, remove
+ unnecessary pkg_setup phase, and don't install the LICENSE file.
05 Nov 2010; Jeroen Roovers <jer@gentoo.org> phppgadmin-4.2.3.ebuild:
Stable for HPPA (bug #336869).
diff --git a/dev-db/phppgadmin/phppgadmin-5.0.2.ebuild b/dev-db/phppgadmin/phppgadmin-5.0.2.ebuild
new file mode 100644
index 000000000000..988b3c3d1925
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-5.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-5.0.2.ebuild,v 1.1 2011/01/06 06:18:19 radhermit Exp $
+
+EAPI="3"
+
+inherit webapp
+
+MY_P=phpPgAdmin-${PV}
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[postgres,session]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}