summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-05-09 10:12:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-05-09 10:12:14 +0000
commit5c74311199a6d84a603252a46302302c6b1036b4 (patch)
treeffc5c886645a93b899d3f1c733da0028dff1db9d /dev-db/phppgadmin
parentRemove p.mask for dev-libs/dv* since removed. (diff)
downloadgentoo-2-5c74311199a6d84a603252a46302302c6b1036b4.tar.gz
gentoo-2-5c74311199a6d84a603252a46302302c6b1036b4.tar.bz2
gentoo-2-5c74311199a6d84a603252a46302302c6b1036b4.zip
Version bump (bug #467972).
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/ChangeLog9
-rw-r--r--dev-db/phppgadmin/phppgadmin-5.1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-db/phppgadmin/ChangeLog b/dev-db/phppgadmin/ChangeLog
index 4e47162156a9..d45ed4d0b938 100644
--- a/dev-db/phppgadmin/ChangeLog
+++ b/dev-db/phppgadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phppgadmin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.108 2012/10/17 22:32:59 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.109 2013/05/09 10:12:14 dev-zero Exp $
+
+*phppgadmin-5.1 (09 May 2013)
+
+ 09 May 2013; Tiziano Müller <dev-zero@gentoo.org> +phppgadmin-5.1.ebuild:
+ Version bump (bug #467972).
17 Oct 2012; <naota@gentoo.org> phppgadmin-5.0.4.ebuild:
Add ~x86-fbsd. #198321
diff --git a/dev-db/phppgadmin/phppgadmin-5.1.ebuild b/dev-db/phppgadmin/phppgadmin-5.1.ebuild
new file mode 100644
index 000000000000..d928b7e1acf4
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-5.1.ebuild,v 1.1 2013/05/09 10:12:14 dev-zero Exp $
+
+EAPI="4"
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/php[postgres,session]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}