summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-04-30 22:01:38 +0000
committerMatti Bickel <mabi@gentoo.org>2010-04-30 22:01:38 +0000
commit0270e1a3578332331047ea12dc0762b49bd19067 (patch)
treebf566863df5c98200c34ac8d8174f7654288a51c /dev-db/phppgadmin
parentVersion bump, bug #314803. Thanks to dev-zero for the strigi work. (diff)
downloadgentoo-2-0270e1a3578332331047ea12dc0762b49bd19067.tar.gz
gentoo-2-0270e1a3578332331047ea12dc0762b49bd19067.tar.bz2
gentoo-2-0270e1a3578332331047ea12dc0762b49bd19067.zip
version bump from the php-experimental overlay
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/ChangeLog8
-rw-r--r--dev-db/phppgadmin/phppgadmin-4.2.3.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-db/phppgadmin/ChangeLog b/dev-db/phppgadmin/ChangeLog
index 908ecdbdb695..3c1b5b243109 100644
--- a/dev-db/phppgadmin/ChangeLog
+++ b/dev-db/phppgadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/phppgadmin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.83 2010/02/21 17:38:21 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.84 2010/04/30 22:01:38 mabi Exp $
+
+*phppgadmin-4.2.3 (30 Apr 2010)
+
+ 30 Apr 2010; <mabi@gentoo.org> +phppgadmin-4.2.3.ebuild:
+ version bump from the php-experimental overlay (thanks to Tsisaruk V
+ <tsisaruk.v@gmail.com>)
*phppgadmin-9999 (21 Feb 2010)
diff --git a/dev-db/phppgadmin/phppgadmin-4.2.3.ebuild b/dev-db/phppgadmin/phppgadmin-4.2.3.ebuild
new file mode 100644
index 000000000000..a9434b5ec648
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-4.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-4.2.3.ebuild,v 1.1 2010/04/30 22:01:38 mabi Exp $
+
+EAPI="2"
+inherit webapp depend.php
+
+IUSE=""
+
+MY_P=phpPgAdmin-${PV}
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ dev-lang/php[postgres,session]
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}