summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-05 08:41:51 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-05 08:41:51 +0000
commitf9651cb00fd92961a98f1855472a088e64fba8d6 (patch)
treea0ad4a1ac0b6f3db210ca49a07c7f5b8e945a397 /dev-db/pgxnclient
parentFix bug #515552 - Bump android studio to 0.8.1.135.1248636, thanks to C.J. Wi... (diff)
downloadgentoo-2-f9651cb00fd92961a98f1855472a088e64fba8d6.tar.gz
gentoo-2-f9651cb00fd92961a98f1855472a088e64fba8d6.tar.bz2
gentoo-2-f9651cb00fd92961a98f1855472a088e64fba8d6.zip
revbump; conversion -> distutils-r1, add missing dep setuptools, add test phase, remove old, fixes Bug 515020
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-db/pgxnclient')
-rw-r--r--dev-db/pgxnclient/ChangeLog11
-rw-r--r--dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild (renamed from dev-db/pgxnclient/pgxnclient-1.2.ebuild)22
2 files changed, 24 insertions, 9 deletions
diff --git a/dev-db/pgxnclient/ChangeLog b/dev-db/pgxnclient/ChangeLog
index fb005e948a97..37d13b5df185 100644
--- a/dev-db/pgxnclient/ChangeLog
+++ b/dev-db/pgxnclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/pgxnclient
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgxnclient/ChangeLog,v 1.1 2013/01/17 07:36:31 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgxnclient/ChangeLog,v 1.2 2014/07/05 08:41:51 idella4 Exp $
+
+*pgxnclient-1.2-r1 (05 Jul 2014)
+
+ 05 Jul 2014; Ian Delaney <idella4@gentoo.org> +pgxnclient-1.2-r1.ebuild,
+ -pgxnclient-1.2.ebuild:
+ revbump; conversion -> distutils-r1, add missing dep setuptools, add test
+ phase, remove old, fixes Bug 515020
*pgxnclient-1.2 (17 Jan 2013)
diff --git a/dev-db/pgxnclient/pgxnclient-1.2.ebuild b/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
index a4b6c00ef882..320eca8f892e 100644
--- a/dev-db/pgxnclient/pgxnclient-1.2.ebuild
+++ b/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgxnclient/pgxnclient-1.2.ebuild,v 1.1 2013/01/17 07:36:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild,v 1.1 2014/07/05 08:41:51 idella4 Exp $
EAPI="5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-* *-jython"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils eutils
+inherit distutils-r1
DESCRIPTION="PostgreSQL Extension Network Client"
HOMEPAGE="http://pgxnclient.projects.postgresql.org/ http://pypi.python.org/pypi/${PN}"
@@ -16,7 +15,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="test"
RDEPEND=">=dev-db/postgresql-server-9.1"
-DEPEND="${RDEPEND}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # suite written onlt for py2
+ pushd ${PN} > /dev/null
+ if ! python_is_python3; then
+ PYTHONPATH=../ "${PYTHON}" -m unittest discover || die "tests failed"
+ fi
+ popd > dev/null
+}